Está en la página 1de 2

Proceso parcial Dimension Dimension Dimension Dimension Dimension Dimension s1[5]; s2[5]; s3[5]; s4[5]; s5[5]; s6[5];

Escribir "Digite numero a sumar en la lista 1" ; Para x<-1 Hasta 5 Con Paso 1 Hacer Leer s1[x]; FinPara Escribir "Digite numero a sumar en la lista 2" ; Para x<-1 Hasta 5 Con Paso 1 Hacer Leer s2[x]; FinPara Escribir "Digite numero a sumar en la lista 3"; Para x<-1 Hasta 5 Con Paso 1 Hacer Leer s3[x]; FinPara Escribir "Digite numero a sumar en la lista 4" ; Para x<-1 Hasta 5 Con Paso 1 Hacer Leer s4[x]; FinPara Escribir "Digite numero a sumar en la lista 5 " ; Para x<-1 Hasta 5 Con Paso 1 Hacer Leer s5[x]; FinPara k<-0; p<-0; e<-0; w<-0; z<-0; Para x<-1 Hasta 5 Con Paso 1 Hacer k <- k+s1[x]; p<- p+s2[x]; e<- e+s3[x]; z<- z+s4[x]; w<- w+s5[x]; FinPara Escribir "la suma lista 1 es ", k; Escribir "la suma lista 2 es ", p; Escribir "la suma lista 3 es ", e;

Escribir "la suma lista 4 es ", z; Escribir "la suma lista 5 es ", w; s6[1]<-k; s6[2]<-p; s6[3]<-e; s6[4]<-z; s6[5]<-w; aux <- 0; Para i<-1 Hasta 5 Con Paso 1 Hacer Para x<-1 Hasta 4 Con Paso 1 Hacer Si s6[x]>s6[x+1] Entonces aux<-s6[x]; s6[x]<-s6[x+1]; s6[x+1]<-aux; FinSi FinPara FinPara Escribir "Vector ordenado"; Para i<-1 Hasta 5 Con Paso 1 Hacer Escribir s6[i]; FinPara FinProceso