Está en la página 1de 20

Comandos para Mikrotik

Ingresamos a la consola de Mikrotik. Y si es desde Windows, vamos a inicio, en, ejecutar y escribimos telnet://192.168.0.1 o tambien puedes darle un click aqui telnet://192.168.0.1 nos pide nombre de usuario y password [admin@Mikrotik]> se abrir en esta forma la consola y ah ejecutaremos nuestras ordenes. Presionar la tecla TAB dos veces, podemos ver el listado de opciones principales: ]> ip address > ]>pr Para ver los IP en nuestro mikrotik De esto rescatamos el comando PRINT, que lo que hace es mostrar los datos, listar configuraciones, es este caso las configuraciones IP. Podemos ver en el resultado del comando bajo la columna del signo # a los numeros que se denominan ID's y sirven para identificar a cada entrada, al lado del "1" vemos una "X" que quiere decir que esa IP esta configurada pero Deshabilitada: Flags: X - disabled, I - invalid, D - dynamic. ]> ip proxy para configurar el proxy, para ver las opciones presionamos la tecla Tab

]> ip luego presionamos la tecla tab , nos dar: acounting dhcp-client dns ipsec pool service traffi-flow address dhcp-relay firewall neighbor proxy socks upnp arp dhcp-server hotspot packing route tftp export

] > ? nos da las opciones que hay. ] > print muestra lo que hay ] > pr igual que print ] > quit sale del login ] > / regresa a su origen o raz ] > .. Para retroceder un directorio ] > redo este comando sirve para deshacer una alteracin ] > undo para visualizar lo histrico

] > system shutdown apagaga el systema ] > sytem reboot reinicia el systema

] > interface para ver las interfaces instaladas ] >ping para hacer consulta de red ] >setup para hacer una configuracin bsica del sistema, configurar IP , gateway , entre otros, ] > password para cambiar la contrasea ] > user add Para agregar un usuario , (full) permisos totales de administracin, (read)permisos de solo lectura, (write)permisos limitados de escritura. ] >user cambia al directorio de usuarios , para ver los usuarios escribimos print Nombre del sistema Aqu se muestra el ejemplo de configuracin del nombre del sistema: ] /system identity> set name="UGEL Acomayo - Acomayo Cusco"

Seguridad WPA/2 Aqu se muestra el ejemplo de configuracin de la seguridad WPA/2: [admin@MikroTik] /interface wireless security-profiles> add name=willay authentication-types=wpa2-psk,wpa-psk eapmethods= passthrough group-ciphers=aes-ccm mode=dynamic-keys unicast-ciphers=aes-ccm wpa2-pre-shared-key=XXXXXXXXXXXX wpapreshared-key=XXXXXXXXXXXX En cada punto de la red se configura la seguridad en la capa de enlace WPA y WPA2. Como no se usan certificaciones TLS para la autentificacin, el eap-method se configura como passthrough, lo que significa que se confa el proceso de identificacin en el servidor RADIUS si ste existe. Tanto los datos unicast como broadcast usan el protocolo aes-ccm para encriptar, el cual es mucho ms seguro que tkip. El modo en dynamic-

] /interface wireless> set wlan1 acktimeout= dynamic antenna-mode=ant-a band=5ghz basic-ratesa/ g=6Mbps disabled=no disable-running-check=yes frequency=5745 mode=station rate-set=configured security-profile=willay

ssid=WILLAY15 supported-rates-a/g=6Mbps,9Mbps,12Mbps,18Mbps txpower= 25 tx-power-mode=card-rates Para ver en forma grfica vasta con darle a 192.168.0.1/graphs/ ]> log ]log>pr para ver log ]log>pr follog en tiempo real para salir Ctrl + C

]>system resource para ver cada segundo ]system resource>pr interval=1s precionar la "Q" para salir ]> ip firewall filter Para ver varias opciones presionamos la tecla Tab: Regla firewall, supongamos ahora que necesitamos bloquear el puerto 23 de TCP para todos los hosts menos para la red 10.10.128.0/24 en la interfase de entrada LAN: Escribimos add y vemos todas las opciones que tenemos para una regla de firewall, vamos a usar solo unas pocas. Un ejemplo de la pagina http://www.foromikrotik.com.ar/foro/vie ... 95e011624f Cdigo: Seleccionar todo
[admin@Pruebas] ip firewall filter> add chain=forward protocol=tcp dst-port=23 src-address=!10.10.128.0/24 ininterface=lan [admin@Pruebas] ip firewall filter> print Flags: X - disabled, I - invalid, D dynamic 0 chain=forward in-interface=lan srcaddress=!10.10.128.0/24 protocol=tcp dst-port=23 action=accept [admin@Pruebas] ip firewall filter>

]> ppp active ]ppp active>pr Para ver los clientes pppoe conectados ] > ip firewall filter print count-only ] > ip firewall connection print count-only ] > ping 192.168.0.1 haciendo ping a un host para salir precionamos Ctrl + C ] > system ssh 192.168.0.1 Para hacer SSH a un equipo

] > system telnet 192.168.0.1 ] > tool mac-telnet 00:15:F9:36:C2:XX acceder por MAC a otro RouterOS de la red: ]> add agrega usuarios o IP en la interface Ejemplo ]>user ]user> add provedor Administrador del Sitio Mensajes: 71 Registrado: Sab, 20 Nov 2010, 09:04 System Reset es usado para borrar toda la configuracin del router. Antes de hacer esto, puede ser til el crear un archivo de backup para la configuracin. vamos a crear un bakup en nuestros sitema con el manual de http://wiki.mikrotik.com/wiki/Configuration_Management_Spanish
[admin@MikroTik] system backup save name=test Configuration backup saved [admin@MikroTik] system backup para ver que se realizo el backup con el nombre test.backup [admin@MikroTik] file [admin@MikroTik] file>pr

Cargar la prueba de fichero de reserva salvada:


[admin@MikroTik] system backup> load name=test Restore and reboot? [y/N]: y

Para ver Los Drivers que soporta nuestra version de Mikrotik


[admin@MikroTik]system resource pci>

[admin@MikroTik]system resource pci>pr Para subir un scrip en el directorio


[admin@MikroTik]system script> Para hacer una exportacion de archivo [admin@MikroTik] ip address> export file=address [admin@MikroTik] ip address>

HHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHH

GUIA DE COMANDOS BASICOS DE CONSOLA


Bueno, como se los habia prometido, una mini guia con los comandos y combinaciones mas comunes para la consola. Qu importancia tiene? Por ej: se murio nuestro RB y no podemos acceder por Winbox, ni por IP ni por MAC, enotnces conectamos un cable serie y podemos obtener acceso por linea de comandos para tratar de solucionar el problema, o en un caso no tan extremo podriamos enocntrarnos con una PC con RouterOS y sin ningun puerto de trabajo con Windows o Linux donde podamos correr un Winbox para acceder a su configuracion, enotnces tendriamos que usar la consola para poder hacerlo. Tambien es bueno saber que hay comandos u opciones en consola que no estan reflejados en la interfase del Winbox, asi que para configurarlos debemos usar consola si o si. Cuando hablamos de consola hablamos de un interprete de comandos, es una interfase en modo texto que esta a la espera de que le ingresen ordenes a travez del teclado (olvidense del mouse, muchos colores y 3D), los que alguna vez usaron algun sistema basado en Unix saben muy bien de lo que hablo, algunos la odian, otros son fanaticos, en mi caso uso siempre que puedo el Winbox, pero a la hora de usar la consola lo hago sin problemas y eso es lo que voy a tratar de demostrarles en esta guia. Para este ejemplo vamos a usar un programita llamado PuTTY (Open Source, gratis) que esta disponible para todos los sistemas operativos, o al menos la mayoria. El PuTTY funciona como un cliente que se conecta a un servidor que puede ser TELNET o SSH (en nuestro caso). El primero es un servicio antiguo que todavia se sigue usando para realizar conexiones remotas y obtener una consola "virtual" o "emulada" de tal fora que seria lo mismo que estar tipeando los datos sentado frente a la PC que nos estamos conectando. La desventaja de este servicio es que a los datos transmitidos no se les aplica ningun tipo de encriptacion ni seguridad, o sea que cualquier nene que este observando el trafico de nuestra red podria ver todo lo que ingresamos. Para enfrentar esta prolematica salio a la luz SSH (Secure SHell) que su objetivo es el mismo pero con avanzadas tecnicas de encriptacion, o sea que podemos estar seguros realizando una conexion de este tipo. Asi que vamos a usar para nuestro ejemplo el PuTTY y conexiones SSH (PuTTY da a elegir el tipo de conexion que deseamos) Se lo bajan desde aca: http://www.chiark.greenend.org.uk/~sgta ... nload.html -Qu datos necesitamos para acceder por consola? .La IP del equipo al que queremos acceder .Un usuario .Un password Asi que descargamos el PuTTY y lo ejecutamos:

En este caso mi RouterOS de pruebas es el que esta en la IP 10.10.128.128, ahi ustedes ingresan la IP de su servidor. En connection type usamos SSH y el puerto por defecto para este tipo de conexion es el 22 de TCP. Si queremos guardar esos datos para luego no tenes que volver a ingresarlos asignamos un nombre en "Saved sessions" y luego un clic en "Save". Hacemos un clic en "Open" para establecer la conexion. La primera vez que iniciemos sesion nos sale un cartelito al que le damos "Si" o "Yes".

Luego se abre una ventana con fondo negro (por defecto) con una leyenda que dice "login as: " es aqui donde debemos ingresar el usuario (Son los mismos datos que usamos para Winbox), confirmamos con un enter y luego ingresamos una contrasea la cual no sera mostrada en pantalla ni tampoco la cantidad de caracteres ingresados. Volvemos a confirmar con un enter. Finalmente obtenemos nuestra querida consola : )

Ahi esta, esperando a que le ingresemos algo... piensen que los sistemas mas sofisticados y complejos del mundo como routers, servidores, centrales telefonicas, robots de produccion en serie, etc, etc, usan un simple linea de comandos para su programacion.

Ahora vamos con los comandos mas utilizados y necesarios (siempre usamos minusculas en la consola): "[admin@Pruebas] >" esto quiere decir que nos encontramos en el nivel superior del arbol o del menu. Si se oprime dos veces seguidas la tecla TAB podemos ver el listado de opciones principales: Cdigo:
[admin@Pruebas] > certificate file system user ip password ppp radius setup

driver import tool export interface login undo [admin@Pruebas] >

isdn-channels log

ping port

queue quit

redo routing

snmp special-

Como ven, es casi lo mismo que la columna de botones que tenemos en el Winbox.

Por ejemplo, queremos ver las direcciones IP que tenemos configuradas: Cdigo:
[admin@Pruebas] > ip address print Flags: X - disabled, I - invalid, D - dynamic # ADDRESS NETWORK BROADCAST INTERFACE 0 10.10.128.128/24 10.10.128.0 10.10.128.255 lan 1 X 192.168.100.120/23 192.168.100.0 192.168.101.255 lan [admin@Pruebas] >

De esto rescatamos el comando PRINT, que lo que hace es mostrar los datos, listar configuraciones, es este caso las configuraciones IP. Podemos ver en el resultado del comando bajo la columna del signo # a los numeros que se denominan ID's y sirven para identificar a cada entrada, al lado del "1" vemos una "X" que quiere decir que esa IP esta configurada pero Deshabilitada: Flags: X - disabled, I - invalid, D - dynamic. Supongamos que ahora queremos ver que es lo que nos ofrece el menu de IP: Cdigo:
[admin@Pruebas] > ip [admin@Pruebas] ip>(oprimimos dos veces seguidas TAB) accounting dhcp-client dns hotspot packing route vrrp address dhcp-relay export ipsec pool service flow arp dhcp-server firewall neighbor proxy socks [admin@Pruebas] ip>

telephony trafficupnp

Entonces lo que obtenemos seria lo que vemos al desplegar las opciones que vemos en el Winbox cuando hacemos clic en el boton IP del menu. Se va entendiendo? Ahora vamos a entrar a la configuracion del proxy: Cdigo:
[admin@Pruebas] ip> proxy [admin@Pruebas] ip proxy> print enabled: no src-address: 0.0.0.0 port: 8080 parent-proxy: 0.0.0.0:0 cache-drive: (unknown) cache-administrator: "webmaster" max-disk-cache-size: none max-ram-cache-size: unlimited cache-only-on-disk: no

maximal-client-connections: maximal-server-connections: max-object-size: max-fresh-time: [admin@Pruebas] ip proxy>

1000 1000 4096KiB 3d

Y ahora vamos a ver que opciones tenemos dentro del menu proxy: [/code][admin@Pruebas] ip proxy>(TAB TAB) access check-drive connections edit format-drive inserts monitor set cache clear-cache direct export get lookups print [admin@Pruebas] ip proxy>[/code] Ven? Es lo mismo que veriamos de forma grafica en Winbox. A esta altura nos encontramos en [admin@Pruebas] ip proxy> Supongamos que queremos volver a la raiz o menu principal: Cdigo:
[admin@Pruebas] ip proxy> / [admin@Pruebas] >

O sea que con la "/" volvemos a la raiz Otra forma: Cdigo:


[admin@Pruebas] ip proxy> .. [admin@Pruebas] ip> .. [admin@Pruebas] >

NOTA: Podemos usar la tecla TAB mientras escribimos el nombre de los menues u opciones para completar la palabra, por ejemplo: si escribimos en el menu principal: Cdigo:
[admin@Pruebas] > syst(TAB) Obtenemos: [admin@Pruebas] > system

Con esto concuimos que ingresando ".." vamos retrocediendo uno a uno en los menues u opciones. Bien, hasta aca ya sabemos movernos en los menues y listar confiuraciones. Veamos ahora las opciones que tenemos o lo que podemos hacer con una regla que ya esta creada: Usamos una del firewall, filter, para eso tenemos que ir hasta ahi: Cdigo:

[admin@Pruebas] > ip firewall filter [admin@Pruebas] ip firewall filter> print Flags: X - disabled, I - invalid, D - dynamic 0 chain=input protocol=icmp action=accept [admin@Pruebas] ip firewall filter>

Ahi vemos la regla con ID 0 que lo que hace es bloquear el ping que entra por la cadena input. Supongamos que queremos consultarle a un amigo por esta regla y el nos pide que le pasemos el codigo para que la vea, enotnces hacemos lo siguiente: Cdigo:
[admin@Pruebas] ip firewall filter> export from=0 # jul/16/2010 10:11:07 by RouterOS 2.9.27 # software id = 9X0H-PLT # / ip firewall filter add chain=input protocol=icmp action=accept comment="" disabled=no [admin@Pruebas] ip firewall filter>

Asi que el comando export nos devuelve toda la consiguracion del FIlter del Firewall en modo de codigo, si nuestro amigo copia este codigo y lo pega en su consola la regla automaticamente se le configura en su equipo, asi como un script, la regla en codigo seria esta: Cdigo:
/ ip firewall filter add chain=input protocol=icmp action=accept comment="" disabled=no

El modificador de comando "from= " lo que hace es seleccionar "Qu exportar", en este caso exportamos la regla de ID 0, el comando export a secas devuelve TODA la configuracion, o sea que si tenemos 50 reglas sera un codigo bastante extenso. Ahora nuestro amigo nos dice que para bloquear el ping en la cadena input deberiamos cambiar el valor action=accept por action=drop, lo hariamos asi: Cdigo:
[admin@Pruebas] ip firewall filter> print Flags: X - disabled, I - invalid, D - dynamic 0 chain=input protocol=icmp action=accept [admin@Pruebas] ip firewall filter> set 0 action= accept add-dst-to-address-list add-src-to-address-list passthrough reject return tarpit [admin@Pruebas] ip firewall filter> set 0 action=accept

drop

jump

log

Primero usamos el PRINT para saber que numero de regla le corresponde, luego con el comando SET decimos que vamos a configurarle un valor al campo ACTION de la regla 0, enotnces escribimos: [admin@Pruebas] ip firewall filter> set 0 action= Y presionamos dos veces TAB para ver que opciones se le pueden configurar al campo ACTION, al hacerlo nos devuelve: accept add-dst-to-address-list add-src-to-address-list drop jump log passthrough reject return tarpit

Lo que nos interesa es bloquearlo, asi que escribimos "dr" despues del igual y apretamos TAB para completar la palabra drop o bien la escribimos toda a mano: Cdigo:
[admin@Pruebas] ip firewall filter> set 0 action=drop

Confirmamos con enter y visualizamos la nueva configuracion: Cdigo:


[admin@Pruebas] ip firewall filter> print Flags: X - disabled, I - invalid, D - dynamic 0 chain=input protocol=icmp action=drop [admin@Pruebas] ip firewall filter>

Vemos que efectivamente quedo en action=drop

Otra forma de hacerlo es con el comando EDIT, se la siguiente forma: Visualizamos el ID: (por mas que ya lo sepamos) Cdigo:
[admin@Pruebas] ip firewall filter> print Flags: X - disabled, I - invalid, D - dynamic 0 chain=input protocol=icmp action=accept

Y editamos el valor ACTION de la regla 0 Cdigo:


[admin@Pruebas] ip firewall filter> edit 0

Damos un enter y nos dice: value-name: Ingresamos: value-name: action Y se abre un simple editor con el valor que tiene asignado, borramos, escribimos la nueva orden y guardamos con Ctrl+O o salimos con Ctrl+C Le damos un print para ver como quedo: Cdigo:
[admin@Pruebas] ip firewall filter> print Flags: X - disabled, I - invalid, D - dynamic 0 chain=input protocol=icmp action=drop [admin@Pruebas] ip firewall filter>

Para deshabilitar una regla: Hacemos un print, obtenemos el ID y escribimos: Cdigo:

[admin@Pruebas] ip firewall filter> set 0 disabled=yes

Para habilitarla: Cdigo:


[admin@Pruebas] ip firewall filter> set 0 disabled=no

Para borrarla: Cdigo:


[admin@Pruebas] ip firewall filter> remove 0

Para mover reglas: (Siempre listar las reglas antes con print, es necesario para el sistema) Cdigo:
[admin@Pruebas] ip firewall filter> move 5 0

Eso le dice que mueva la regla de ID 5 a la posicion 0, la regla 0 enotnces se desplazara hacia abajo para dejar a la que era 5 en su lugar.

Perfecto, a lo ya aprendido le agregamos editar, setear, habilitar, deshabilitar, borrar y mover reglas.

-COMO AGREGAR REGLAS: Entra en juego el comando ADD Por ejemplo, deseamos agregar una IP a una interfase que no la tiene: Vamos hasta IP ADRESS: Cdigo:
[admin@Pruebas] ip address> [admin@Pruebas] ip address> print Flags: X - disabled, I - invalid, D - dynamic # ADDRESS NETWORK BROADCAST [admin@Pruebas] ip address>

INTERFACE

Vemos que no tiene ningun ID, por lo tanto no hay nada configurado, vamos a agregar la IP 10.10.128.128 con mascara 255.255.255.0: Cdigo:
[admin@Pruebas] ip address> add address=10.10.128.128/24 interface=lan

Si hacemos TAB TAB luego de interface= vamos a ver las interfaces disponibles, en este caso es lan. Aceptamos la regla con un enter. y visualizamos con print:

Cdigo:
[admin@Pruebas] ip address> print Flags: X - disabled, I - invalid, D - dynamic # ADDRESS NETWORK BROADCAST 0 10.10.128.128/24 10.10.128.0 10.10.128.255 [admin@Pruebas] ip address>

INTERFACE lan

Vemos que por defecto la IP ya queda habilitada y el broadcast y network lo completa solo en base a la mascara (/24) y la IP (10.10.128.128) Ya tenemos una IP asignada en el sistema!. Veamos un ejemplo mas complejo con alguna regla de firewall, supongamos ahora que necesitamos bloquear el puerto 23 de TCP para todos los hosts menos para la red 10.10.128.0/24 en la interfase de entrada LAN: Escribimos add y vemos toooodas las opciones que tenemos para una regla de firewall, vamos a usar solo unas pocas, asi que: Cdigo:
[admin@Pruebas] ip firewall filter> add chain=forward protocol=tcp dstport=23 src-address=!10.10.128.0/24 in-interface=lan [admin@Pruebas] ip firewall filter> print Flags: X - disabled, I - invalid, D - dynamic 0 chain=forward in-interface=lan src-address=!10.10.128.0/24 protocol=tcp dst-port=23 action=accept [admin@Pruebas] ip firewall filter>

En cada valor podemos ir apretando TAB para ver las opciones y completar palabras.

-OTROS COMANDOS UTILES Para ver el log: Cdigo:


[admin@Pruebas] > log print jul/02 09:07:38 system,info disabled web-proxy-2.9.27 jul/02 09:07:39 system,info enabled webproxy-test-2.9.27 jul/02 09:07:39 system,info router rebooted jul/02 09:07:56 system,info,account user admin logged in from 10.10.128.194 via winbox jul/02 09:07:56 system,info,account user admin logged in from 10.10.128.194 via telnet jul/02 09:09:08 system,info,account user admin logged out from 10.10.128.194 via telnet jul/02 09:10:42 system,info the proxy access rule added by admin jul/02 09:10:50 system,info the proxy access rule removed by admin jul/02 09:32:02 system,info,account user admin logged out from 10.10.128.194 via winbox

jul/08 13:56:11 system,info,account user admin logged in from 10.10.128.194 via winbox jul/08 13:56:17 system,info,account user admin logged out from 10.10.128.194 via winbox jul/11 09:18:31 system,info,account user admin logged in from 10.10.128.194 via winbox jul/11 09:37:44 system,info,account user admin logged out from 10.10.128.194 via winbox 09:12:29 system,info,account user admin logged in from 10.10.128.194 via ssh 10:05:07 system,info filter rule added by admin 10:22:06 system,info filter rule changed by admin 10:41:04 system,info filter rule removed by admin 10:56:11 system,info filter rule added by admin [admin@Pruebas] >

Para ver el log y seguirlo en tiempo real: Cdigo:


[admin@Pruebas] > log print follow

Para visualizar los recursos cada un segundo: Cdigo:


[admin@Pruebas] > system resource print interval=1s

interval=1s hace que el print se ejecute cada 1 segundo, salimos con Ctrl+C Para ver los clientes pppoe conectados Cdigo:
[admin@Pruebas] > ppp active print

Para contar los clientes pppoe o contar reglas: Cdigo:


[admin@Pruebas] > ppp active print count-only [admin@Pruebas] > ip firewall filter print count-only [admin@Pruebas] > ip firewall connection print count-only

etc... Para hacer ping a un host: Cdigo:


[admin@Pruebas] > ping 10.10.128.1 10.10.128.1 64 byte ping: ttl=64 time=2 ms 10.10.128.1 64 byte ping: ttl=64 time=1 ms 10.10.128.1 64 byte ping: ttl=64 time=1 ms 3 packets transmitted, 3 packets received, 0% packet loss round-trip min/avg/max = 1/1.3/2 ms [admin@Pruebas] >

Para hacer SSH a un equipo de la red o de internet:

Cdigo:
[admin@Pruebas] > system ssh 10.10.128.1

(Solo se puede con el usuario admin, no deja cambiar el login por root, por ejemplo) Para hacer Telnet a un equipo de la red o de internet: Cdigo:
[admin@Pruebas] > system telnet 10.10.128.1

(Aca si podemos especificar el usuario, recuerden que no es ua conexion segura) Para acceder por MAC a otro RouterOS de la red: Cdigo:
[admin@Pruebas] > tool mac-telnet 00:15:F9:36:C2:XX

(Si apretamos TAB TAB a la hora de poner la MAC vemos cuales podemos acceder)

Con eso ya pueden configurar un RouterOS desde la consola sin problemas, espero que les sea de mucha utilidad, cualquier otra cosa que quieran saber que no este contamplado preguntenlo aca mismo. Saludos! JJJJJJJJJJJJJJJJJJJJJJJJJJJJJJJJJJJJJJJJJJJJJJJJJJJJJJJJJJJJJJJJJJJJJJJJJJJJJJJJJJJJJJJJJJJJJJJJJJJJJ

2. [Modo Consola] Aprendiendo a usar los SCRIPTS- Comandos Generales (shorcut keys)
Como hemos visto en el post anterior si ya hemos entrado correctamente, Mikrotik te dar un mensaje de bienvenida Cdigo:
MikroTik v5.18 Login:

MMM MMM MMMM MMMM MMM MMMM MMM KKK MMM MM MMM MMM MMM KKK MMM MMM KKK

III III III III

KKK KKK KKK

KKK

RRRRRR RRR RRR RRRRRR RRR RRR

OOOOOO OOO OOO OOO OOO

TTTTTTTTTTT TTTTTTTTTTT TTT III TTT TTT TTT III III III

KKK KKK KKK KKKKK KKK KKK

KKKKK KKK KKK KKK KKK

OOOOOO

MikroTik RouterOS 5.18 (c) 1999-2012

http://www.mikrotik.com/

[admin@MikroTik] >

Jerarqua En modo terminal (prompt) nos permite la configuracin del router utilizando comandos de texto. Estos comandos se establecen dentro de cada nivel que se selecciona. Por lo general mejor es explicar con un ejemplo: Normalmente uno entra a la tabla ARP via winbox de esta manera:

pero por medio de la consola o terminal podemos entrar tambien de la misma manera, simplemente escribimos IP-->ARP-->: Cdigo:
[admin@MikroTik] [admin@MikroTik] [admin@MikroTik] [admin@MikroTik] > > ip /ip> arp /ip arp>

Pero usted dir Donde est el cuadrito ARP? Bueno por ello este post se llama "comandos generales", para poder saber que comandos se pueden escribir solamente tenemos que tipear el simbolo "?" (interrogante)

Este simbolo ser una elemento de mucha ayuda ya que si no sabemos algo al escribir ? nos dir que opciones existen en el nivel que nos encontramos. Cdigo:
[admin@MikroTik] /ip arp> ?

Una vez que hayamos tecleado esa letra aparecer las opciones Cdigo:
[admin@MikroTik] /ip arp> Address Resolution Protocol is used to map IP address to MAC layer address. Router has a table of rently used ARP entries. Normally table is built dynamically, but to increase network security, s c entries can be added. .. -- go up to ip add -- Create a new item comment -- Set comment for items disable -- Disable static ARP entry edit -enable -- Enable static ARP entry export -- Print or save an export script that can be used to restore configuration find -- Find items by value get -- Gets value of item's property print -- Print values of item properties remove -- Remove item set -- Change item properties [admin@MikroTik] /ip arp>

Como pueden observar existe una opcin llamada print con esta opcin podemos "imprimir" es decir mostrar en texto el cuadro del ARP que apareca en winbox Cdigo:
[admin@MikroTik] /ip Flags: X - disabled, # ADDRESS 0 192.168.1.55 1 192.168.1.169 2 192.168.1.54 3 192.168.1.71 4 192.168.1.8 5 192.168.1.198 6 192.168.1.181 7 192.168.1.180 8 192.168.1.89 9 192.168.1.205 10 192.168.1.206 11 192.168.1.182 12 192.168.1.1 13 192.168.1.7 14 192.168.1.2 arp>print I - invalid, H - DHCP, D - dynamic MAC-ADDRESS INTERFACE B0:48:7A:AA:67:EF LAN 00:1D:0F:F7:48:A2 LAN B0:48:7A:0F:F7:48 LAN 00:23:CD:F4:EC:D3 LAN 00:11:5B:00:23:CD LAN 00:16:EC:C1:28:76 LAN F7:42:65:D8:94:CF LAN 00:23:CD:D8:94:CF LAN D8:94:CF:F7:42:65 LAN C0:D5:21:F4:EC:D3 LAN 00:23:CD:F4:EC:D3 LAN 00:06:5B:D8:94:CF LAN 00:06:5B:96:DD:FC LAN 74:EA:3A:FF:38:D9 LAN F4:EC:D3:C0:D5:21 LAN

-- [Q quit|D dump|down]

Bueno entonces vamos avanzar explicando algunas "shortcut" (teclas de atajo) para luego explicar los comandos generales que estn asociados al Mikrotik Hemos reducido el nmero de comandos para no perdernos, vamos primero ha observar lo mas general, El propsito de este foro es dirigido a poder hacer uso del Mikrotik con pocos conocimientos en redes asi que esperemos su comprensin

Teclas de atajo (shorcut keys)


F1 o la letra ?
Nos muestra la ayuda en el contexto que puede estar trabajando (ya sea en interfaces o en el area de IP etc). Se coloca despus de el comando a consulta. Ejemplo: Cdigo:
[admin@MikroTik] > ? driver -- Driver management file -- Local router file storage. import -- Run exported configuration script interface -- Interface configuration ip -- IP options log -- System logs password -- Change password ping -- Send ICMP Echo packets port -- Serial ports queue -- Bandwidth management quit -- Quit console radius -- Radius client settings redo -- Redo previously undone action routing -- Various routing protocol settings system -- System information and utilities tool -- Diagnostics tools undo -- Undo previous action user -- User management while -- executes command while condition is true export -- Print or save an export script that can be used to restore configuration

Control-C
Interrumpe el comando que estamos tratando de ejecutar

Dos puntos ".."


Esto sirve para poder bajar de nivel en el que se esta trabajando, un ejemplo de ello podra ser que estamos configurando el mangle y necesitamos salir del nivel IP-->ARP-->MANGLE para poder ir al nivel global.

Cdigo:
[admin@MikroTik] [admin@MikroTik] [admin@MikroTik] [admin@MikroTik] /ip firewall mangle> .. /ip firewall> .. /ip> .. >

Es de mucha ayuda cuando deseamos pasar de un nivel a otro nivel pero un poco engorroso si deseamos ir al nivel mas general. Para ello usamos la tecla "/"

Tecla "/"
Lo usamos en dos formas, la primera para salir de un nivel. Usando el ejemplo anterior, habiamos necesitado escribir tres veces ".." para poder salir al nivel base, pero gracias a la tecla / solo basta con escribirla para poder ir defrente. Cdigo:
[admin@MikroTik] /ip firewall mangle> / [admin@MikroTik] >

La otra forma de poder usarla es saltandonos de un nivel a otro nivel Normalmente esto hariamos si queremos ir de un nivel a otro, (ayudandonos con las letras "..") Cdigo:
[admin@MikroTik] [admin@MikroTik] [admin@MikroTik] [admin@MikroTik] [admin@MikroTik] [admin@MikroTik] [admin@MikroTik] [admin@MikroTik] [admin@MikroTik] /ip firewall> mangle /ip firewall mangle> .. /ip firewall> .. /ip> .. > > interface /interface> /interface> ethernet /interface ethernet>

Pero gracias a la letra "/" se hace mas sencillo Cdigo:


[admin@MikroTik] /ip firewall mangle> /interface ethernet [admin@MikroTik] /interface ethernet>

La tecla TAB Esta letra nos ayudar a poder completar la sintaxis en los comandos, mientras tecleamos una palabra ustedes vern que cambia de un color negro a un color ya sea azul verdefuxia y esto es debido que el Mikrotik reconoce algunos comandos automticamente y para no estar tecleando todo el comando solo debemos presionar TAB

Continuaraaaaaaaaaaa...

DFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFf