P. 1
Ejemplos Con Labview

Ejemplos Con Labview

4.67

|Views: 42.723|Likes:
Publicado porosor2
ejemplos con labview
ejemplos con labview

More info:

Published by: osor2 on Jul 26, 2009
Copyright:Attribution Non-commercial

Availability:

Read on Scribd mobile: iPhone, iPad and Android.
download as PDF, TXT or read online from Scribd
See more
See less

09/27/2015

pdf

text

original

Ejercicio 0 – Abrir y Cerrar un Instrumento Virtual

Examine el VI Signal Generation and Processing (Generación y Procesamiento de Señales) y corralo. Cambie las frecuencias y tipos de señales de entrada y vea como el display en las graficas cambia. Cambie la ventana de procesamiento de señales y las opciones de filtro. Después de que halla examinado el VI y las diferentes opciones que usted puede cambiar, pare el VI al presionar el botón de parada (Stop button) 1. Seleccione Start»Programs»National Instruments»LabVIEW 7.0»LabVIEW para lanzar LabVIEW. La caja de dialogo de LabVIEW aparece. 2. Seleccione Help»Find Examples. La caja de dialogo que aparece muestra y enlaza todos los VIs de ejemplo disponibles en LabVIEW. 3. En el Browse Tab, seleccione browse (navegar) de acuerdo al tema deseado. Elija Analyzing and Processing Signals (analizando y procesando señales), después Signal Processing, después Signal Generation and Processing.vi. Esto abrirá el Panel Frontal del VI Signal Generation and Processing. Nota Usted también puede abrir el VI al hacer clic en el botón Open VI (abrir VI) y navegar a labview\examples\apps\demos.llb\Signal Generation and Processing.vi. Panel Frontal 4. Haga clic en el botón de Run (correr) de la barra de herramientas, mostrado a la izquierda, para correr este VI. Este VI determina el resultado de filtrar una señal generada. Este ejemplo también muestra el espectro de poder (power spectrum) para señales generadas. Las señales resultantes son mostradas en graficas en el panel frontal, como se muestra en la siguiente figura.

5. Utilice la herramienta de Operación, mostrada en la izquierda, para cambiar la señal de Entrada y la señal de Procesamiento, use las flechas de incremento o decremento en el control, y mueva el puntero a la Frecuencia deseada. 6. Presione el botón de More Info… (mas información) o [F5] para leer mas acerca de las funciones de análisis. 7. Presione el botón Stop (parada) o [F4] para parar el VI. Diagrama de Bloques 8. Seleccione Window»Show Diagram o presione las teclas <Ctrl-E> para mostrar el diagrama de bloque del VI Signal Generation and Processing.
(MacOS) Presione las teclas <Command-E>. (Sun) Presione las teclas <Meta-E>. (Linux) Presione las teclas <Alt-E>.

Este diagrama de bloque contiene muchos de los elementos básicos de diagrama de bloque, incluyendo subVIs, funciones, y estructuras, de las cuales usted aprenderá mas tarde en el curso. 9. Seleccione Window»Show Panel o presione las teclas <Ctrl-E> para regresar al Panel Frontal. 10. Cierre el VI y no guarde los cambios.

Fin del Ejercicio

Ejercicio 1 – Convertir °C a °F Construir un VI
Complete los pasos siguientes para crear un VI que tome un número representando grados Celsius y lo convierta a un número representando grados Fahrenheit. En las ilustraciones de cableado, la flecha al final del icono del mouse (mostrado al lado izquierdo) muestra donde hacer clic y el numero en la flecha indica cuantas veces hay que hacer clic.

Panel Frontal
1. Seleccione File»New para abrir un nuevo panel frontal.

2. (Opcional) Seleccione Window»Tile Left and Right para mostrar el panel frontal y el diagrama de bloques uno al lado del otro. 3. Cree un control digital numérico. Usted utilizara este control para introducir el valor en grados Centígrados. a. Seleccione el control digital en la paleta de Controls»Numeric Controls. Si la paleta de Controls no esta visible, haga clic-derecho en un área abierta del panel frontal para desplegarla. b. Mueva el control al panel frontal y haga clic para colocar el control. c. Escriba deg C adentro de la etiqueta y haga clic afuera de la etiqueta o haga clic en el botón Enter de la barra de herramientas. Si usted no escribe el nombre inmediatamente, LabVIEW utiliza una etiqueta que tiene por defecto. Usted puede editar una etiqueta en cualquier momento utilizando la herramienta de Etiquetado. 4. Cree un indicador digital numérico. Usted utilizara este indicador para mostrar el valor en grados Fahrenheit. a. Seleccione el indicador digital en la paleta Controls»Numeric Indicators. b. Mueva el indicador al panel frontal y haga clic para colocar el indicador. c. Escriba deg F adentro de la etiqueta y haga clic afuera de la etiqueta o haga clic en el botón Enter. LabVIEW crea terminales de control e indicación correspondientes en el diagrama de bloques. Las terminales representan el tipo de dato de control o indicación. Por ejemplo, una terminal DBL representa un control o indicador numérico de punto flotante con valor de precisión-doble. Nota Las terminales de control tienen un borde más grueso que las terminales de los indicadores.

Diagrama de Bloque
5. Despliegue el diagrama de bloques hacienda clic en el o seleccionando Window»Show Diagram.

Nota: Las terminales del Diagrama de Bloques pueden ser vistas como iconos o como terminales. Para cambiar la manera en que LabVIEW despliega estos objetos haga clic derecho en la terminal y seleccione View As Icon.

6. Seleccione las funciones de Multiplicación (Multiply) y Suma (Add) en la paleta de Functions»Numeric y colóquelas en el diagrama de bloques. Si la paleta de Functions no esta visible, haga clic derecho en un área libre en el bloque de diagramas para desplegarla. 7. Seleccione una constante numérica en la paleta Functions»Numeric y coloque dos de ellas en el diagrama de bloques. Cuando usted coloca la constante numérica por primera vez esta queda seleccionada de manera que usted pueda escribir el valor deseado. 8. Escriba 1.8 en una de las constantes y 32.0 en la otra. Si usted movió las constantes antes de haberles asignado (escrito) un valor, entonces utilice la herramienta de Etiquetado para ingresar los valores. 9. Utilice la herramienta de cableado para conectar los iconos como se muestra en el diagrama de bloques previo. • Para cablear de una terminal a la otra, utilice la herramienta de Cableado para hacer clic en la primera terminal, mover la herramienta a la segunda terminal, y hacer clic en la segunda terminal, como se muestra en la siguiente ilustración. Usted puede comenzar el cableado desde cualquier terminal.

Usted puede doblar un cable al hacer clic para sujetar el cable a la pantalla y moviendo el cursor en una dirección perpendicular. Presione la barra de espaciamiento para cambiar la dirección de cableado. • Para identificar terminales en los nodos, haga clic derecho en las funciones de Multiplicación y Suma y seleccione Visible Items»Terminals desde el menú de atajo para desplegar el conector. Regrese a los iconos una vez que haya cableado haciendo clic derecho en las funciones y seleccionando Visible Items»Terminals desde el menú de atajo para remover la selección (checkmark). • Cuando mueva la herramienta de Cableado sobre una terminal, el área de la terminal se ilumina intermitentemente, indicando que al hacer clic sobre ella se conectara el cable a la terminal y una etiqueta de sugerencia aparece, mostrando el nombre de la terminal. • Para cancelar un cable que se ha comenzado a conectar, presione la tecla <Esc>, haga clic derecho, o haga clic en la terminal de inicio. 10. Despliegue el panel frontal haciendo clic en el o seleccionando Window»Show Panel. 11. Salve el VI ya que usted utilizara este VI después en el curso. a. Seleccione File»Save. b. Navegue a c:\exercises\LV Intro. Note Salve todos los VIs que edita en este curso en c:\exercises\LV Intro. c. Escriba Convertir C a F.vi en el ventana de dialogo. d. Haga clic en el botón Save. 12. Ingrese un número en el control digital y corra el VI. a. Utilice la herramienta de Operación o la herramienta de Etiquetado para hacer doble clic en el control digital y escribir un nuevo numero (valor). b. Haga clic en el botón de Run para correr el VI. c. Trate diferentes números varios y corra el VI otra vez. 13. Seleccione File»Close para cerrar el VI Convertir C a F.

Fin del Ejercicio

Ejercicio 2a – Crear un SubVI Panel Frontal
1. Seleccione File»Open y navegue a c:\exercises\LV Intro para abrir el VI Convertir C a F. Si usted cerro todos los VIs que estaban abiertos, haga clic en el botón Open… en la ventana de dialogo de LabVIEW Sugerencia Haga clic en la flecha junto al botón Open… en la ventana de dialogo de LabVIEW para abrir documentos recientemente abiertos, tales como Convertir C a F.vi. El siguiente panel frontal aparece.

2. Haga clic derecho en el icono en la parte superior derecha del panel frontal y seleccione Edit Icon del menú de atajo. Esto hace que la ventana de dialogo Icon Editor aparezca. 3. Haga doble clic en la herramienta de Selección en la parte izquierda de la ventana de dialogo del Icon Editor para seleccionar el icono por defecto. 4. Presione la tecla <Delete> para remover el icono por defecto. 5. Haga doble clic en la herramienta de Rectángulo para re-dibujar la orilla. 6. Cree el siguiente icono.

a. Utilice la herramienta de Texto para hacer clic en el área de edición. b. Escriba C y F. c. Haga doble clic en la herramienta de Texto y cambie el tamaño de la letra (fuente) a Small Fonts. d. Utilice la herramienta de Lápiz para crear una flecha. Nota Para dibujar líneas rectas horizontales o verticales presione la tecla <Shift> mientras usted utiliza la herramienta de Lápiz para mover el cursor. e. Utilice la herramienta de Selección y las teclas de flecha (arrow keys) para mover el texto y la flecha que usted creo.

f. Seleccione el icono B&W y seleccione 256 Colors en el campo Copy from para crear un icono en blanco y negro, el cual LabVIEW utiliza para imprimir a menos que usted tenga una impresora a colores. g. Cuando el icono este completo, haga clic en el botón OK para cerrar la ventana de dialogo Icon Editor. El icono aparece en la esquina superior derecha del panel frontal y del diagrama de bloque. 7. Haga clic derecho en el icono localizado en el panel frontal y seleccione Show Connector desde el menú de atajo para definir el patrón de terminales del conector. LabVIEW selecciona un patrón para el conector basado en el número de controles e indicadores en el panel frontal. Por ejemplo, este panel frontal tiene dos terminales, deg C y deg F, por lo que LabVIEW selecciona un patrón de conector con dos terminales. 8. Asigne las terminales al control digital y al indicador digital. a. Seleccione Help»Show Context Help para desplegar la ventana Context Help. Mire cada conexión en la ventana Context Help mientras usted las hace. b. Haga clic en la terminal izquierda del conector. La herramienta automáticamente se cambia a la herramienta de Cableado, y la terminal se torna negra. c. Haga clic en el control deg C. La terminal izquierda se torna naranja, y el control se remarca. d. Haga clic en un área desocupada del panel frontal. El remarcado desaparece, y la terminal se cambia al color del tipo de dato del control para indicar que usted ha conectado la terminal. e. Haga clic en la terminal derecha del conector y haga clic en el indicador deg F. La terminal derecha se torna naranja. f. Haga clic en un área desocupada del panel frontal. Ambas terminales son color naranja. g. Mueva el cursor sobre el conector. La ventana de Context Help muestra que ambas terminales están conectadas a valores de punto flotante. 9. Seleccione File»Save para salvar el VI porque usted usara este VI mas adelante en el curso. 10. Seleccione File»Close para cerrar el VI Convertir C a F.

Fin del Ejercicio

Ejercicio 2b – Adquisición de Datos
Para completar este ejercicio, usted necesitara el sensor de temperatura de punta fría (IC temperature sensor) disponible en ya sea el BNC-2120, SCB-68, o DAQ Signal Accessory. En el caso de no disponer de los dispositivos de adquisición de datos, añadiremos un dispositivo simulado con el fin de poder realizar el ejercicio. Para ello, se deberá abrir el programa Measurement & Automation Explorer, programa que controla la configuración de las tarjetas de adquisición de datos (reales y simuladas).

Una vez abierto el programa aparecerán las características de todos los dispositivos de adquisición, tareas, escalas y software asociado. Para configurar un dispositivo simulador se deberá desplegar el apartado Devices and Interfaces y, en el caso de que no exista ningún dispositivo de adquisición de datos (solamente los puertos del ordenador), seleccionar la creación de un nuevo dispositivo situándonos en Devices and Interfaces con el ratón y en el menú que aparece con el botón derecho seleccionar Create New...

Entre los dispositivos que aparecen seleccionar NI-DAQmx Simulated Device con lo que nos aparecerá otra lista en la que elegiremos la PCI-6034E de la serie E Series DAQ.

Una vez hecho esto ya podemos cerrar el programa Measurement & Automation Explorer y continuar con el ejercicio.

Panel Frontal
1. Seleccione File»New para abrir el nuevo panel frontal. 2. Cree el indicador de termómetro, como se muestra en el siguiente panel frontal.

a. Seleccione el termómetro en la paleta Controls»Numeric Indicators y colóquelo en el panel frontal. b. Escriba Temperature adentro de la etiqueta y haga clic afuera de la etiqueta o haga clic en el botón Enter en la barra de herramientas. c. Haga clic derecho en el termómetro y seleccione Visible Items»Digital Display de el menú de atajo para mostrar el despliegue digital del termómetro. 3. Cree el control de switch vertical. a. Seleccione el switch de conmutación vertical (vertical toggle switch) en la paleta Controls»Buttons. b. Escriba Temp Scale adentro de la etiqueta y haga clic afuera de la etiqueta o haga clic en el botón Enter. c. Use la herramienta de Etiquetado para colocar una etiqueta libre, deg C, junto a la posición verdadera (TRUE) del switch, como se muestra en el panel frontal previo. d. Coloque una etiqueta libre, deg F, junto a la posición falsa (FALSE) del switch.

Diagram de Bloque
4. Seleccione Window»Show Diagram para desplegar el diagrama de bloques. 5. Construya el siguiente diagrama de bloques.

a. Coloque el VI DAQ Assistant Express localizado en la paleta Functions»Input. Haga las siguientes configuraciones en el Asistente de Configuración DAQ (DAQ Assistant configuration wizard). i. Seleccione Analog Input como el tipo de medición. ii. Seleccione Voltage. iii. Seleccione ai0 como el canal de su aparato de adquisición de datos. iv. En la sección de temporizado de tareas (Task Timing), seleccione Acquire 1 sample. b. Coloque la función Convert from Dynamic Data localizada en Functions»Signal Manipulation y seleccione escalar simple (Single Scalar) como el tipo resultante de datos (Resulting data type). c. Coloque la función de multiplicación (Multiply) localizada en la paleta Functions»Numeric. Esta función multiplica el voltaje que el VI AI Sample Channel regresa por 100.0 para obtener la temperatura en Celsius. d. Seleccione Functions»Select a VI, navegue hacia el VI Convertir C a F VI, el cual usted construyó en el Ejercicio 2a, y coloque el VI en el diagrama de bloques. Este VI convierte las lecturas en Celsius a Fahrenheit. e. Coloque la función de seleccionar (Select) localizada en la paleta Functions»Comparison. Esta función regresa el valor de la temperatura ya sea en Fahrenheit (FALSE) o en Celsius (TRUE), dependiendo en el valor de Temp Scale. f. Haga clic derecho en la terminal y de la función de multiplicación (Multiply), seleccione Create»Constant, escriba 100, y presione la tecla <Enter> para crear otra constante numérica. g. Utilice la herramienta de Posicionamiento para colocar los iconos como se muestra en el bloque de diagramas previo y utilice la herramienta de Cableado para conectarlos juntos. Sugerencia Para identificar terminales en los nodos, haga clic derecho en el icono y seleccione Visible Items»Terminal del menú de atajo para desplegar el conector. 6. Despliegue el panel frontal al hacer clic en el o al seleccionar Window»Show Panel. 7. Haga clic en el botón Continuous Run, mostrado al lado izquierdo, para correr el VI continuamente. 8. Ponga su dedo en el sensor de temperatura y mire el incremento en temperatura. 9. Haga clic en el botón Continuous Run otra vez para parar el VI. 10. Cree el siguiente icono, de manera que usted pueda usar el VI de Temperatura como un subVI.

a. Haga clic con el botón derecho en el icono en la parte superior derecha del panel frontal y seleccione Edit Icon desde el menú de atajo. La ventana de dialogo Icon Editor aparece. b. Haga doble clic con la herramienta de Selección en el lado izquierdo de la ventana de dialogo Icon Editor para seleccionar el icono por defecto. c. Presione la tecla <Delete> para remover el icono por defecto. d. Haga doble clic en la herramienta de Rectángulo para re-dibujar la orilla. e. Use la herramienta de Lápiz para dibujar un icono que represente el termómetro. f. Utilice el Foreground y las herramientas de Llenado para colorear el termómetro de rojo. Nota Para dibujar líneas rectas horizontales o verticales, presione la tecla <Shift> mientras utilice la herramienta del lápiz para mover el cursor. a. Haga clic doble sobre la herramienta de Texto, mostrada a la izquierda, y cambie el tamaño de la letra (fuente) a Small Fonts. b. Seleccione el icono B&W y seleccione 256 Colors en el espacio Copy from para crear un icono en blanco y negro, el cual LabVIEW utiliza para imprimir a menos que usted tenga una impresora a color. c. Cuando el icono este completo, haga clic en el botón OK. El icono aparece en la esquina superior derecha del panel frontal. 11. Seleccione File»Save para salvar el VI. Elija un lugar en su disco duro para salvar el VI como Termometro.vi. 12. Seleccione File»Close para cerrar el VI.

Fin del Ejercicio

Ejercicio 3 – Utilizando Ciclos
Use un ciclo mientras (while) y un grafico de forma de onda para construir un VI que demuestre temporizado de software.

Panel Frontal
1. Abra un nuevo VI. 2. Construya el siguiente panel frontal.

a. Seleccione el selector corredizo horizontal en la paleta Controls»Numeric Controls y colóquelo en el panel frontal. Usted utilizara este selector corredizo para cambiar el temporizado del software. b. Escriba millisecond delay adentro de la etiqueta y haga clic afuera de la etiqueta o haga clic en el botón Enter en la barra de herramientas, mostrada a la izquierda. c. Coloque un botón de parada (Stop) desde la paleta Controls»Buttons. d. Seleccione una grafica de forma de onda (waveform chart) en la paleta Controls»Graph Indicators y colóquela en el panel frontal. El grafico de forma de onda desplegara los datos en tiempo real. e. Escriba Value History adentro de la etiqueta y haga clic afuera de la etiqueta o haga clic en el botón Enter. f. La leyenda de la grafica de forma de onda identifica la grafica como Plot 0. Utilice la herramienta de Etiquetado para hacer tres clics en Plot 0 en la leyenda de la grafica, escriba Value, y haga clic afuera de la etiqueta o haga clic en el botón Enter para re-etiquetar la leyenda. g. El generador de números aleatorios genera números entre 0 y 1, en un salón de clases usted podría reemplazar esto por un VI de adquisición de datos. Utilice la herramienta de Etiquetado para hacer doble clic en 10.0 en el eje-y, escriba 1, y haga clic afuera de la etiqueta o haga clic en el botón Enter para re-escalar el grafico. h. Cambie 10.0 en el eje-y a 0. i. Etiquete el eje-y como Value y el eje-x como Time (sec).

Diagrama de Bloque
3. Seleccione Window»Show Diagram para desplegar el diagrama de bloques. 4. Circunscriba las dos terminales en un ciclo mientras (While Loop), como se muestra en el siguiente diagrama de bloques.

a. Seleccione el ciclo mientras (While Loop) en la paleta Functions»Execution Control. b. Haga clic y arrastre un rectángulo de selección alrededor de las dos terminales. c. Utilice la herramienta de Posicionamiento para cambiarle el tamaño al ciclo, si es necesario. 5. Seleccione el Random Number (0-1) en la paleta Functions»Arithmetic and Comparison»Numeric. Alternativamente usted podría usar un VI que este obteniendo datos desde un sensor externo. 6. Cablee los objetos del diagrama de bloques como se muestra en el diagrama de bloque mostrado previamente. 7. Salve el VI como Utilice un Ciclo.vi porque usted usara este VI mas adelante en el curso. 8. Despliegue el panel frontal al seleccionarlo o al seleccionar Window»Show Panel. 9. Corra el VI. La sección del diagrama de bloques dentro de las orilla del ciclo mientras (While Loop) se ejecuta hasta la condición especificada se vuelve verdadera (TRUE). Por ejemplo, mientras el botón STOP no esta presionado, el VI retornara un nuevo numero y lo desplegara en la grafica de forma de onda. 10. Haga clic en el botón STOP para parar la adquisición. La condición es falsa (FALSE), y el ciclo para de ejecutarse. 11. Formatee y personalice las escalas X y Y de la grafica de forma de onda. a. Haga clic derecho y seleccione Properties desde el menú de atajo. La siguiente ventana de dialogo aparece.

b. Haga clic en el tab de Scale y seleccione diferentes estilos para el ejey. Usted también puede seleccionar diferentes modos de linearizacion, opciones de cuadricula, factores de escala, y formatos y precisión. Note que estos se actualizaran interactivamente en la grafica de forma de onda c. Seleccione las opciones que usted desee y haga clic en el botón OK.

12. Haga clic derecho en la grafica de forma de onda y seleccione Data Operations»Clear Chart desde el menú de atajo para vaciar el buffer de despliegue y resetear la grafica de forma de onda. Si el VI esta corriendo, usted puede seleccionar Clear Chart desde el menú de atajo.

Añadiendo Temporizado
Cuando este VI corre, el ciclo mientras (While Loop) se ejecuta tan rápido como le es posible. Complete los siguientes pasos para tomar datos a ciertos intervalos, tales como una vez cada medio-segundo, como se muestra en el siguiente diagrama de bloque.

a. Coloque el VI Time Delay Express localizado en la paleta Functions»Execution Control. En la ventana de dialogo que aparece inserte 0.5. Esta función asegurara que cada iteración ocurra cada medio-segundo (500 ms). b. Divida el retardo en milisegundos (millisecond delay) por 1000 para obtener tiempo en segundos. Conecte la salida de la división a la entrada Delay Time (s) del VI Time Delay Express. Esto le permitirá ajustar la velocidad de la ejecución desde el selector corredizo en el panel frontal. 13. Salve el VI, porque usted utilizara este VI mas adelante en el curso. 14. Corra el VI. 15. Trate diferentes valores en el retardo en milisegundos (millisecond delay) y corra el VI otra vez. Note como esto afecta la velocidad de la generación de números y de su despliegue. 16. Cierre el VI.

Fin del Ejercicio

Ejercicio 4 - Analizando e Ingresando Datos
Complete los siguientes pasos para construir un VI que mida temperatura cada 0.25 s por 10s. Durante la adquisición, el VI mostrara las mediciones en tiempo real en una grafica de forma de onda. Después que la adquisición se haya completado, el VI graficara los datos en una grafica y calculara las temperatura mínima, máxima, y average. El VI mostrara el mejor ajuste de la curva para la grafica de la temperatura.

Panel Frontal
1. Abra un nuevo VI y construya el siguiente panel frontal utilizando las siguientes sugerencias.

No cree los indicadores Mean, Max, y Min todavía. Creelos en el Diagrama de Bloque al hacer clic derecho en las funciones y elegir Crear Indicador (Create Indicator). Después posiciónelos en el Panel Frontal.

Diagrama de Bloque
2. Construya el siguiente diagrama de bloque.

a. Seleccione Functions»All Functions»Select a VI… y elija Termometro.vi (del ejercicio previo). b. Coloque la función Wait Until Next ms Multiple localizada en la paleta de Functions»All Functions »Time & Dialog y cree una constante de 250. Así como el VI Time Delay Express, esta función causa que el ciclo para (For Loop) se ejecute cada 0.25 s (250 ms). c. Coloque la función Array Max & Min localizada en la paleta Functions»All Functions »Array. Esta función regresa las temperaturas máximas y mínimas. d. Coloque el VI Mean (media) localizado en la paleta Functions»All Functions» Mathematics»Probability and Statistics. Este VI regresa el average de las mediciones de temperatura. e. Haga clic derecho en las terminales de salida de la función Array Max & Min y del VI Mean y seleccione Create»Indicator desde el menú de atajo para crear los indicadores Max, Min, y Mean. f. Coloque el VI Write LabVIEW Measurements File Express localizado en la paleta Functions»Output. LabVIEW automáticamente insertara la función From DDT en el cable que usted conectara a la entrada de Señales (Signals input). 3. Salve el VI como Logger de Temperatura.vi. 4. Despliegue el panel frontal y corra el VI. 5. Después de presionar STOP (parar) una ventana de dialogo aparecerá. Ingrese el nombre del documento para salvar la hoja electrónica de datos (spreadsheet). 6. Abra el documento de hoja electrónica de datos (spreadsheet) para asegurarse que el documento fue creado apropiadamente utilizando Notepad o creando un VI que lea el documento de la manera siguiente. • Cree el siguiente diagrama de bloques

• • •

Coloque el VI Read LabVIEW Measurement File Express localizado en la paleta Functions»Input. Configure el VI para que le pida al usuario elegir el documento a leer y cambien el delimitante a un Tab Haga clic derecho en Signals Output (señales de salida) y elija crear indicador grafico

7. Corra el VI 8. Salve y cierre ambos VIs.

Fin del Ejercicio

Otros ejercicios – Resolución de un problema corriente alterna
Para completar la fase de aprendizaje, aplicaremos el entorno LabVIEW para la resolución de un sencillo circuito de corriente alterna, como el mostrado en la figura. Se deberá determinar la intensidad que circula por el circuito, conocidos los datos de la tensión alterna y los parámetros de la resistencia y de la autoinducción.

Para su resolución en el dominio fasorial, utilizaremos las funciones de números complejos que aparecen en el panel de funciones numéricas de LabVIEW.

Una vez resuelto el problema, calculada la corriente i(t), se utilizarán las funciones de generación mostradas en la siguiente figura para su representación en las gráficas correspondientes.

El panel frontal adoptará la siguiente estructura:

Otros ejercicios – Análisis de la corriente de un condensador
A continuación se resolverá un ejercicio de análisis de la corriente de un condensador. En el laboratorio de Máquinas Eléctricas se dispone de un sistema que permite la adquisición de la tensión y corriente de un condensador, como muestra la siguiente figura:

Los datos de esta adquisición están en un fichero junto con el programa de la asignatura (www.uva.es) y se denomina C-0. Si realizamos su representación utilizando LabVIEW nos daría una gráfica como la representada en la figura:

Pretendemos con este ejercicio analizar la distorsión de la onda de corriente a partir del programa LabVIEW. Para ello utilizaremos las funciones que nos permiten hacer un desarrollo armónico de la tensión y la corriente.

Para la lectura de datos desde el fichero se utilizará la función Read Waveform from File.vi.

Para hacer el análisis armónico se utilizará la función Harmonic Distortion Analyzer.vi.

El panel frontal adoptará la siguiente estructura:

Obsérvese ampliando la representación de armónicos como la impedancia del condensador va disminuyendo a medida que aumenta la frecuencia.

Otros ejercicios – Resolución de un problema de transitorios
Otro sencillo problema que podemos resolver en el entorno LabVIEW puede ser el circuito mostrado en la figura donde se deberá determinar la intensidad que circula por el circuito, conocidos los datos de la tensión y los parámetros de la resistencia y de la autoinducción, cuando se conecta el mismo en el instante inicial (t = 0).

Para su resolución se deberán usar las funciones de resolución de ecuaciones diferenciales.

El panel frontal adoptará la siguiente estructura:

You're Reading a Free Preview

Descarga
scribd
/*********** DO NOT ALTER ANYTHING BELOW THIS LINE ! ************/ var s_code=s.t();if(s_code)document.write(s_code)//-->