P. 1
Empezando Con Rcmdr Es

Empezando Con Rcmdr Es

|Views: 3|Likes:
Publicado poralepico

More info:

Published by: alepico on Oct 11, 2013
Copyright:Attribution Non-commercial

Availability:

Read on Scribd mobile: iPhone, iPad and Android.
download as PDF, TXT or read online from Scribd
See more
See less

10/11/2013

pdf

text

original

Iniciación a R Commander

*
John Fox (2 de junio de 2008)

1. Iniciar R Commander

Una vez que R se está ejecutando, simplemente cargando el paquete Rcmdr mediante la instrucción library(Rcmdr) en la consola de R, se inicia la interfaz gráca de usuario (GUI) de R Commander. Para que funcione correctamente con Windows, R Commander requiere la interfaz de documento único (SDI) de R1 . Después de cargar el paquete, las ventanas R Console y R Commander deberían aparecer más o menos como en las guras ?? y ??. Éstas y otras imágenes en este documento fueron creadas con Windows XP; si usa otra versión de Windows (o, por supuesto, otra plataforma informática), entonces la apariencia de la pantalla puede diferir2 . Si estos paquetes no están instalados, Rcmdr ofrecerá instalarlos desde Internet o desde archivos locales (e.g., desde un CDROM). Si usted instala el paquete Rcmdr a través de Windows R GUI, los paquetes de los cuales Rcmdr depende deberían ser instalados automáticamente. En general, puede instalar el paquete Rcmdr y todos los paquetes de los que depende a través de la función install.packages, estableciendo el argumento dependencies = TRUE. Gracias a Dirk Eddelbuettel, los usuarios de Debian Linux sólo necesitan la instrucción apt-get install r-cran-rcmdr para instalar el paquete Rcmdr junto con todos los paquetes que éste requiere. En cualquier caso, instalar y cargar el paquete Rcmdr en los sistemas Linux suele ser sencillo. La tarea puede ser más complicada con OS/X en los sistemas Macintosh, ya que el paquete tcltk del cual depende Rcmdr requiere que Tcl/Tk esté instalado y que R se esté ejecutando con XWindows. Para habilitar los grácos en 3D en Rcmdr, instale el paquete rgl. Puede encontar más información sobre la instalación en la web de R Commander http://socserv.socsci.mcmaster.ca/jfox/Misc/Rcmdr/index.html y en http://knuth.uca.es/R/doku
* Este manual está revisado y traducido en marzo de 2008, del original de Fox (2005), como parte del proyecto R-UCA, puede encontrar más información en http://knuth.uca.es/R. 1 La versión de Windows de R normalmente se ejecuta desde una interfaz de documentos múltiples (MDI), que contiene la ventana R Console, las ventanas Graphics Device creadas durante la sesión y cualquier otra ventana relacionada con el proceso R. En contraste, en la interfaz de documento único (SDI), las ventanas R Console y Graphics Device no están contenidas en una ventana maestra. Hay varias maneras de ejecutar R en modo SDI, por ejemplo, editando el archivo Rconsole en el subdirectorio etc de R, o añadiendo sdi al campo Destino en la pestaña Acceso Directo dentro de Propiedades del icono del escritorio R. Esta limitación del paquete Rcmdr es heredada del paquete tcltk, del cual depende Rcmdr. 2 Dese cuenta de que Rcmdr requiere algunos paquetes además de varios de los paquetes recomendados que normalmente son distribuidos con R, y de que carga estos paquetes en el arranque. Rcmdr, los paquetes requeridos, y muchos otros paquetes aportados están disponibles para descarga desde la Red Extensa de Archivos R [Comprehensive R Archive Network (CRAN)] en http://cran.r-project.org

1

Figura 1: La ventana R Console tras cargar el paquete Rcmdr. Las ventanas R Commander y R Console otan libremente en el escritorio. Normalmente usted usará los menús y cuadros de diálogo de R Commander para leer, manipular y analizar datos. Las instrucciones R generadas por la GUI de R Commander aparecen en la ventana de texto superior (denominada Ventana de Instrucciones) dentro de la ventana principal de R Commander. También puede escribir las instrucciones R directamente en la ventana de instrucciones o en R Console tras el símbolo del sistema > (mayor que); sin embargo, el propósito principal de R Commander es evitar tener que escribir instrucciones. El resultado aparece impreso por defecto en la segunda ventana de texto (denominada Ventana de Resultados). La ventana gris inferior (denominada Mensajes) muestra mensajes de error, advertencias y otra información (notas), como el mensaje de inicio de la gura ??. Cuando cree grácos, éstos aparecerán en una ventana separada Graphics Device. Existen varios menús en la parte superior de la ventana R Commander: Fichero Opciones de menú para cargar y guardar archivos de instrucciones; para guardar resultados y el área de trabajo R; y para salir. Editar Opciones de menú (Cortar, Copiar, Pegar, etc.) para editar los contenidos de las ventanas de instrucciones y de resultados. Al pulsar con el botón derecho en la ventana de instrucciones o de resultados también aparece un menú contextual de edición. Datos Submenús que contienen opciones de menú para leer y manipular datos. 2

por ejemplo. diagnósticos y grácas para un modelo estadístico. Distribuciones Probabilidades. Herramientas Opciones de menú para cargar paquetes R no relacionados con el paquete Rcmdr (e. Modelos Opciones de menú y submenús para obtener resúmenes. Estadísticos Submenús que contienen opciones de menú para una variedad de análisis estadísticos básicos.2-0) se muestra en el apéndice ??. cuantiles y grácos para distribuciones estadísticas estándares (para usarse. tests de hipótesis. Ayuda Opciones de menú para obtener información sobre R Commander (incluyendo este manual). como se muestra más adelante en este documento. y para añadir cantidades diagnósticas. intervalos de conanza. a la serie de datos. cada cuadro de diálogo de R Commander tiene un botón de Ayuda (ver más abajo).. La interfaz de R Commander incluye algunos elementos además de los menús 3 . Grácas Opciones de menú para crear grácos estadísticos simples. La mayoría de las opciones de menú conducen a cuadros de diálogo. El menú en árbol completo de R Commander (versión 1.Figura 2: La ventana de R Commander al inicio. Las opciones de menú están inactivas (se muestran en gris) si no son aplicables en el contexto actual.g. como residuos. Además. como sustituto de las tablas estadísticas) y ejemplos de estas distribuciones. para acceder a datos guardados en otro paquete). y para establecer algunas opciones.

. las instrucciones generadas por la GUI se copian en esta ventana.g. puede elegir entre ellos pulsando sobre el botón. Inmediatamente debajo de la barra de herramientas se encuentra la ventana de instrucciones (denominada de esta manera). Inicialmente no hay ninguna serie de datos activa. Una desventaja de usar el editor de datos para mostrar la serie de datos actual es que la ventana de edición no se puede seguir mostrando mientras se realizan otras operaciones. una ventana grande en la cual podrá desplazarse hacia arriba y abajo en el texto. Bajo la ventana de instrucciones hay una ventana grande para los resultados que permite editar el texto y desplazarse arriba y abajo sobre él. un modelo lineal (como el modelo de regresión lineal). Inicialmente no hay ningún modelo activo. podrá elegir entre las series de datos que están actualmente en la memoria (si hay más de una). el presionar Ejecutar hará que todas ellas se ejecuten. alternativamente. Presionando el botón Ejecutar. Editar y Distribuciones son excepciones). Como se ha mencionado anteriormente. la combinación de teclas Ctrl-r para ejecutar). Si presiona este botón. La combinación de teclas Ctrl-a selecciona todo el texto de la ventana de instrucciones.y diálogos: Bajo los menús hay una barra de herramientas con una la de botones. y editando el archivo model-classes. Si se seleccionan varias líneas (e. la línea contenida en el cursor se ejecuta (o se re-ejecuta) para su resolución. Vea la ayuda de R Commander para más detalles. Para usar el editor de datos sin tener en cuenta el número de variables. pulsando con el botón izquierdo y arrastrando el ratón sobre ellas). se usa el editor de datos R en su lugar para mostrar la serie de datos. un modelo lineal generalizado. proporcionado por la función showData del paquete relimp de David Firth. El visor de la serie de datos puede permanecer abierto mientras se realizan otras operaciones3 . pero si lo hacen. Cuando el número de variables excede el límite (inicialmente jado en 100). las líneas siguientes a la primera deberán sangrarse con uno o más espacios o tabulaciones. Las 3 El visor de datos. La mayoría de los menús y diálogos en R Commander se reeren a la serie de datos activa (los menús Fichero. 4 . un modelo logit multinominal o un modelo lineal de regresión4 . • Un botón horizontal indica el nombre del modelo estadístico activo.txt en el directorio etc de R. je el límite en 0. puede ir lento con series de datos con gran número de variables. • El botón horizontal que se encuentra más a la izquierda muestra el nombre de la serie de datos activa. 4 Los usuarios pueden proporcionar clases adicionales de modelos estadísticos añadiendo los cuadros de diálogo necesarios y las opciones de menú. Puede editar el texto en la ventana de instrucciones o incluso escribir sus propias instrucciones R en la ventana. que está a la derecha debajo de la ventana de instrucciones (o. Las instrucciones introducidas en la ventana de instrucciones pueden ocupar más de una línea. y Ctrl-s abre una ventana de diálogo para guardar los contenidos de la ventana. Si hay más de un modelo en la memoria. • Los dos botones contiguos le permiten abrir el editor de datos de R para modicar la serie de datos activa o el visor para examinarla.

Entrada de datos La mayoría de los procesos en R Commander asumen que hay un conjunto de datos activo6 . ) conduce a un cuadro de diálogo.90 NA 2. podrá elegir entre ellos. 5 . Se pueden realizar cambios en esta conguración a través del menú Herramientas→Opciones. . Access o dBase. Si hay varios conjuntos de datos en la memoria. Una vez que ha cargado el paquete Rcmdr. así como Introducir y analizar tablas de doble entrada a través del menú Estadísticos→Tablas de contingencia. Cuando R Commander se inicia. 6 Los procesos seleccionados mediante el menú Distribuciones son excepciones. Si reajusta R Commander. desde otro paquete estadístico (Minitab. Esta es una opción razonable para un conjunto de datos pequeño. ya sea escribiendo el nombre del conjunto de datos (si lo conoce) o seleccionando el conjunto de datos en un cuadro de diálogo.1. la conguración por defecto se ha descrito aquí. Los mensajes de error se muestran en rojo.81 52 infant. . Puede importar datos desde un archivo de texto sin formato (ascii) o el portapapeles. o desde un conjunto de datos de Excel. 7 Este archivo se encuentra en el subdirectorio etc del paquete Rcmdr.txt7 Las primeras líneas del archivo son las siguientes: Afghanistan Albania Algeria TFR contraception 6. mucho más extensamente. .60 NA 3. SPSS o Stats).instrucciones escritas en esta ventana aparecen en rojo y los resultados en azul oscuro (como en la R Console).e. Al nal hay una pequeña ventana de texto gris para mensajes. estableciendo las opciones en R. pero sólo uno estará activo. o. En este documento→representa una opción de menú o un submenú de un menú. . R Commander proporciona varias maneras de introducir datos en R: Puede introducir los datos directamente a través de Datos→Nuevo conjunto de datos. 2.5 Ver la ayuda de Rcmdr para más detalles. R Commander es altamente congurable.mortality 154 32 44 GDP 2848 863 1531 region Asia Europe Africa 5 Una opción de menú que termine en elipses (p. Puede leer un conjunto de datos que esté incluido en un paquete R. no hay ningún conjunto de datos activo. . La ventana R Commander puede ser reajustada o maximizada de la manera usual. tres puntos. puede minimizar la R Console. 2. considere el archivo de datos Nations. el ancho de los resultados R subsiguientes automáticamente se ajustará para encajar en la ventana de resultados. los avisos en verde y otros mensajes en azul oscuro.. esto es un consenso estándar de la GUI. Leer datos desde un archivo de texto Por ejemplo.

en particular. y podría usarse para representar diferentes conjuntos de datos. R Commander distingue entre las variables numéricas y los factores. Los nombres R válidos comienzan con una letra mayúscula o minúscula (o un punto. Naciones y NACIONES. Para leer un archivo de datos en R..70 1. seleccionar Datos → Importar datos → desde archivo de texto o portapapeles. Pulsamos en 6 . como se ha hecho aquí.89 NA NA NA 53 NA 22 76 11 NA 124 24 22 25 6 NA NA 355 6966 8055 354 20046 Oceania Europe Africa Americas Americas Europe Oceania La primera línea del archivo contiene los nombres de las variables: TFR (tasa total de fertilidad. expresada como el número total de niños por mujer). por lo que.e. Algunos de los valores faltan. También debería saber que R es sensible a las mayúsculas. Cuando los datos son leídos.) y consisten enteramente en letras. 0-9). Aunque es útil alinear los datos verticalmente. En consecuencia (gura ??). hay cinco nombres de variables pero seis valores en cada línea. En R. GDP (producto doméstico bruto per cápita. Dese cuenta de que las líneas de datos comienzan con los nombres de los países. lo más conveniente es usar NA (que representa no disponible (not available) para codicar los valores que faltan. Las variables TFR. infant. R tratará region como un factor. se convierte en el conjunto de datos activo en R Commander. no se incluirá ningún espacio en un nombre de conjunto de datos. se distingue entre naciones. Pulsando sobre el botón Aceptar que se encuentra en Leer datos desde archivo de texto o portapapeles se abre el cuadro de diálogo Abrir para abrir archivos.69 NA 2. contraception.mortality (la tasa de mortalidad infantil por cada 1000 nacidos vivos).American-Samoa Andorra Angola Antigua Argentina Armenia Australia NA NA 6. R interpreta que el primer valor de cada línea es el nombre de la la. puntos. Como queremos que éstos sean los nombres de cada la para el conjunto de datos. una variable categórica. Nos dirigimos hacia el archivo Nations.. como se muestra en la gura ??. uno o más espacios o tabulaciones. como se muestra en la gura ??. Las líneas siguientes contienen los valores de estos datos. el nombre del conjunto de datos aparece en el botón de conjunto de datos que está arriba a la izquierda en la ventana R Commander.. region contiene nombres de regiones. una línea por país. por ejemplo. Esta operación abre un cuadro de diálogo llamado Leer datos desde archivo de texto o portapapeles. es decir. en dólares americanos) y region (región). no es necesario hacerlo. subrayados (_) y números (p. por el contrario. Cuando esto sucede. no hay un nombre de variable que le corresponda: Esto es.txt. Los valores de datos están separados por espacio en blanco.mortality y GDP son variables numéricas (cuantitativas). En la mayoría de los contextos. en porcentaje). contraception (la tasa de uso de contraceptivos entre las mujeres casadas. Presionando el botón Abrir se leerá el archivo de datos.62 1. . Una vez que éste se ha leído. infant.

. semejante a una hoja de cálculo.Figura 3: Lectura de datos desde un archivo de texto. una nota aparece en la ventana de mensajes (que desaparece cuando la siguiente instrucción showData se ejecuta). puede proceder como se explica a continuación. Los conjuntos de datos en R Commander son conjuntos de datos en R.table crea un conjunto de datos R. en los menús de R Com7 . parcialmente tapados por la visualización del conjunto de datos. hemos usado un conjunto de datos muy pequeño del problema 2. el botón Visualizar conjunto de datos para abrir la ventana del visor de datos. Cuando el conjunto de datos se lee y se convierte en el conjunto de datos activo. que es un objeto que contiene un conjunto de datos en el formato casos por variables: Las las del conjunto de datos representan los casos o las observaciones y las columnas las variables. Dese cuenta de que las instrucciones para leer y ver el conjunto de datos Nations (las instrucciones de R read.. Para ilustrar ésto.2.44 de Moore (2000): Seleccione Datos→Nuevo conjunto de datos. como también se muestra en la gura ??. Introducir datos directamente Para introducir datos directamente en el editor de datos.table y showData) aparecen. en las ventanas de instrucciones y de resultados. La instrucción read. 2.

Figura 4: Diálogo para abrir un archivo para la lectura de datos en un archivo de texto. (Recuerde que los nombres en R no pueden incluir espacios). Esto abrirá la ventana Editor de datos con un conjunto de datos vacío. presionando Tab o Enter. Opcionalmente puede introducir un nombre para el conjunto de datos. como por ejemplo Problem2. El conjunto de datos que ha introducido es ahora el conjunto de datos activo en R Commander. Repita este procedimiento para nominar a la segunda columna height. o situándose sobre la celda con el ratón y pulsando con el botón izquierdo. A continuación. para cerrar la ventana.44. como en la gura ??. en el cuadro de diálogo resultante. justo como hemos hecho. Escriba como nombre de la variable edad. Seleccione Fichero→Cerrar en los menús del Editor de datos o pulse en la X de la esquina superior derecha de la ventana Editor de datos. El Editor de datos debería parecerse ahora a la gura ??. 8 . o presione la tecla Enter. mander. y pulse sobre la X que se encuentra en la esquina superior derecha de la ventana Editor de variables. la ventana debería parecerse a la gura ??. Cuando haya acabado de introducir los datos. Introduzca los datos del problema en las dos primeras columnas del editor de datos. y luego pulsar en el botón Aceptar. Puede desplazarse de una celda a otra usando las echas del teclado. Esto abrirá un cuadro de diálogo llamado Editor de variables. pulse sobre el nombre var1 en la primera columna.

Si intenta leer datos que no se encuentran en estructuras de datos. Una buena GUI debería 8 No todos los datos en paquetes son estructuras de datos y sólo las estructuras de datos son adecuadas para usarse en R Commander.Figura 5: Mostrando el conjunto de datos activo. 9 En general en R Commander. Si sabe el nombre de un conjunto de datos en un paquete.3. cuando es necesario copiar un dato desde una lista a otra localización en el diálogo. al hacer una doble pulsación sobre el nombre de un paquete se muestra su conjunto de datos listado en el cuadro de la derecha.8 El cuadro de diálogo resultante se muestra en la gura ??. basta con una doble pulsación. Describiremos simplemente unos ejemplos básicos a continuación.9 Puede adjuntar paquetes R adicionales en Herramientas→Cargar paquete(s). y haciendo una doble pulsación sobre el nombre del conjunto de datos se copia el nombre al campo de entrada del conjunto de datos. 9 . en caso contrario. Crear resúmenes numéricos y grácas Una vez que hay un conjunto de datos activo. Lectura de datos desde un paquete Muchos paquetes R contienen datos. 2. puede usar los menús de R Commander para generar varios resúmenes numéricos y grácas. Los conjuntos de datos en paquetes pueden listarse en una ventana desplegable a través de Datos→Conjunto de datos en paquetes→Leer conjunto de datos desde paquete adjunto. aparecerá un mensaje de error en la ventana de mensajes de abajo. entonces puede introducir el nombre directamente. 3.

ser ampliamente autoexplicativa: esperamos que una vez que vea cómo funciona R Commander. el primer y el tercer cuartil. R informa de los valores máximos y mínimos. Recuerde que puede cambiar el conjunto de datos activo pulsando en el botón horizontal con el nombre del conjunto de datos activo que se encuentra arriba a la izquierda de la ventana R Commander. seleccionando Estadísticos→Resúmenes→Resúmenes numéricos. le sea fácil usarlo. En los ejemplos de más abajo.mortality y GDP). infant. el factor región falta. intentando protegernos de producir una no deseada voluminosa cantidad de resultados. Si por el contrario escribió los datos manualmente desde Moore (2000) siguiendo los cinco pasos descritos arriba. leído desde un archivo de texto en la sección anterior. asistido.. como también se describió más arriba. obtendrá la gura ??. quizás. Figura 7: Cuadro de diálogo para cambiar el nombre de una variable en el editor de datos. Para cada variable numérica en el conjunto de datos (TFR.mortality y a continuación en Aceptar se obtiene el 10 . por la ayuda en línea. Para la variable categórica region.. Si el conjunto de datos hubiera incluido más de diez variables. Sólo las variables numéricas se muestran en la lista de variables de este diálogo. De manera similar. R Commander nos habría preguntado si realmente queremos continuar. así como el número de valores que faltan. contraception. se abre el cuadro de diálogo mostrado en la gura ??. asumimos que el conjunto de datos activo es Nations. Seleccionando Estadísticos→Resúmenes→Conjunto de datos activo. porque no es razonable calcular resúmenes numéricos para un factor. o leyó el conjunto de datos Prestige del paquete car. obtenemos el número de observaciones en cada nivel del factor.Figura 6: Editor de datos una vez que se han introducido los datos. la mediana. seleccionando entre los conjuntos de datos listados actualmente en la memoria. la media. Pulsando en infant. entonces uno de estos es el conjunto de datos activo.

mortality].75604 2 12 30 66 169 201 6 Por defecto. Debido a que sólo hay un factor en el conjunto de datos Naciones. y NA es el número de valores que faltan. el tercer cuartil y el máximo. El botón Ayuda conduce a una página de ayuda. presionando la tecla mayúsculas mientras pulsa con el botón izquierdo extenderá la selección. la instrucción R que se ejecuta calcula la media y la desviación estándar (sd) de la variable. quantiles)) mean sd 0 % 25 % 50 % 75 % 100 % n NA 43. el cuadro de diálogo resúmenes numéricos de la gura ?? incluye los botones Aceptar.infant. En estos casos. la mediana. se abre el diálogo Grupos. ya sea para el diálogo en sí o (como en este caso) para la función R a la que el diálogo alude. Cancelar y Ayuda. Como es típico en los diálogos de R Commander.10 > numSummary(Nations[. statistics=c(mean. . se aplican los consensos de Windows habituales: pulsando con el botón izquierdo del ratón sobre una variable la selecciona y también deshace la selección de cualquier variable que haya sido previamente seleccionada. . y Ctrl + botón izquierdo conmuta la selección por una variable individual. sd. 11 . n es el número de observaciones válidas. junto con los cuantiles correspondientes con el mínimo. siguiente resultado (en la ventana de resultados). El cuadro de diálogo resúmenes numéricos también tiene en cuenta para calcular resúmenes los grupos denidos por los niveles de un factor. como se muestra en la gura ??. el primer cuartil. Figura 9: Lectura de datos desde un paquete adjunto. En algunos contextos. Pulsando en el botón Resumir por grupos. tendrá que (o querrá) seleccionar más de una variable. solamente la variable 10 Para seleccionar una sola variable en la lista de variables del cuadro. simplemente pulse con el botón izquierdo sobre su nombre.47761 38.Figura 8: La ventana Editor de datos tras haber cambiado los nombres de las dos variables.

00 8.5 36.mortality].79167 29..980001 5 22.75 135 n 55 40 41 41 24 NA 0 1 0 4 1 Otros diálogos de R Commander le permiten seleccionar una variable grupo de esta manera.85366 7. seleccionando Gráficas→Histograma. al seleccionar esta variable y pulsando en Aceptar se cambia el botón Resumir por grupos a Resumir por region (ver gura ??)..0 35.188095 7 61.infant.00 37.0 111. Figura 10: Obtener resúmenes de variables para el conjunto de datos activo.0 16.27273 35.mortality 12 .439713 6 12.60000 17. Por ejemplo.00 21.00 85. y pulsando en infant.122363 5 6. statistics=c(mean.65854 32. en los menús de R Commander se abre el cuadro de diálogo Histograma de la gura ??.00 82 Asia 45. sd. groups=Nations$region. Hacer grácas con R Commander también es sencillo.00 32 Oceania 27.00 154 Europe 11. al pulsar en Aceptar aparece el siguiente resultado: > numSummary(Nations[.región aparecerá en la lista de variables.25 20. quantiles)) mean sd 0 % 25 % 50 % 75 % 100 % Africa 85.00 169 Americas 25.0 72.622229 2 9.

seguido de Aceptar se abre la ventana Graphics Device con el histograma que se muestra en la gura ??. Figura 12: Selección de una variable agrupadora en el cuadro de diálogo Grupos. aparecen en la ventana especial RGL device. Aunque los cuadros de diálogo resultantes dieren en ciertos detalles (por ejemplo.Figura 11: Cuadro de diálogo Resúmenes Numéricos. Modelos estadísticos Varios tipos de modelos Estadísticos pueden ajustarse en R Commander usando las opciones de menú Estadísticos→Ajuste de modelos: modelos lineales (a través de Regresión Lineal y Modelo lineal). . 2003) a través de Modelos→Grácas→Gráca de los efectos. normalmente sólo aparecerá la más reciente en la ventana Graphics Device. R Commander pone en marcha el mecanismo del historial gráco. de la misma manera. Si hace varias grácas en una sesión. Los diagramas de dispersión dinámicos tridimensionales creados mediante Grácas →Grácas 3D→Diagrama de dispersión en 3D. respectivamente]. modelos logit multinominal y modelos ordinales de regresión [los dos últimos desde los paquetes nnet y MASS de Venables y Ripley (2002). el diálogo del modelo lineal generalizado facilita la selección de 11 Al inicio. . modelos lineales generalizados. aparecen en una ventana individual de dispositivo gráco. Puede recuperar las grácas previas usando las teclas Page Up y Page Down de su teclado11 . 13 . las muestras de efecto creadas para modelos estadísticos (Fox. 4. . . esta característica sólo está disponible en los sistemas con Windows.

por ejemplo. si está vacío. La explicación siguiente asume la familiaridad con la fórmula del modelo R. al cual puede acceder a través del menú Ayuda en R Console. ver. en caso contrario. al lado derecho (con un signo + precediéndolo si el contexto lo requiere). al lado izquierdo de la fórmula. Dese cuenta de que los factores (variables categóricas) aparecen etiquetados como tales entre paréntesis en la lista de variables. una familia de distribución y el correspondiente link para la función). 14 . comparten una estructura general común. el manual Introducción a R que viene con R. tiene que hacerlo para. La la de botones sobre la fórmula puede usarse para introducir operadores y paréntesis en el lado derecho de la fórmula. por ejemplo. de hecho. introducir un término tal como log(income) en la fórmula. Figura 14: Diálogo Histograma.12 Al hacer una doble pulsación sobre una variable en el cuadro con la lista de variables la copia a la fórmula del modelo. en el cual la variable de respuesta y las variables explicativas se seleccionan simplemente por el nombre desde una lista que contiene las variables numéricas del conjunto de datos actual.Figura 13: Cuadro de diálogo Resúmenes Numéricos tras seleccionar una variable agrupadora. como se ilustra en el diálogo Modelo lineal de la gura ??. También puede teclear directamente en los campos para las fórmulas y. 12 Una excepción es el diálogo Regresión lineal.

pasa al argumento subset de la función lm. aquí LinearModel. data=Prestige) > summary(LinearModel.1 sea el modelo activo. y hace que LinearModel.1.lm(prestige∼ (education + income )∗type . Figura 16: Cuadro de diálogo Modelo lineal.Figura 15: Una ventana de grácas que contiene el histograma para mortalidad infantil. como teclear ! = prof (lo cual seleccionaría todas las ocupaciones no profesionales del conjunto de datos Prestige). Pulsando el botón Aceptar aparece el siguiente resultado (en la ventana de resultados).1) 15 . con su nombre en el botón Modelo: > LinearModel. El nombre del modelo. es generado automáticamente. si está permitido. pero puede sustituirlo por cualquier nombre R válido. y se usa para ajustar el modelo a un subconjunto de las observaciones en el conjunto de datos. Puede escribir una expresión R en el cuadro llamado Expresión de selección. Una forma de expresión del subconjunto es la expresión lógica que evalúa cada observación como TRUE o FALSE.1 <.

data = Prestige) Residuals: Min 1Q Median 3Q Max -13.2 238.588e-05 ∗ ∗ ∗ education income type education:type income:type Residuals  Signif.prof] type[T.001060 ∗∗ 0. Error 7.prof] education:type[T.wc] education:type[T.713e+00 3.05 `.1 ` ' 1 16 .631 Coecients: (Intercept) education income type[T.940e-04 t value 0.2844 0.289e+00 1.7532 28.64 on 8 and 89 DF.535e+01 -3. Adjusted R-squared: 0.291e+00 -2.' 0.413e-06 ∗ ∗ ∗ 7.wc]  Estimate 2.847 -2.Call: lm(formula = prestige∼(education + income) ∗ type. 0.323 1.2e-16 Las operaciones en el modelo activo pueden seleccionarse en el menú Modelos.318 Pr(> |t|) 0.9859 11.8634 F-statistic: 77.0607 .001 `∗∗' 0.077 2.225 1.903e-03 -2.346 3.765e+01 1. Modelos→Test de hipótesis→Tabla ANOVA da el siguiente resultado: > Anova(LinearModel.119 -1.442 -4. codes: 0 `∗ ∗ ∗' 0.354e+01 1.2660 0.9210 Pr(>F) 1.0 1131.3544 7. codes: 0 `∗ ∗ ∗' 0.388e+00 4.9 591.wc] income:type[T.01 `∗' 0.62e-09 ∗ ∗ ∗ 0.790 6.462 -4.0166 ∗ 5.332 1.522e-03 1.prof] income:type[T.057e+00 9.7478 0.563e-04 1.989e-04 8.318 on 89 degrees of freedom Multiple R-Squared: 0.4 951.8747. 9.055574 .1) Anova Table (Type II tests) Response: prestige Sum Sq 1068.276e+00 1.900 1.01 `∗' 0.572e-01 5.' 0. 2.28e-06 ∗ ∗ ∗ 0.372e+01 1.1 ` ' 1 Residual standard error: 6.0769 .0228 ∗ Signif.757e+00 5.4044 2. Por ejemplo.001 `∗∗' 0.05 `.826 19. p-value: > 2.9 Df 1 1 2 2 2 89 F value 26.072e-03 Std.511e-07 ∗ ∗ ∗ 0.8 3552.

en el cual podrá seleccionar Copiar como metarchivo13 .5. o pulsar con el botón derecho sobre el gráco para abrir un menú contextual. seleccione Fichero→Copiar al portapapeles→como Metarchivo en los menús de Graphics Device.. De esta manera. Generalmente es más conveniente. seleccione el texto con el ratón. Alternativamente. 5.1. en este caso. o incluso Windows WordPad. Un punto que merece la pena mencionar es que también debería usar una fuente monoespaciada (typewriter). como Courier New. Excepciones y nal 5. 13 Como podrá ver cuando examine estos menús. respectivamente. Por ejemplo. sin embargo. Puede encontrar otras rutas alternativas para guardar resultados de texto y grácos en los menús de R Commander Fichero y Gráficos→Guardar gráfico en archivo. tal y como haría para cualquier aplicación de Windows. Las instrucciones generadas por R Commander aparecen en la ventana de instrucciones. luego pegue el gráco en su procesador de texto mediante Editar→Pegar (o Ctrl-v). introducir y ejecutar instrucciones. se le preguntará si quiere guardar el área de trabajo R (p. normalmente contestará No. para los resultados de R. y usted puede teclear y editar instrucciones en la ventana más o menos como en cualquier editor. puede usar Ctrl-w para copiar el gráco desde Graphics Device de R. Salvar y guardar resultados Puede guardar sus resultados de texto usando el menú Fichero en R Commander. obteniendo un registro anotado de su trabajo.3.2. y luego pegue el texto en la ventana del procesador de texto a través de Edición→Pegar (o Ctrl-v). llevar el resultado de texto y los grácos que quiera guardar a un documento de un procesador de texto. Del mismo modo. como Word. o pulse con el botón derecho en la ventana y seleccione Copiar en el menú contextual). Terminar la sesión en R Hay varias maneras de terminar su sesión en R. Sin embargo. y elija Copiar del menú Editar (o presione la combinación de teclas Ctrl-c. Para copiar el texto de la ventana de resultados. de la misma manera. puede intercalar los resultados de R con sus notas y explicaciones propias. De la misma manera. Se le pedirá que conrme si desea salir. 5. puede seleccionar Fichero→Salir→ de Commander y R en los menús de R Commander.e. y a continuación si quiere guardar los contenidos de la ventana de instrucciones y de resultados. para copiar un gráco. Abra un procesador de texto. puede guardar los grácos en una variedad de formatos 17 . Al nal de su sesión en R puede guardar o imprimir el documento que ha creado. los datos que R guarda en la memoria). Introducir instrucciones en la ventana de instrucciones La ventana de instrucciones proporciona facilidades sencillas para editar. puede guardar o imprimir un gráco desde el menú Fichero de la ventana Graphics Device. de otra manera el resultado no se alineará adecuadamente. puede seleccionar Fichero→Salir en R Console.

[2] Fox. todas las líneas de una instrucción multilínea deberán ser ejecutadas simultáneamente para obtener resultados. D. New York. Fourth Edition. un editor de programas. Referencias [1] Fox. Modern Applied Statistics with S. no son tratados adecuadamente a no ser que cada instrucción termine con un punto y coma (. The R Commander: A basic-statistics graphical user interface to R. . Journal of Statistical Software. . Journal of Statistical Software. . . W. 8(15):1-27. o. New York. | . Por otro lado. las tareas hechas con el signo igual (=) producen una salida impresa incluso cuando normalmente no lo harían (e..e. (2003).txt en el directorio etc de R Commander. The Basic Practice of Statistics.Guardar el entorno de trabajo R como. . A. . Este comportamiento puede modicarse editando las entradas del archivo log-exceptions.g.). y conlleva que la ventana de instrucciones tenga un uso limitado como editor de programas.R Commander no proporciona una verdadera consola para R. D. Para programación R seria. Eect displays in R for generalised linear models.Guardar los resultados. [3] Moore. S. .Guardar los resultados como. (2005).Salir . sería preferible usar el editor de instrucciones proporcionado por la versión de R para Windows. Freeman. x = 10). . aún mejor. por ejemplo]. Las instrucciones que normalmente dan resultados invisibles ocasionalmente harán que los resultados aparezcan en la ventana de resultados. and Ripley. (2002). Menú Rcmdr Fichero . B. p. incluso si este resultado habría aparecido normalmente si se hubiera introducido la instrucción en R Console [la instrucción print(x< −10). 19(9):1-42.Guardar las instrucciones como. N.. . J. Los bloques de instrucciones entre paréntesis. . (2000).Guardar las instrucciones | . . | . y la ventana de instrucciones tiene algunas limitaciones: Las instrucciones que se extiendan más allá de una línea deberían tener la segunda y siguientes líneas sangradas con uno o más espacios o tabulaciones. . Second Edition.Abrir chero de instrucciones. Este es el estilo R pobre. | . | . Las instrucciones que incluyan una echa de asignación (< −) no generarán un resultado impreso.Guardar el entorno de trabajo R. Springer. [4] Venables. | .De Commander 18 . . J. | .

| | . .Variables del conjunto de datos activo | | .Añadir números de observaciones al conjunto de datos | . Access o dBase. . | Conjunto de datos activo .Distribución de frecuencias. .Seleccionar conjunto de datos activo.Lista de conjuntos de datos en paquetes | | .Segmentar variable numérica. . . . . .Resúmenes Numéricos.Denir contrastes de un factor.Exportar el conjunto de datos activo. .Nuevo conjunto de datos. . | | . .Eliminar variables del conjunto de datos. . | | . | | . .Recodicar variables.Número de observaciones ausentes | | . .desde datos STATA. . . | . . . . . | . | | . . | | . | | . .Establecer nombres de casos.Borrar | .Convertir variable numérica en factor. . | . .Apilar variables del conjunto de datos activo. . . . | | .Cortar | .Eliminar los casos con valores omitidos. . . . . | .Tabla de estadísticas.Filtrar el conjunto de datos activo.Buscar.desde datos Minitab | | .Renombrar variables.Calcular una nueva variable | . | Conjunto de datos en paquetes .desde datos SPSS. . .Ayuda sobre el conjunto de datos activo (si es posible) | | .Conjunto de datos activo | | . Estadísticos .Importar datos . . | | . .Guardar el conjunto de datos activos. .Test de normalidad de Shapiro-Wilk. | .De Commander y R Editar . .desde archivo de texto o portapapeles.Reordenar niveles de factor.Copiar | . . . . . | . .Limpiar ventana | . | .Pegar | . . .| . .Tipicar variables. | | . | .Modicar variables del conjunto de datos activo . | | . . | .Matriz de correlaciones. 19 . . . . . .Seleccionar todo Datos . . .Cargar conjunto de datos.Leer conjunto de datos desde paquete adjunto. | . . . | | .Actualizar conjunto de datos activo | | .Test de correlación | | . . | | .desde Excel.Resúmenes . | .

Medias . | .Tabla de doble entrada. . . .Diagrama de dispersión en 3D. . .Tablas de contingencia .Gráca 3D RGL.Modelo lineal generalizado. | . | . . . | . | .Gráca secuencial. | .Gráca de tallos y hojas. | .Análisis dimensional .Ajuste de modelos . . . . .ANOVA de múltiples factores.Modelo ordinal de regresión. . . . | .Guardar gráco en chero .Test de Levène . | . . . | . . . | .Gráca XY. .| | | | | | | | | | | | | | | | | | | | | | | | | . .Test F para dos varianzas.Modelo lineal. . . . . . | | .Test t para muestras independientes. .Tabla de entradas múltiples.Análisis factorial.Identicar observaciones con el ratón | | . . . | . . . . .Guardar gráco en chero. . . . . . | .Gráca de líneas.como mapa de bits.Test de Wilcoxon para dos muestras. . . | . .Resumir la agrupación jerárquica. . . .Matriz de diagramas de dispersión.Gráca de barras. .Test de Bartlett | .Gráca de sectores. . .Agregar la agrupación jerárquica al conjunto de datos.ANOVA de un factor. . . . . .Histograma. . .Modelo logit multinominal.Test de proporciones para una muestra. . .Grácos 3D . . | .Test de proporciones para dos muestras. Grácas . 20 .Fiabilidad de escala. .Test de Wilcoxon para muestras emparejadas. | . . . .Gráca de las medias. .Test de Kruskal-Wallis.Gama de colores | . | . . . . | . . . . | . . . | . . .Análisis de agrupación . . . . . . . | .Regresión lineal. .Test t para datos relacionados.Agrupación jerárquica.Varianzas . | . | .Análisis de componentes principales. .como PDF/Postscript/EPS. | . . | . .Gráca de comparación de cuantiles. | .Agrupación por k-medias. . . | . .Diagrama de dispersión. . . | . . | .Diagrama de caja.Introducir y analizar una tabla de doble entrada. . . . | . | . . | . | .Proporciones . | .Test no paramétricos .Test t para una muestra. | .

| | | . . | | | . . . . . . .distribución normal .Distribuciones continuas . | | | .Distribución beta . . .Grácas básicas de diagnóstico | . .Intervalos de conanza.Cuantiles Chi-cuadrado.Gráca de comparación de cuantiles de los residuos. | | . . .Distribución uniforme . .Distribución t .Probabilidades F. .Test de Durbin-Watson para autocorrelación. | | . .Probabilidades Chi-cuadrado. | | | .Modelos . .Muestra de una distribución beta. . | | | . . | .Probabilidades normales. . . | | .Gráca de la distribución beta.Grácas .Tabla ANOVA | .Gráca de variables agregadas | . . | . | | | . | | | .Hipótesis lineal. | | | . . . | | | . . | | . | . | | | . | | . .Factores de inación de varianza | | . | | .Probabilidades uniformes.Test de valores atípicos de Bonferroni | .Cuantiles normales.Gráca de inuencia | . | | .Gráca de la distribución normal. .Gráca de los efectos Distribuciones . . . | | | . . .Muestra de una distribución exponencial.Probabilidades t. | . . . | . . | | | .Muestra de una distribución uniforme. . . . | | | .Probabilidades beta.Selecciona el modelo activo. | | | .Gráca de la distribución Chi-cuadrado. . .Muestra de una distribución normal.Comparar dos modelos. . . . . . . .Resumir el modelo | . . | | | . .Diagnósticos Numéricos .Muestra de una distribución Chi-cuadrado.Test de Breusch-Pagan para heteroscedasticidad. . . | | | . .Distribución exponencial . .Gráca de la distribución exponencial. .Cuantiles beta. . | | . | . | | | .Distribución F . . | | .Gráca de la distribución uniforme.Gráca de la distribución F.Test de hipótesis . | | | . . | | | . . . 21 . .Añadir las estadísticas de las observaciones a los datos.Distribución Chi-cuadrado .Muestra de una distribución t. .Test RESET de no linealidad. .Gráca de componentes + residuos | . . .Gráca de la distribución t. .Probabilidades exponenciales. . . . | | | .Cuantiles exponenciales. . | | | .Muestra de una distribución F. .Cuantiles t. .Cuantiles uniformes. . .Cuantiles F. . . .

. . .Cuantiles binomiales. . . | | | . | | | .Cuantiles logísticos.Muestra de una distribución gamma. . | | | . | | | . . . . | | | . . .Distribución logística . .Muestra de una distribución Gumbel. | | | . | | | . .Muestra de una distribución de Poisson.Gráca de la distribución logística. . | | | . | .Probabilidades hipergeométricas acumuladas. . .Probabilidades de Poisson acumuladas. . . . . . . .Gráca de la distribución lognormal.Probabilidades binomiales.Gráca de la distribución Weibull. | | | .Probabilidades de Poisson. . | | | . . | | | . .Distribución lognormal . | | | .Cuantiles geométricos. | | | . .Gráca de la distribución de Cauchy. | | | . . | | . .Cuantiles hipergeométricos. | | | .| | . . . | | .Muestra de una distribución de Cauchy. . | | | . . . . . . . | | . .Muestra de una distribución logística.Gráca de la distribución binomial negativa. | | | .Distribución Weibull . . . | | | . . | | | . . | | | . . | | . | | | . .Probabilidades binomiales negativas. | | .Cuantiles de Poisson. . .Distribución binomial . . .Distribuciones discretas . . | | | . | | | . . . | | | .Gráca de la distribución geométrica.Distribución Gumbel . | | | . .Cuantiles de Cauchy. | | | . | | | . . .Gráca de la distribución gamma. . | | | . . | | | .Muestra de una distribución Weibull. . .Gráca de la distribución de Poisson. . . .Distribución de Cauchy . . . . . | | | .Distribución gamma . | | .Probabilidades gamma.Cuantiles binomiales negativos. .Probabilidades de Cauchy. . .Distribución de Poisson . . | | | . .Cuantiles gamma. . | | . .Muestra de una distribución binomial. | | | . .Muestra de una distribución binomial negativa. . | | | . 22 .Probabilidades geométricas.Probabilidades geométricas acumuladas. .Gráca de la distribución binomial.Probabilidades lognormal. .Cuantiles lognormal. | | | .Muestra de una distribución geométrica. . .Gráca de la distribución Gumbel.Distribución binomial negativa .Probabilidades Gumbel. . . . . . . . . .Distribución geométrica . .Muestra de una distribución hipergeométrica.Probabilidades logísticas.Muestra de una distribución lognormal.Gráca de la distribución hipergeométrica. . | | | .Probabilidades binomiales negativas acumuladas. | | . . .Distribución hipergeométrica . . . | | | .Cuantiles Weibull. | | .Cuantiles Gumbel | | | .Probabilidades binomiales acumuladas. .Probabilidades hipergeométricas. | | | . .Probabilidades Weibull.

Cargar plug-in(s) de Rcmdr | .Ayuda de R Commander | .Información sobre Rcmdr 23 . | . Ayuda .Opciones.Herramientas . . .Introducción a R Commander | .Ayuda sobre el conjunto de datos activo (si es posible) | . . .Cargar paquete(s).

You're Reading a Free Preview

Descarga
scribd
/*********** DO NOT ALTER ANYTHING BELOW THIS LINE ! ************/ var s_code=s.t();if(s_code)document.write(s_code)//-->