Alphaware©

Problemas comunes en Excel
Herramientas de Colaboración Digital
Johnny

2010

dice: =SI (E11=0. 0. qué hacer si es verdad. si es verdad mejor que no divida porque va a mostrar error. Excel marca un error y lo muestra con esta clave: #¡DIV/0!. Por lo tanto. si es verdad mejor que ponga un cero y no el error. la fórmula dice: dividir G11 entre E11. significa que su fórmula está dividiendo algo entre cero. Y Excel muestra el error. qué hacer si no es verdad) En español. dividir 0 entre 0. G11/E11) Y en un idioma intermedio dice: =SI( la celda E11 vale cero y por lo tanto voy a dividir algo entre cero. si no es verdad que sí haga la división En el idioma de las funciones de Excel. si no es verdad que sí divida lo que tengo en G11 entre lo que tengo en E11) . cada vez que vea esta clave. Para solucionarlo. se puede utilizar la función =SI() ¿Cómo? La función dice =SI ( comparación. lo que queremos que diga es: = ¿voy a dividir entre cero?. o sea. Vea la siguiente figura: Como la celda E11 no tiene valor.Cada vez que se intenta dividir una cantidad entre cero.

. Puntero en posición equivocada Puntero en la posición correcta Columna con el ancho corregido Nota: Solamente se muestran los casos más comunes. Esto agrandará la columna hasta el ancho necesario para que se pueda mostrar el número completo. la fórmula ya no se puede calcular y entonces aparece el error #¡REF!. o corregir este error de dos formas: cambiando el formato del número. Para obtener información más completa sobre este error. o haciendo más ancha la columna. Para obtener información más completa sobre este error. puede seguir cualquiera de las siguientes instrucciones (ya que todas tratan sobre cómo dar formato a los números): Para hacer más ancha la columna Posicione el puntero en la raya derecha de la columna y de doble click sobre la raya. Cuando eliminamos un renglón o una columna que era parte de una fórmula. Cuando en una celda se muestra ##### significa que el formato elegido no cabe en el ancho de la columna. consulte la ayuda de Excel. Para cambiar el formato del número. Se puede evitar que aparezca.Nota: Solamente se muestran los casos más comunes. consulte la ayuda de Excel.

. se puede simplemente borrar la parte sobrante de la fórmula (quitar #¡REF!) El error #¿Nombre? aparece normalmente cuando hay una fórmula mal escrita. La mayoría de las veces esto no es posible. ya que es normal que hagamos correcciones a la hoja luego de que hemos terminado algunas fórmulas. falten comillas o falten dos puntos. la fórmula correcta es =SUMAR(A4:C4) . Una de las causas más comunes es que haya un error de ortografía en algún lugar. Vea los dos ejemplos siguientes: Faltan los dos puntos. tenemos en D4 una fórmula que suma A4 + B4 + C4 Si borramos la columna B. ya sea haciéndola de nuevo o borrando la parte de la fórmula que dice #¡REF!. Los errores de dedo no se pueden evitar. simplemente revise la fórmula con cuidado y haga los ajustes pertinentes. Se corrige arreglando la fórmula. la fórmula en C (antes D) se descompone y queda así: Para corregir el error. Por ejemplo. Para corregir.Se evita no borrando renglones ni columnas que sean parte de una fórmula.

Por ejemplo. el argumento es A2 y en esa celda debe haber forzosamente una fecha. Si hay un texto. la fórmula no sabrá que hacer y marcará un error #¡VALOR! También aparece cuando una función no encuentra el resultado y nos sabe qué regresar. entonces la función no sabrá que dato regresar y marcará un error #¡VALOR!: Por lo tanto el error #¡VALOR! aparece normalmente cuando la fórmula o función no sabe qué valor regresar. entonces uso la función =ENCONTRAR(). no SUMAN Todas las fórmulas o funciones de Excel llevan entre paréntesis uno o varios argumentos. la función para encontrar el año que está en la celda A2 es =AÑO(A2). . Si por un error en el texto no tengo una coma. Aquí. Por ejemplo.La palabra correcta es SUMAR. ya sea porque: se puso un texto en lugar de un número o viceversa. cuando en una columna tengo las capitales y los países separados por comas y necesito saber en qué posición está la coma para poder separar capital del país.

simplemente revise la fórmula con cuidado y haga los ajustes pertinentes. Para corregir. ya sea porque: se puso un texto en lugar de un número o viceversa. BUSCARV. simplemente revise la fórmula con cuidado y haga los ajustes pertinentes. pero que no está definido en la tabla de descripciones. la función no encontró el resultado. Existen dos causa comunes cuando se presenta este error: Que la función tenga un argumento mal escrito Que no encuentre el valor buscado cuando se utiliza cualquiera de las siguientes funciones: BUSCAR. COINCIDIR no sabe qué valor regresar. BUSCARH. donde se está buscando una moneda con código BOL. En este caso. Los errores de dedo no se pueden evitar. COINCIDIR Vea el ejemplo de la figura. Para corregir. la función regresa el valor #N/A Por lo tanto el error #N/A aparece normalmente cuando alguna de las funciones BUSCAR. BUSCARV. BUSCARH.una fórmula o función no encontró el resultado. Una forma de evitarlo es utilizando la sugerencia de Fernando Vasquez: . Los errores de dedo no se pueden evitar.

no siempre tenemos el tiempo necesario para pensarlas y probarlas antes de dar por terminado el trabajo que estamos haciendo. FALSO) SI NO ENCUENTRA NADA EL RESULTADO SERIA EL VALOR DE ERROR #N/A Este se corrige utilizando la formula =SI( ESERORR( BUSCARV(B2. C8/C9) . 3. y en C8 hay un 0.C7:E14.FALSO). Si la respuesta es VERDADERO. Si la respuesta es FALSO. C7:E14. Si en C7 hay un 5. puede generar un error. digamos "hola". Para evitarlo se puede poner la siguiente fórmula: =SI ( ESERROR(C8/C9). estaríamos dividiendo entre cero por lo que Excel marca el error #¡DIV/0!. Para los casos en que sospechamos que la fórmula. y la fórmula dice C7/C8. Para evitarlo se puede poner la siguiente fórmula: =SI( ESERROR(C8/C9).FALSO) ).Se puede corregir [o más bien evitar] el resultado del Error #N/A en una fórmula de Excel de la siguiente manera =BUSCARV (B2. C8/C9) Si en C7 hay un 5 y en C8 hay un texto. estaríamos dividiendo un número entre un texto. así si el resultado es un valor de error este lo sustituye por 0 o si se le pone un valor “” dejara el resultado en Blanco o poniendo la palabra “Sin Valor” entre comillas el resultado será la palabra Sin Valor Muchos de los errores que maneja Excel pueden prevenirse con un poco de cuidado al momento de elaborar las formulas. y la fórmula dice C7/C8. bajo algunas circunstancias no controladas.3.C7:E14. significa que no hay errores y que sí se puede evaluar la fórmula. 0. 0. BUSCARV(B2. Sin embargo. por lo que Excel marca el error #¡VALOR!.3. significa que no se puede escribir un resultado y mejor hay que poner un cero o un espacio en blanco. 0. la función =ESEROR () nos puede sacar de apuros (excepto en el caso del error #! N/A¡ Lo que hacemos es probar la fórmula con =ESERROR ().

y la fórmula dice C7/C8. sí lo encontró. Excel genera el error #N/A. la función =BUSCARV() arrojará el error No Disponible #!N/A¡. C8/C9) Casi todos los errores que manda Excel se pueden detectar y controlar con la función =ESERROR (). Si así es. se utiliza la función =ESNOD () Ejemplos Si tenemos una serie números del 1 al 7 en la columna A y otra con los nombres de los días de la semana en la columna B. 0. y luego borro todo el renglón. primero se debe evaluar si la búsqueda arrojará un error.Si en C7 hay un 5 y en C8 hay un 2.. Para evitarlo. y luego buscamos con el día número 9. . estaríamos dividiendo un número entre una celda inexistente. si una búsqueda exacta con =BUSCARV () o =BUSCARH () no encuentra el valor buscado. Para este caso. significa que no encontró el valor exacto que buscaba. Sin embargo. por lo que Excel marca el error #¡DIV/0!. que en español se interpreta como No Disponible. de lo contrario. Para evitarlo se puede poner la siguiente fórmula: =SI( ESERROR(C8/C9).

Sign up to vote on this title
UsefulNot useful