P. 1
Problemas Comunes en Excel

Problemas Comunes en Excel

|Views: 9|Likes:

More info:

Published by: Jose Leonardo Perez Perez on Apr 23, 2013
Copyright:Attribution Non-commercial

Availability:

Read on Scribd mobile: iPhone, iPad and Android.
download as PDF, TXT or read online from Scribd
See more
See less

09/01/2014

pdf

text

original

Alphaware©

Problemas comunes en Excel
Herramientas de Colaboración Digital
Johnny

2010

Vea la siguiente figura: Como la celda E11 no tiene valor. si es verdad mejor que ponga un cero y no el error. se puede utilizar la función =SI() ¿Cómo? La función dice =SI ( comparación. Y Excel muestra el error. significa que su fórmula está dividiendo algo entre cero. dice: =SI (E11=0.Cada vez que se intenta dividir una cantidad entre cero. si no es verdad que sí divida lo que tengo en G11 entre lo que tengo en E11) . si no es verdad que sí haga la división En el idioma de las funciones de Excel. dividir 0 entre 0. G11/E11) Y en un idioma intermedio dice: =SI( la celda E11 vale cero y por lo tanto voy a dividir algo entre cero. lo que queremos que diga es: = ¿voy a dividir entre cero?. cada vez que vea esta clave. Por lo tanto. si es verdad mejor que no divida porque va a mostrar error. la fórmula dice: dividir G11 entre E11. qué hacer si es verdad. o sea. 0. Para solucionarlo. Excel marca un error y lo muestra con esta clave: #¡DIV/0!. qué hacer si no es verdad) En español.

Para cambiar el formato del número. la fórmula ya no se puede calcular y entonces aparece el error #¡REF!. . Cuando eliminamos un renglón o una columna que era parte de una fórmula. Para obtener información más completa sobre este error. Se puede evitar que aparezca. puede seguir cualquiera de las siguientes instrucciones (ya que todas tratan sobre cómo dar formato a los números): Para hacer más ancha la columna Posicione el puntero en la raya derecha de la columna y de doble click sobre la raya.Nota: Solamente se muestran los casos más comunes. Para obtener información más completa sobre este error. Puntero en posición equivocada Puntero en la posición correcta Columna con el ancho corregido Nota: Solamente se muestran los casos más comunes. consulte la ayuda de Excel. Cuando en una celda se muestra ##### significa que el formato elegido no cabe en el ancho de la columna. o haciendo más ancha la columna. Esto agrandará la columna hasta el ancho necesario para que se pueda mostrar el número completo. consulte la ayuda de Excel. o corregir este error de dos formas: cambiando el formato del número.

La mayoría de las veces esto no es posible. Por ejemplo.Se evita no borrando renglones ni columnas que sean parte de una fórmula. falten comillas o falten dos puntos. ya sea haciéndola de nuevo o borrando la parte de la fórmula que dice #¡REF!. Una de las causas más comunes es que haya un error de ortografía en algún lugar. Se corrige arreglando la fórmula. la fórmula correcta es =SUMAR(A4:C4) . Los errores de dedo no se pueden evitar. ya que es normal que hagamos correcciones a la hoja luego de que hemos terminado algunas fórmulas. simplemente revise la fórmula con cuidado y haga los ajustes pertinentes. Para corregir. se puede simplemente borrar la parte sobrante de la fórmula (quitar #¡REF!) El error #¿Nombre? aparece normalmente cuando hay una fórmula mal escrita. . Vea los dos ejemplos siguientes: Faltan los dos puntos. la fórmula en C (antes D) se descompone y queda así: Para corregir el error. tenemos en D4 una fórmula que suma A4 + B4 + C4 Si borramos la columna B.

entonces la función no sabrá que dato regresar y marcará un error #¡VALOR!: Por lo tanto el error #¡VALOR! aparece normalmente cuando la fórmula o función no sabe qué valor regresar. Por ejemplo. cuando en una columna tengo las capitales y los países separados por comas y necesito saber en qué posición está la coma para poder separar capital del país. entonces uso la función =ENCONTRAR(). la función para encontrar el año que está en la celda A2 es =AÑO(A2). Si por un error en el texto no tengo una coma. Aquí.La palabra correcta es SUMAR. ya sea porque: se puso un texto en lugar de un número o viceversa. la fórmula no sabrá que hacer y marcará un error #¡VALOR! También aparece cuando una función no encuentra el resultado y nos sabe qué regresar. Si hay un texto. el argumento es A2 y en esa celda debe haber forzosamente una fecha. . Por ejemplo. no SUMAN Todas las fórmulas o funciones de Excel llevan entre paréntesis uno o varios argumentos.

BUSCARH. BUSCARH. Para corregir. ya sea porque: se puso un texto en lugar de un número o viceversa. Existen dos causa comunes cuando se presenta este error: Que la función tenga un argumento mal escrito Que no encuentre el valor buscado cuando se utiliza cualquiera de las siguientes funciones: BUSCAR. BUSCARV. Una forma de evitarlo es utilizando la sugerencia de Fernando Vasquez: . simplemente revise la fórmula con cuidado y haga los ajustes pertinentes. En este caso. COINCIDIR no sabe qué valor regresar. Para corregir. Los errores de dedo no se pueden evitar. donde se está buscando una moneda con código BOL. Los errores de dedo no se pueden evitar. COINCIDIR Vea el ejemplo de la figura. pero que no está definido en la tabla de descripciones.una fórmula o función no encontró el resultado. la función regresa el valor #N/A Por lo tanto el error #N/A aparece normalmente cuando alguna de las funciones BUSCAR. BUSCARV. simplemente revise la fórmula con cuidado y haga los ajustes pertinentes. la función no encontró el resultado.

C7:E14. estaríamos dividiendo un número entre un texto. Si la respuesta es VERDADERO.3. FALSO) SI NO ENCUENTRA NADA EL RESULTADO SERIA EL VALOR DE ERROR #N/A Este se corrige utilizando la formula =SI( ESERORR( BUSCARV(B2. 0. BUSCARV(B2. Para evitarlo se puede poner la siguiente fórmula: =SI ( ESERROR(C8/C9). C7:E14.FALSO) ). y la fórmula dice C7/C8. no siempre tenemos el tiempo necesario para pensarlas y probarlas antes de dar por terminado el trabajo que estamos haciendo.C7:E14. por lo que Excel marca el error #¡VALOR!.FALSO). Para los casos en que sospechamos que la fórmula. digamos "hola". la función =ESEROR () nos puede sacar de apuros (excepto en el caso del error #! N/A¡ Lo que hacemos es probar la fórmula con =ESERROR (). así si el resultado es un valor de error este lo sustituye por 0 o si se le pone un valor “” dejara el resultado en Blanco o poniendo la palabra “Sin Valor” entre comillas el resultado será la palabra Sin Valor Muchos de los errores que maneja Excel pueden prevenirse con un poco de cuidado al momento de elaborar las formulas. C8/C9) . Sin embargo. puede generar un error. significa que no hay errores y que sí se puede evaluar la fórmula. 0. Si la respuesta es FALSO. Si en C7 hay un 5. Para evitarlo se puede poner la siguiente fórmula: =SI( ESERROR(C8/C9). 0.3. C8/C9) Si en C7 hay un 5 y en C8 hay un texto.Se puede corregir [o más bien evitar] el resultado del Error #N/A en una fórmula de Excel de la siguiente manera =BUSCARV (B2. bajo algunas circunstancias no controladas. significa que no se puede escribir un resultado y mejor hay que poner un cero o un espacio en blanco. estaríamos dividiendo entre cero por lo que Excel marca el error #¡DIV/0!. y la fórmula dice C7/C8. y en C8 hay un 0. 3.

y luego buscamos con el día número 9. estaríamos dividiendo un número entre una celda inexistente. si una búsqueda exacta con =BUSCARV () o =BUSCARH () no encuentra el valor buscado. y luego borro todo el renglón. Para evitarlo se puede poner la siguiente fórmula: =SI( ESERROR(C8/C9). de lo contrario. Para evitarlo. por lo que Excel marca el error #¡DIV/0!. C8/C9) Casi todos los errores que manda Excel se pueden detectar y controlar con la función =ESERROR (). significa que no encontró el valor exacto que buscaba. Si así es. primero se debe evaluar si la búsqueda arrojará un error. . se utiliza la función =ESNOD () Ejemplos Si tenemos una serie números del 1 al 7 en la columna A y otra con los nombres de los días de la semana en la columna B. y la fórmula dice C7/C8. que en español se interpreta como No Disponible.Si en C7 hay un 5 y en C8 hay un 2. Excel genera el error #N/A. Para este caso. la función =BUSCARV() arrojará el error No Disponible #!N/A¡. sí lo encontró. 0.. Sin embargo.

You're Reading a Free Preview

Descarga
scribd
/*********** DO NOT ALTER ANYTHING BELOW THIS LINE ! ************/ var s_code=s.t();if(s_code)document.write(s_code)//-->