Alphaware©

Problemas comunes en Excel
Herramientas de Colaboración Digital
Johnny

2010

si no es verdad que sí divida lo que tengo en G11 entre lo que tengo en E11) . si es verdad mejor que no divida porque va a mostrar error. cada vez que vea esta clave. Por lo tanto. G11/E11) Y en un idioma intermedio dice: =SI( la celda E11 vale cero y por lo tanto voy a dividir algo entre cero. la fórmula dice: dividir G11 entre E11. Y Excel muestra el error. Para solucionarlo. si es verdad mejor que ponga un cero y no el error.Cada vez que se intenta dividir una cantidad entre cero. o sea. qué hacer si no es verdad) En español. dividir 0 entre 0. Excel marca un error y lo muestra con esta clave: #¡DIV/0!. qué hacer si es verdad. Vea la siguiente figura: Como la celda E11 no tiene valor. 0. lo que queremos que diga es: = ¿voy a dividir entre cero?. se puede utilizar la función =SI() ¿Cómo? La función dice =SI ( comparación. dice: =SI (E11=0. significa que su fórmula está dividiendo algo entre cero. si no es verdad que sí haga la división En el idioma de las funciones de Excel.

. Cuando en una celda se muestra ##### significa que el formato elegido no cabe en el ancho de la columna. Para cambiar el formato del número. la fórmula ya no se puede calcular y entonces aparece el error #¡REF!. Para obtener información más completa sobre este error. Puntero en posición equivocada Puntero en la posición correcta Columna con el ancho corregido Nota: Solamente se muestran los casos más comunes.Nota: Solamente se muestran los casos más comunes. puede seguir cualquiera de las siguientes instrucciones (ya que todas tratan sobre cómo dar formato a los números): Para hacer más ancha la columna Posicione el puntero en la raya derecha de la columna y de doble click sobre la raya. consulte la ayuda de Excel. Cuando eliminamos un renglón o una columna que era parte de una fórmula. Para obtener información más completa sobre este error. Esto agrandará la columna hasta el ancho necesario para que se pueda mostrar el número completo. o corregir este error de dos formas: cambiando el formato del número. o haciendo más ancha la columna. consulte la ayuda de Excel. Se puede evitar que aparezca.

Por ejemplo. simplemente revise la fórmula con cuidado y haga los ajustes pertinentes. Los errores de dedo no se pueden evitar. La mayoría de las veces esto no es posible. la fórmula correcta es =SUMAR(A4:C4) . ya que es normal que hagamos correcciones a la hoja luego de que hemos terminado algunas fórmulas.Se evita no borrando renglones ni columnas que sean parte de una fórmula. Una de las causas más comunes es que haya un error de ortografía en algún lugar. tenemos en D4 una fórmula que suma A4 + B4 + C4 Si borramos la columna B. . Vea los dos ejemplos siguientes: Faltan los dos puntos. ya sea haciéndola de nuevo o borrando la parte de la fórmula que dice #¡REF!. Para corregir. se puede simplemente borrar la parte sobrante de la fórmula (quitar #¡REF!) El error #¿Nombre? aparece normalmente cuando hay una fórmula mal escrita. Se corrige arreglando la fórmula. la fórmula en C (antes D) se descompone y queda así: Para corregir el error. falten comillas o falten dos puntos.

Por ejemplo.La palabra correcta es SUMAR. . Si hay un texto. entonces la función no sabrá que dato regresar y marcará un error #¡VALOR!: Por lo tanto el error #¡VALOR! aparece normalmente cuando la fórmula o función no sabe qué valor regresar. el argumento es A2 y en esa celda debe haber forzosamente una fecha. la función para encontrar el año que está en la celda A2 es =AÑO(A2). entonces uso la función =ENCONTRAR(). Si por un error en el texto no tengo una coma. no SUMAN Todas las fórmulas o funciones de Excel llevan entre paréntesis uno o varios argumentos. cuando en una columna tengo las capitales y los países separados por comas y necesito saber en qué posición está la coma para poder separar capital del país. Por ejemplo. Aquí. la fórmula no sabrá que hacer y marcará un error #¡VALOR! También aparece cuando una función no encuentra el resultado y nos sabe qué regresar. ya sea porque: se puso un texto en lugar de un número o viceversa.

simplemente revise la fórmula con cuidado y haga los ajustes pertinentes. Para corregir. pero que no está definido en la tabla de descripciones. simplemente revise la fórmula con cuidado y haga los ajustes pertinentes. BUSCARH. la función regresa el valor #N/A Por lo tanto el error #N/A aparece normalmente cuando alguna de las funciones BUSCAR. Una forma de evitarlo es utilizando la sugerencia de Fernando Vasquez: . BUSCARV. COINCIDIR no sabe qué valor regresar. Los errores de dedo no se pueden evitar. BUSCARH. Para corregir. donde se está buscando una moneda con código BOL. COINCIDIR Vea el ejemplo de la figura. la función no encontró el resultado. Los errores de dedo no se pueden evitar. En este caso. ya sea porque: se puso un texto en lugar de un número o viceversa.una fórmula o función no encontró el resultado. BUSCARV. Existen dos causa comunes cuando se presenta este error: Que la función tenga un argumento mal escrito Que no encuentre el valor buscado cuando se utiliza cualquiera de las siguientes funciones: BUSCAR.

significa que no hay errores y que sí se puede evaluar la fórmula. estaríamos dividiendo entre cero por lo que Excel marca el error #¡DIV/0!. puede generar un error. significa que no se puede escribir un resultado y mejor hay que poner un cero o un espacio en blanco. Para evitarlo se puede poner la siguiente fórmula: =SI ( ESERROR(C8/C9). y la fórmula dice C7/C8. 3.3.FALSO). Para evitarlo se puede poner la siguiente fórmula: =SI( ESERROR(C8/C9).Se puede corregir [o más bien evitar] el resultado del Error #N/A en una fórmula de Excel de la siguiente manera =BUSCARV (B2. no siempre tenemos el tiempo necesario para pensarlas y probarlas antes de dar por terminado el trabajo que estamos haciendo. C8/C9) Si en C7 hay un 5 y en C8 hay un texto. 0. C8/C9) . y la fórmula dice C7/C8. Sin embargo. Si la respuesta es FALSO. bajo algunas circunstancias no controladas. Si en C7 hay un 5. por lo que Excel marca el error #¡VALOR!. 0. BUSCARV(B2. digamos "hola".3.FALSO) ). FALSO) SI NO ENCUENTRA NADA EL RESULTADO SERIA EL VALOR DE ERROR #N/A Este se corrige utilizando la formula =SI( ESERORR( BUSCARV(B2. estaríamos dividiendo un número entre un texto. 0. C7:E14. así si el resultado es un valor de error este lo sustituye por 0 o si se le pone un valor “” dejara el resultado en Blanco o poniendo la palabra “Sin Valor” entre comillas el resultado será la palabra Sin Valor Muchos de los errores que maneja Excel pueden prevenirse con un poco de cuidado al momento de elaborar las formulas.C7:E14. Si la respuesta es VERDADERO.C7:E14. y en C8 hay un 0. Para los casos en que sospechamos que la fórmula. la función =ESEROR () nos puede sacar de apuros (excepto en el caso del error #! N/A¡ Lo que hacemos es probar la fórmula con =ESERROR ().

primero se debe evaluar si la búsqueda arrojará un error. significa que no encontró el valor exacto que buscaba. si una búsqueda exacta con =BUSCARV () o =BUSCARH () no encuentra el valor buscado. sí lo encontró. la función =BUSCARV() arrojará el error No Disponible #!N/A¡. Sin embargo. estaríamos dividiendo un número entre una celda inexistente. por lo que Excel marca el error #¡DIV/0!. Excel genera el error #N/A. Para este caso. y luego borro todo el renglón. que en español se interpreta como No Disponible. . se utiliza la función =ESNOD () Ejemplos Si tenemos una serie números del 1 al 7 en la columna A y otra con los nombres de los días de la semana en la columna B. Para evitarlo se puede poner la siguiente fórmula: =SI( ESERROR(C8/C9). 0.Si en C7 hay un 5 y en C8 hay un 2. Para evitarlo. de lo contrario. y luego buscamos con el día número 9. C8/C9) Casi todos los errores que manda Excel se pueden detectar y controlar con la función =ESERROR (). Si así es. y la fórmula dice C7/C8..

Sign up to vote on this title
UsefulNot useful