Alphaware©

Problemas comunes en Excel
Herramientas de Colaboración Digital
Johnny

2010

Cada vez que se intenta dividir una cantidad entre cero. Y Excel muestra el error. lo que queremos que diga es: = ¿voy a dividir entre cero?. se puede utilizar la función =SI() ¿Cómo? La función dice =SI ( comparación. cada vez que vea esta clave. Por lo tanto. si es verdad mejor que ponga un cero y no el error. Excel marca un error y lo muestra con esta clave: #¡DIV/0!. dice: =SI (E11=0. si no es verdad que sí haga la división En el idioma de las funciones de Excel. 0. qué hacer si no es verdad) En español. significa que su fórmula está dividiendo algo entre cero. G11/E11) Y en un idioma intermedio dice: =SI( la celda E11 vale cero y por lo tanto voy a dividir algo entre cero. Vea la siguiente figura: Como la celda E11 no tiene valor. la fórmula dice: dividir G11 entre E11. si es verdad mejor que no divida porque va a mostrar error. Para solucionarlo. o sea. si no es verdad que sí divida lo que tengo en G11 entre lo que tengo en E11) . dividir 0 entre 0. qué hacer si es verdad.

Para cambiar el formato del número. consulte la ayuda de Excel. consulte la ayuda de Excel. . Para obtener información más completa sobre este error.Nota: Solamente se muestran los casos más comunes. o haciendo más ancha la columna. Para obtener información más completa sobre este error. Cuando eliminamos un renglón o una columna que era parte de una fórmula. Esto agrandará la columna hasta el ancho necesario para que se pueda mostrar el número completo. puede seguir cualquiera de las siguientes instrucciones (ya que todas tratan sobre cómo dar formato a los números): Para hacer más ancha la columna Posicione el puntero en la raya derecha de la columna y de doble click sobre la raya. Cuando en una celda se muestra ##### significa que el formato elegido no cabe en el ancho de la columna. la fórmula ya no se puede calcular y entonces aparece el error #¡REF!. o corregir este error de dos formas: cambiando el formato del número. Puntero en posición equivocada Puntero en la posición correcta Columna con el ancho corregido Nota: Solamente se muestran los casos más comunes. Se puede evitar que aparezca.

simplemente revise la fórmula con cuidado y haga los ajustes pertinentes. Para corregir. La mayoría de las veces esto no es posible. .Se evita no borrando renglones ni columnas que sean parte de una fórmula. Vea los dos ejemplos siguientes: Faltan los dos puntos. tenemos en D4 una fórmula que suma A4 + B4 + C4 Si borramos la columna B. Por ejemplo. Se corrige arreglando la fórmula. se puede simplemente borrar la parte sobrante de la fórmula (quitar #¡REF!) El error #¿Nombre? aparece normalmente cuando hay una fórmula mal escrita. ya sea haciéndola de nuevo o borrando la parte de la fórmula que dice #¡REF!. la fórmula en C (antes D) se descompone y queda así: Para corregir el error. la fórmula correcta es =SUMAR(A4:C4) . ya que es normal que hagamos correcciones a la hoja luego de que hemos terminado algunas fórmulas. Los errores de dedo no se pueden evitar. Una de las causas más comunes es que haya un error de ortografía en algún lugar. falten comillas o falten dos puntos.

Aquí. Si hay un texto.La palabra correcta es SUMAR. la fórmula no sabrá que hacer y marcará un error #¡VALOR! También aparece cuando una función no encuentra el resultado y nos sabe qué regresar. . Por ejemplo. entonces uso la función =ENCONTRAR(). la función para encontrar el año que está en la celda A2 es =AÑO(A2). entonces la función no sabrá que dato regresar y marcará un error #¡VALOR!: Por lo tanto el error #¡VALOR! aparece normalmente cuando la fórmula o función no sabe qué valor regresar. Por ejemplo. ya sea porque: se puso un texto en lugar de un número o viceversa. el argumento es A2 y en esa celda debe haber forzosamente una fecha. cuando en una columna tengo las capitales y los países separados por comas y necesito saber en qué posición está la coma para poder separar capital del país. no SUMAN Todas las fórmulas o funciones de Excel llevan entre paréntesis uno o varios argumentos. Si por un error en el texto no tengo una coma.

BUSCARH.una fórmula o función no encontró el resultado. BUSCARV. BUSCARH. Para corregir. Para corregir. Los errores de dedo no se pueden evitar. Una forma de evitarlo es utilizando la sugerencia de Fernando Vasquez: . COINCIDIR no sabe qué valor regresar. simplemente revise la fórmula con cuidado y haga los ajustes pertinentes. simplemente revise la fórmula con cuidado y haga los ajustes pertinentes. la función regresa el valor #N/A Por lo tanto el error #N/A aparece normalmente cuando alguna de las funciones BUSCAR. En este caso. ya sea porque: se puso un texto en lugar de un número o viceversa. donde se está buscando una moneda con código BOL. Los errores de dedo no se pueden evitar. BUSCARV. pero que no está definido en la tabla de descripciones. Existen dos causa comunes cuando se presenta este error: Que la función tenga un argumento mal escrito Que no encuentre el valor buscado cuando se utiliza cualquiera de las siguientes funciones: BUSCAR. la función no encontró el resultado. COINCIDIR Vea el ejemplo de la figura.

0. Si la respuesta es FALSO. estaríamos dividiendo entre cero por lo que Excel marca el error #¡DIV/0!. y la fórmula dice C7/C8. estaríamos dividiendo un número entre un texto. así si el resultado es un valor de error este lo sustituye por 0 o si se le pone un valor “” dejara el resultado en Blanco o poniendo la palabra “Sin Valor” entre comillas el resultado será la palabra Sin Valor Muchos de los errores que maneja Excel pueden prevenirse con un poco de cuidado al momento de elaborar las formulas. y la fórmula dice C7/C8. Para evitarlo se puede poner la siguiente fórmula: =SI ( ESERROR(C8/C9). FALSO) SI NO ENCUENTRA NADA EL RESULTADO SERIA EL VALOR DE ERROR #N/A Este se corrige utilizando la formula =SI( ESERORR( BUSCARV(B2. Para evitarlo se puede poner la siguiente fórmula: =SI( ESERROR(C8/C9). puede generar un error. la función =ESEROR () nos puede sacar de apuros (excepto en el caso del error #! N/A¡ Lo que hacemos es probar la fórmula con =ESERROR (). C8/C9) .3. no siempre tenemos el tiempo necesario para pensarlas y probarlas antes de dar por terminado el trabajo que estamos haciendo. digamos "hola". por lo que Excel marca el error #¡VALOR!. C7:E14. 3. Para los casos en que sospechamos que la fórmula.FALSO) ). significa que no se puede escribir un resultado y mejor hay que poner un cero o un espacio en blanco. 0. C8/C9) Si en C7 hay un 5 y en C8 hay un texto. Sin embargo. 0. bajo algunas circunstancias no controladas. significa que no hay errores y que sí se puede evaluar la fórmula. BUSCARV(B2.FALSO).C7:E14.3. Si en C7 hay un 5. y en C8 hay un 0.C7:E14.Se puede corregir [o más bien evitar] el resultado del Error #N/A en una fórmula de Excel de la siguiente manera =BUSCARV (B2. Si la respuesta es VERDADERO.

que en español se interpreta como No Disponible. primero se debe evaluar si la búsqueda arrojará un error. Excel genera el error #N/A. Para evitarlo se puede poner la siguiente fórmula: =SI( ESERROR(C8/C9). .. estaríamos dividiendo un número entre una celda inexistente. Para este caso. y la fórmula dice C7/C8. y luego borro todo el renglón. de lo contrario. y luego buscamos con el día número 9. significa que no encontró el valor exacto que buscaba. 0. Para evitarlo. la función =BUSCARV() arrojará el error No Disponible #!N/A¡. se utiliza la función =ESNOD () Ejemplos Si tenemos una serie números del 1 al 7 en la columna A y otra con los nombres de los días de la semana en la columna B. Si así es. si una búsqueda exacta con =BUSCARV () o =BUSCARH () no encuentra el valor buscado. sí lo encontró. C8/C9) Casi todos los errores que manda Excel se pueden detectar y controlar con la función =ESERROR ().Si en C7 hay un 5 y en C8 hay un 2. por lo que Excel marca el error #¡DIV/0!. Sin embargo.

Sign up to vote on this title
UsefulNot useful