Alphaware©

Problemas comunes en Excel
Herramientas de Colaboración Digital
Johnny

2010

G11/E11) Y en un idioma intermedio dice: =SI( la celda E11 vale cero y por lo tanto voy a dividir algo entre cero. Vea la siguiente figura: Como la celda E11 no tiene valor.Cada vez que se intenta dividir una cantidad entre cero. cada vez que vea esta clave. si no es verdad que sí divida lo que tengo en G11 entre lo que tengo en E11) . qué hacer si no es verdad) En español. qué hacer si es verdad. se puede utilizar la función =SI() ¿Cómo? La función dice =SI ( comparación. Y Excel muestra el error. si no es verdad que sí haga la división En el idioma de las funciones de Excel. dice: =SI (E11=0. Para solucionarlo. si es verdad mejor que no divida porque va a mostrar error. Excel marca un error y lo muestra con esta clave: #¡DIV/0!. la fórmula dice: dividir G11 entre E11. o sea. significa que su fórmula está dividiendo algo entre cero. Por lo tanto. lo que queremos que diga es: = ¿voy a dividir entre cero?. si es verdad mejor que ponga un cero y no el error. 0. dividir 0 entre 0.

consulte la ayuda de Excel. Cuando eliminamos un renglón o una columna que era parte de una fórmula. Para cambiar el formato del número. Esto agrandará la columna hasta el ancho necesario para que se pueda mostrar el número completo. Puntero en posición equivocada Puntero en la posición correcta Columna con el ancho corregido Nota: Solamente se muestran los casos más comunes. o haciendo más ancha la columna. Se puede evitar que aparezca. . o corregir este error de dos formas: cambiando el formato del número.Nota: Solamente se muestran los casos más comunes. puede seguir cualquiera de las siguientes instrucciones (ya que todas tratan sobre cómo dar formato a los números): Para hacer más ancha la columna Posicione el puntero en la raya derecha de la columna y de doble click sobre la raya. Para obtener información más completa sobre este error. Para obtener información más completa sobre este error. la fórmula ya no se puede calcular y entonces aparece el error #¡REF!. consulte la ayuda de Excel. Cuando en una celda se muestra ##### significa que el formato elegido no cabe en el ancho de la columna.

la fórmula en C (antes D) se descompone y queda así: Para corregir el error. Para corregir. tenemos en D4 una fórmula que suma A4 + B4 + C4 Si borramos la columna B. Se corrige arreglando la fórmula. . ya que es normal que hagamos correcciones a la hoja luego de que hemos terminado algunas fórmulas. Los errores de dedo no se pueden evitar. Una de las causas más comunes es que haya un error de ortografía en algún lugar. La mayoría de las veces esto no es posible. ya sea haciéndola de nuevo o borrando la parte de la fórmula que dice #¡REF!. la fórmula correcta es =SUMAR(A4:C4) . falten comillas o falten dos puntos. Por ejemplo. Vea los dos ejemplos siguientes: Faltan los dos puntos. simplemente revise la fórmula con cuidado y haga los ajustes pertinentes. se puede simplemente borrar la parte sobrante de la fórmula (quitar #¡REF!) El error #¿Nombre? aparece normalmente cuando hay una fórmula mal escrita.Se evita no borrando renglones ni columnas que sean parte de una fórmula.

.La palabra correcta es SUMAR. Por ejemplo. la función para encontrar el año que está en la celda A2 es =AÑO(A2). la fórmula no sabrá que hacer y marcará un error #¡VALOR! También aparece cuando una función no encuentra el resultado y nos sabe qué regresar. Aquí. entonces la función no sabrá que dato regresar y marcará un error #¡VALOR!: Por lo tanto el error #¡VALOR! aparece normalmente cuando la fórmula o función no sabe qué valor regresar. Si hay un texto. el argumento es A2 y en esa celda debe haber forzosamente una fecha. cuando en una columna tengo las capitales y los países separados por comas y necesito saber en qué posición está la coma para poder separar capital del país. no SUMAN Todas las fórmulas o funciones de Excel llevan entre paréntesis uno o varios argumentos. ya sea porque: se puso un texto en lugar de un número o viceversa. entonces uso la función =ENCONTRAR(). Si por un error en el texto no tengo una coma. Por ejemplo.

BUSCARH.una fórmula o función no encontró el resultado. BUSCARV. BUSCARV. simplemente revise la fórmula con cuidado y haga los ajustes pertinentes. Los errores de dedo no se pueden evitar. pero que no está definido en la tabla de descripciones. la función regresa el valor #N/A Por lo tanto el error #N/A aparece normalmente cuando alguna de las funciones BUSCAR. Una forma de evitarlo es utilizando la sugerencia de Fernando Vasquez: . ya sea porque: se puso un texto en lugar de un número o viceversa. la función no encontró el resultado. simplemente revise la fórmula con cuidado y haga los ajustes pertinentes. COINCIDIR no sabe qué valor regresar. COINCIDIR Vea el ejemplo de la figura. Los errores de dedo no se pueden evitar. donde se está buscando una moneda con código BOL. BUSCARH. Existen dos causa comunes cuando se presenta este error: Que la función tenga un argumento mal escrito Que no encuentre el valor buscado cuando se utiliza cualquiera de las siguientes funciones: BUSCAR. En este caso. Para corregir. Para corregir.

Si la respuesta es VERDADERO.3. Para evitarlo se puede poner la siguiente fórmula: =SI( ESERROR(C8/C9). bajo algunas circunstancias no controladas. 0. Para los casos en que sospechamos que la fórmula. y en C8 hay un 0. estaríamos dividiendo un número entre un texto. significa que no hay errores y que sí se puede evaluar la fórmula. C7:E14. C8/C9) . digamos "hola". 3.FALSO). no siempre tenemos el tiempo necesario para pensarlas y probarlas antes de dar por terminado el trabajo que estamos haciendo. FALSO) SI NO ENCUENTRA NADA EL RESULTADO SERIA EL VALOR DE ERROR #N/A Este se corrige utilizando la formula =SI( ESERORR( BUSCARV(B2. 0.3. y la fórmula dice C7/C8.C7:E14. Si en C7 hay un 5. así si el resultado es un valor de error este lo sustituye por 0 o si se le pone un valor “” dejara el resultado en Blanco o poniendo la palabra “Sin Valor” entre comillas el resultado será la palabra Sin Valor Muchos de los errores que maneja Excel pueden prevenirse con un poco de cuidado al momento de elaborar las formulas. Si la respuesta es FALSO.Se puede corregir [o más bien evitar] el resultado del Error #N/A en una fórmula de Excel de la siguiente manera =BUSCARV (B2.FALSO) ). 0. puede generar un error. significa que no se puede escribir un resultado y mejor hay que poner un cero o un espacio en blanco. la función =ESEROR () nos puede sacar de apuros (excepto en el caso del error #! N/A¡ Lo que hacemos es probar la fórmula con =ESERROR (). por lo que Excel marca el error #¡VALOR!. C8/C9) Si en C7 hay un 5 y en C8 hay un texto. y la fórmula dice C7/C8. estaríamos dividiendo entre cero por lo que Excel marca el error #¡DIV/0!. Sin embargo. Para evitarlo se puede poner la siguiente fórmula: =SI ( ESERROR(C8/C9).C7:E14. BUSCARV(B2.

Sin embargo. que en español se interpreta como No Disponible. significa que no encontró el valor exacto que buscaba. de lo contrario. primero se debe evaluar si la búsqueda arrojará un error.Si en C7 hay un 5 y en C8 hay un 2. Para este caso. estaríamos dividiendo un número entre una celda inexistente. C8/C9) Casi todos los errores que manda Excel se pueden detectar y controlar con la función =ESERROR (). se utiliza la función =ESNOD () Ejemplos Si tenemos una serie números del 1 al 7 en la columna A y otra con los nombres de los días de la semana en la columna B. Para evitarlo. Si así es. sí lo encontró. la función =BUSCARV() arrojará el error No Disponible #!N/A¡. y luego borro todo el renglón. y luego buscamos con el día número 9. Para evitarlo se puede poner la siguiente fórmula: =SI( ESERROR(C8/C9). y la fórmula dice C7/C8. 0. si una búsqueda exacta con =BUSCARV () o =BUSCARH () no encuentra el valor buscado.. . por lo que Excel marca el error #¡DIV/0!. Excel genera el error #N/A.

Sign up to vote on this title
UsefulNot useful