P. 1
1 - Introduccion a La GUI de Unity3D

1 - Introduccion a La GUI de Unity3D

|Views: 2|Likes:
Publicado porjcramossa

More info:

Published by: jcramossa on Apr 22, 2013
Copyright:Attribution Non-commercial

Availability:

Read on Scribd mobile: iPhone, iPad and Android.
download as PDF, TXT or read online from Scribd
See more
See less

08/11/2015

pdf

text

original

Tutorial de Unity 3D Tema 1 Introducción a la GUI de Unity3D

Introducción a la GUI de Unity3D 1. Objetivos Este tema es lo primero que debes leer si es la primera vez que usas Unity3D. Aquí explicaremos cuáles son las secciones clave de la GUI (Interfaz gráfica de usuario) de Unity3D y describiremos la forma de crear nuevos elementos y posicionarlos en las escenas de nuestro videojuego. Para demostrar los aspectos esenciales del interfaz de Unity vamos a crear una escena 3D muy sencilla que permitirá a un personaje caminar sobre una superficie. Para facilitarte las cosas, siempre utilizaremos un guión (-) para prefijar todas las acciones que requieran tu intervención directa con el programa. 2. Interfaz Aunque existen otros modos de visualizar la interfaz, vamos a empezar con el más sencillo. Asegúrate que el interfaz se encuentra en modo “2 by 3”. – Para hacerlo, haz clic en las pestañas superiores: Window → Layout → 2 by 3 Aunque en adelante trabajaremos siempre en modo “2 by 3”, el interfaz de Unity es totalmente configurable. Todas sus ventanas pueden redimensionarse, cambiarse de posición y anclarse arrastrando y soltando sus pestañas superiores. Observarás que el menú de Layout permite salvar la configuración de ventanas, algo que nos será muy útil más adelante para guardar nuestra configuración favorita a la hora de animar, editar terrenos, etc.

Tutorial de Unity 3D Introducción a la GUI de Unity3D

Pág. 1

Observa a continuación un ejemplo donde hemos guardado varios tipos de Layout personalizados: Tutorial de Unity 3D Introducción a la GUI de Unity3D Pág. 2 .Tutorial de Unity 3D Tema 1 Introducción a la GUI de Unity3D Durante tus primeras experiencias con Unity 3D es frecuente que el interfaz pierda accidentalmente su aspecto inicial y quieras regresar al modo 2 by 3. En esos casos recuerda siempre que el menú de Layout también puede accederse fácilmente desde el botón en la esquina superior derecha de la interfaz.

Project View – Es la vista del proyecto y muestra la lista de todos los assets (Recursos) que hay disponibles para usar en tu videojuego. 5. permitiendo modificarlas. En adelante la llamaremos Vista de Inspector. Si no tienes ningún objeto seleccionado no nos mostrará nada. 3. Inspector View – Es la vista de inspección y muestra una lista con todas las propiedades del objeto de tu videojuego que tienes seleccionado actualmente. ordenados alfabéticamente. En adelante la llamaremos Vista de Proyecto. verás que el interfaz está ahora dividido en estas 5 regiones principales que puedes contrastar con la captura a pie de página: 1. seleccionarlos.. texturas.. 4. y permite añadir nuevos objetos en ella. En adelante la llamaremos Vista de Juego. 3 . Nos permitirá seleccionarlos fácilmente a partir de su nombre en lugar de buscarlos en la escena. modelos 3D. Tutorial de Unity 3D Introducción a la GUI de Unity3D Pág.Tutorial de Unity 3D Tema 1 Introducción a la GUI de Unity3D Volviendo al Layout “2 by 3”. etc. ya sean sonidos. Game View – Es la vista del videojuego y muestra cómo se verá tu videojuego al ejecutarse. editar el escenario. En adelante la llamaremos Vista de Jerarquía. Scene View – Es la vista de la escena de tu videojuego. En adelante la denominaremos Vista de Escena. 2. Hierarchy View – Es la vista de jerarquía y muestra la lista de todos los objetos que hay ahora mismo en la escena.

En este punto también puedes seleccionar una lista de paquetes de recursos que vienen por defecto (Texturas. y así con cualquier otro objeto. su nombre es Main Camera y en adelante nos referiremos a ella como Cámara Principal.. Localizar objetos en el espacio 3D Antes de continuar. la podrás ver como el único elemento en la lista de la Vista de Jerarquía. Si seleccionas un objeto en la Vista de Escena podrás comprobar si has seleccionado el objeto correcto porque se mostrará también iluminado también en la Vista de Jerarquía. Tutorial de Unity 3D Introducción a la GUI de Unity3D Pág. – Crea un nuevo proyecto haciendo clic en las pestañas superiores: File → New Project. De momento selecciona solamente el paquete Character Controller. También puedes hacer simplemente doble clic en su nombre en la Vista de Jerarquía para centrarla de la misma manera. 4 . pulsando la tecla F realizarás la opción de Seleccionar el Frame (Frame Select). – Reinicia Unity3D (Cierra el programa y vuélvelo a abrir). – Escribe un nombre para el proyecto. Le pondremos como nombre “Cámara” y pulsaremos intro para terminar. – Vamos a trabajar en castellano siempre que nos sea posible. – Ahora comprueba la Vista de Escena. si a contiunación hacemos otro clic nos permitirá cambiar su nombre. Para ello podemos hacer clic sobre su nombre en la Vista de Jerarquía. que es un paquete muy básico con personajes. y haz clic en Create Project para continuar. vamos a reiniciar Unity3D para crear un nuevo proyecto con el que empezar desde cero. modelos. Por defecto sólo habrá en él una cámara principal. Una vez finalice la carga de recursos podrás ver el “mundo” de tu videojuego. el que tú quieras. scripts. Esta es la técnica que debemos seguir siempre que queramos localizar un objeto en la escena.Tutorial de Unity 3D Tema 1 Introducción a la GUI de Unity3D 3. Una vez hecho eso. si mueves el cursor dentro de la Vista de Escena. puedes hacer clic en ella en la Vista de Jerarquía. Otra opción es hacer clic derecho y seleccionar Rename. – Observa en este punto que todos los objetos pueden ser seleccionados tanto haciendo clic sobre ellos en la Vista de Escena como en la Vista de Jerarquía. así que vamos a renombrar la Cámara Principal. etc. Si no puedes ver la cámara en ella.) para que se encuentren disponibles en tu nuevo proyecto. que se encarga de centrar en la escena el objeto seleccionado.. efectos de sonido.

5 .Tutorial de Unity 3D Tema 1 Introducción a la GUI de Unity3D 4. moverlos a una posición determinada. etc. Creando objetos en el videojuego A continuación vamos a añadir unos cuantos objetos en el mundo de nuestro videojuego. – Añade un cubo al mundo del videojuego seleccionando: Game Object → Create Other → Cube – Añade una luz puntual seleccionando: Game Object → Create Other → Point Light Todos los objetos que has creado aparecen por defecto en la misma posición. rotarlos. – Selecciona la pestaña superior: Game Object → Create Other → Plane. Esto creará una superficie bidimensional (Un plano) sobre el cuál podrá moverse nuestro personaje principal. Tutorial de Unity 3D Introducción a la GUI de Unity3D Pág. A continuación vamos a ocuparnos de movernos por la escena. con una rotación neutra y sus valores iniciales por defecto.

Tutorial de Unity 3D Tema 1 Introducción a la GUI de Unity3D 5. estás usando un touch pad o simplemente te resulta más fácil. Rotación – Alt + Clic Izquierdo 2. Desplazamiento – Clic central (Presionar la rueda del ratón) y arrastrar. evita usar la rueda del ratón para hacer zoom. Si te es posible. rotar y escalar. si tu ratón es de un sólo botón. Los botones de la parte superior izquierda de la interfaz te permitirán posicionar. respectivamente. 6 . a continuación detallamos cómo puedes recorrer el mundo de tu videojuego en la Vista de Escena y mirarlo desde cualquier ángulo utilizando los siguientes controles: 1. aunque es recomendable hacerlo por desplazamientos. justo debajo de las pestañas superiores: 1. Zoom – Control + Alt + Clic Izquierdo – Prueba los controles anteriores hasta que te familiarices con ellos. Mover los objetos del videojuego Puedes modificar la posición. también puedes utilizar los siguientes controles alternativos siempre y cuando tengas seleccionada la herramienta con icono en forma de mano que verás en la parte superior izquierda. Rotación – Clic derecho y arrastrar 2. Al hacer zoom con la rueda del ratón se modifica la precisión de desplazamiento y abusar del zoom provocará que a veces el desplazamiento sea demasiado lento o demasiado rápido. También con las teclas direccionales 3. Aunque no es lo habitual. Navegando por la Vista de Escena Aunque los controles son muy intuitivos y serás capaz de aprenderlos con la simple práctica. Zoom – Rueda del ratón. 6. la rotación y el tamaño (Escala) de cualquier objeto que tengas seleccionado en el espacio 3D. Son los siguientes: Tutorial de Unity 3D Introducción a la GUI de Unity3D Pág.

7 . Mueve el cubo con la herramienta Mover de manera que quede fuera de la Vista de Escena. También puedes introducir directamente los valores numéricos en ese panel. respectivamente. z. Otra forma más avanzada de modificar la rotación es mover la Vista de Escena de forma que mire en la dirección con la que queremos alinear el objeto. Si hacemos clic en las pestañas superiores y seleccionamos: Game Object → Move to View. y a continuación mover la Vista de Escena de forma que mire a la posición donde queremos mover el objeto. una para cada eje en el espacio 3D. Otra forma más avanzada de modificar la posición de un objeto del videojuego es hacer clic sobre él para seleccionarlo. La herramienta Rotar: También puede seleccionarse pulsando la tecla E. y podrás introducirlos en él manualmente si lo deseas. verde y azul se corresponden con los ejes x. Para rotar el objeto sobre cualquiera de sus ejes. el panel de la Vista de Inspector también cambiará sus valores al mismo tiempo que rotas el objeto. se mostrarán 3 flechas. Observa que al mismo tiempo que mueves el objeto. Si seleccionamos un objeto del videojuego y a continuación pulsamos esta tecla se mostrará la herramienta de rotación. Si la pulsamos mientras tenemos un objeto seleccionado. Los colores rojo.Tutorial de Unity 3D Tema 1 Introducción a la GUI de Unity3D 1. Finalmente intenta devolver el cubo de nuevo hasta la posición del plano. – Mueve ahora también la luz puntual de manera que se encuentre encima del cubo y el plano. Si hacemos clic en las pestañas superiores y seleccionamos: Game Object → Align with View. mantén presionado clic izquierdo sobre el eje que quieres rotar y mueve el ratón. – Vamos a hacer un pequeño ejercicio. el objeto se moverá a la posición a la que mira la cámara actualmente. Usa ahora la opción de Seleccionar el Frame haciendo doble clic sobre el cubo en la jerarquía (O bien pulsando la tecla F en la Vista de Escena). y. La herramienta Mover: También puede seleccionarse pulsando la tecla W. el objeto se quedará alineado en la dirección a la que mira la cámara de la Vista de Escena. Para mover un objeto haz clic izquierdo en la flecha que represente el eje en el que quieres mover el objeto y mueve el ratón para modificar su posición hasta el punto que desees. De la misma manera. 2. Tutorial de Unity 3D Introducción a la GUI de Unity3D Pág. los valores de su posición también cambian en el panel de la Vista de Inspector. Esto nos será sobre todo útil para orientar luces direccionales o cámaras para que apunten a donde queremos.

La Vista de Juego Recuerda que la Vista de Juego nos muestra cómo se vería el videojuego en ejecución.Tutorial de Unity 3D Tema 1 Introducción a la GUI de Unity3D La Vista de Escena de tu videojuego debería lucir aproximadamente de ésta manera si has realizado correctamente los últimos pasos. Si no puedes ver el mundo de tu videojuego en la Vista de Juego es porque tu cámara no está mirando en la dirección correcta. con sus texturas. iluminación final. navega por al escena hasta localizarlos. así la Vista de Videojuego coincidirá con la Vista de Escena. 8 . o cambiando sus valores directamente en el panel del Vista de Inspector. etc. Se denomina campo de visión de la cámara y representa lo que ésta puede ver. recuerda que también puedes ajustar manualmente la configuración de la cámara usando las herramientas de Mover y Rotar. 7. una vez hecho esto. Verás que una malla en forma de pirámide blanca sale desde ella. De esta manera la cámara del videojuego se alineará exactamente en esa posición y orientación. Si el campo de visión no apunta directamente a los objetos de tu videojuego. – Haz clic en la cámara principal. vuelve a seleccionar la cámara en la jerarquía y haz clic en la pestaña superior: Game Object → Align with View. Tutorial de Unity 3D Introducción a la GUI de Unity3D Pág. Para casos concretos.

o bien usando la Vista de Inspector para teclear un valor preciso en él. ya que el segundo correspondería al eje Y y los planos como tales no pueden agrandarse “hacia arriba”. 9 . 8. – Selecciona el cubo y redimensiónalo visualmente a lo largo del eje Y subiendo hacia arriba el bloque con forma de cubo en ese eje de forma que el cubo termine pareciéndose a un pilar. también puedes hacerlo pulsando la tecla R. Ahora vamos a reescalar algunos objetos de nuestro videojuego: – Selecciona el plano y pon a 10 los valores de escala tanto en el eje X como en el Z usando la Vista de Inspector. Tutorial de Unity 3D Introducción a la GUI de Unity3D Pág. Podrás escalar visualmente cualquier objeto haciendo clic en el bloque con forma de pequeño cubo que aparece en el extremo de cada eje. Serán el primer y el tercer valor de la escala. Redimensionando objetos del videojuego Para cambiar el tamaño de un objeto. selecciónalo en primer lugar y pulsa el botón correspondiente en la parte superior izquierda de la interfaz.Tutorial de Unity 3D Tema 1 Introducción a la GUI de Unity3D Quizás también desees mover la luz puntual para conseguir un efecto más estético.

etc. – Aprovecha nuevamente en este punto para poner nombres en castellano a todos los objetos de la escena. Utilizando los Recursos Un videojuego está compuesto por modelos 3D. Recuerda que puedes hacer ésto seleccionándolo en la Vista de Jerarquía. Recuerda que a la hora de crear el proyecto seleccionamos un paquete llamado Character Controllers para incluirlo como recurso. En el subdirectorio Character Controlers verás un Prefab llamado First Person Controller (Controlador de Primera Persona).. Todos los Standard Assets que vienen con Unity son colecciones de objetos de videojuego (Scripts. texturas. Tutorial de Unity 3D Introducción a la GUI de Unity3D Pág. Es una muy buena práctica utilizar un lenguaje común y conocer bien todos los objetos que hay en tu proyecto. incluso más en la versión pro. Como peculiaridad. y también pueden descargarse gran cantidad de ellos en internet. Como verás más adelante estas agrupaciones de objetos se denominan Prefabs y son fundamentales para trabajar con Unity de manera eficiente. Unity3D viene con muchos recursos de serie. haciendo clic derecho sobre él y seleccionando la opción Rename (Renombrar). modelos.. verás que para expandir un directorio debes pulsar el icono en forma de triángulo que hay a la izquierda de su icono de carpeta. 10 . pulsa Enter para guardarlo.) que han sido previamente ensamblados entre ellos con una agrupación lógica.Tutorial de Unity 3D Tema 1 Introducción a la GUI de Unity3D – Renombra el cubo como “Pilar”. código fuente. Recuerda que es recomendable que los nombres de los objetos del videojuego comiencen con letra mayúscula. Estos elementos se denominan Recursos (Assets). Tras escribir el nombre que desees. archivos de sonido. En la Vista de Proyecto expande el directorio llamado Standard Assets (Recursos Estándar) y a continuación expande el subdirectorio Character Controllers (Controladores de Personaje). Ahora es el momento de utilizarlo. texturas. Vamos a añadir a nuestro videojuego uno de los personajes prefabricados que podemos encontrar en los Recursos. 9.

11 . usa el ratón para mirar a tu alrededor y la tecla espacio para saltar. Luces. en ese caso debes detener o simplemente pausar el videojuego primero. ésta volverá a su modo normal de visualización. colisionadores. Escena. puedes hacerlo pulsando la tecla Supr con ella seleccionada o bien haciendo clic derecho sobre ella en la Vista de Jerarquía y seleccionando la opción Delete. de forma que puedes ver el videojuego dentro de la Vista de Escena y la Vista de Videojuego. Tutorial de Unity 3D Introducción a la GUI de Unity3D Pág.W). Esta característica está desactivada mientras el videojuego se encuentra en ejecución.D. puedes ver los componentes asociados en su Vista de Inspector (p. etc. dicha Vista pasará a modo pantalla completa. 10. la cual toma precedencia frente la Cámara Principal que existía desde un principio. Pulsando el espacio de nuevo dentro de la pantalla completa. Añadiendo componentes Los objetos de tu videojuego pueden tener cierto número de componentes (También llamados comportamientos) asociados. Asegúrate de que el First Person Controller no está atrapado dentro del plano. Al hacer clic en un objeto del videojuego.Tutorial de Unity 3D Tema 1 Introducción a la GUI de Unity3D – Arrastra el First Person Controller en la Vista de Escena. Observa como la Vista de Videojuego cambia. – Arranca el videojuego clicando el botón Play que puedes ver en la parte superior central de la GUI de Unity. – Puedes detener la ejecución del videojuego en cualquier momento pulsando nuevamente el botón Play o bien hacer una simple pausa utilizando el botón de Pausa. Observa que la pantalla permanece igual. Esto resulta útil cuando se están haciendo ajustes en la Vista de Escena.). o cuando se está probando el juego desde la Vista de Videojuego.S. etc. – Borra la Cámara Principal (Main Camera) ya que no la vamos a volver a necesitar. La Vista de Videjuego a partir de ahora será lo que el jugador puede ver dentro del juego.). esto es porque el FPS Controller prefabricado viene con su propia cámara. Usa las teclas cursor para mover a tu personaje por el entorno (También puedes usar A.ej. para ello muévelo de forma que quede sobre el plano. En este punto es interesante que sepas que pulsando la barra espaciadora mientras el cursor se encuentra dentro de cualquiera de las distintas Vistas de Unity3D (Videojuego.

el Cubo con Gravedad debería colisionar contra el Pilar y a continuación caer sobre el plano comportándose como si hubiese gravedad. Renómbralo como “Cubo con Gravedad” en la Vista de Jerarquía.Tutorial de Unity 3D Tema 1 Introducción a la GUI de Unity3D – Haz clic en el Pilar y mira sus componentes asociados en la Vista de Inspector. Observa que en la Vista de Inspector el componente también aparecerá añadido. – Haz clic en el Cubo con Gravedad para asegurarte de que lo tienes seleccionado. Cuando duplicamos un objeto. 11. el objeto caerá hacia abajo hasta que golpee una superficie que tenga un componente asociado de tipo Collider. Tutorial de Unity 3D Introducción a la GUI de Unity3D Pág. Por ejemplo. todas las características y comportamientos del objeto son a su vez copiados. Es una forma muy rápida de crear escenas complejas con multitud de objetos. – Añade otro cubo a la escena (Game Object → Create Other → Cube). – Mueve el Cubo con Gravedad de forma que se encuentre sobre el Pilar. Duplicar – Duplicar un objeto del videojuego es la característica más potente de Unity. por ejemplo el Plano. Ahora vamos a añadir más Cubos con Gravedad a nuestra escena. 12 . Queremos configurar la escena de forma que. Pulsa ahora el botón Play. Esto añadirá el componente Rigidbody al objeto del videojuego que tengas seleccionado. Este tipo de componente permite al objeto del videojuego comportarse como si estuviese dentro de un mundo con gravedad. Vamos a añadir otro cubo más a la escena y añadir un componente adicional. El Cubo con Gravedad colisione con el Pilar y después caiga al suelo. a una poca distancia sobre él. Ahora vamos a añadir un Rigidbody (Cuerpo rígido) al cubo. – Asegúrate de que tienes el Cubo con Gravedad seleccionado. cuando pulsemos Play. selecciona entonces Component → Physics → Rigidbody.

ya que ha sido creado exactamente sobre la misma posición que el anterior. Mueve el nuevo Cubo con Gravedad seleccionando la herramienta mover (O pulsando la tecla W) y muévelo hacia arriba en el eje Y. – – – Tutorial de Unity 3D Introducción a la GUI de Unity3D Pág. o simplemente haciendo clic derecho sobre él en la Vista de Jerarquía y seleccionando la opción Duplicate). no puedes verlo.Tutorial de Unity 3D Tema 1 Introducción a la GUI de Unity3D – Pulsa Ctrl+D (También puedes hacerlo desde el menú Edit. Repite este proceso de forma que haya varios Cubos con Gravedad en la escena. Observa que sin embargo. unos sobre otros formando alguna estructura que resulte divertida de ver al derrumbarse. Ejecuta ahora el videojuego y los Cubos con Gravedad interactuarán entre ellos comportándose con total naturalidad. 13 . Observa cómo aparece una nueva entrada con un Cubo con Gravedad adicional en la Vista de Jerarquía.

14 .Tutorial de Unity 3D Tema 1 Introducción a la GUI de Unity3D Tutorial de Unity 3D Introducción a la GUI de Unity3D Pág.

You're Reading a Free Preview

Descarga
scribd
/*********** DO NOT ALTER ANYTHING BELOW THIS LINE ! ************/ var s_code=s.t();if(s_code)document.write(s_code)//-->