P. 1
Manual de Macromedia Flash 8

Manual de Macromedia Flash 8

|Views: 51|Likes:
Publicado porprofesorchonero

More info:

Published by: profesorchonero on Apr 18, 2013
Copyright:Attribution Non-commercial

Availability:

Read on Scribd mobile: iPhone, iPad and Android.
download as DOC, PDF, TXT or read online from Scribd
See more
See less

02/02/2014

pdf

text

original

Centro Americano Integral de Idiomas y Computación C@INICOMPUT S.A. Manual de Macromedia Flash 8.

0

INTRODUCCION A MACROMEDIA FLASH 8.0

Macromedia Flash 8.0, es una herramienta que permite crear animaciones interactivas con diversos tipos de funciones y efectos. Actualmente es una herramienta más completa en un entorno a aplicaciones de animación y en ambiente a los diferentes sitios de entorno Web. Usted aprenderá a crear animaciones con sonidos, puede utilizar sus propios archivos MP3, también se podrán importar videos y podrá editar estos videos y colocar fragmentos de ellos en sus presentaciones. Flash 8.0, es una herramienta de edición con la que pueden crearse desde animaciones simples hasta complejas aplicaciones Web interactivas. Las aplicaciones de Flash pueden enriquecerse añadiendo imágenes, sonidos y videos. Flash incluye muchas funciones que la convierten en una herramienta con muchas presentaciones sin perder por ello la facilidad de uso.

Pág. # 1

Centro Americano Integral de Idiomas y Computación C@INICOMPUT S.A. Manual de Macromedia Flash 8.0

EFECTOS DE LINEA DE TIEMPO Es posible aplicar efectos de línea de tiempo en cualquier objeto del escenario para añadir transiciones y animaciones con rapidez, tales como aumentos progresivos, desenfoques giros y otros tipos de animaciones de línea de tiempo. PLANTILLAS ACTUALIZADAS. Flash incluye plantillas actualizadas para crear presentaciones, aplicaciones de aprendizaje por Internet, anuncio, aplicaciones para dispositivos móviles y otros tipos de documentos de Flash de uso común. CREAR, ABRIR UN DOCUMENTO Y CONFIGURAR PROPIEDADES Durante el trabajo de Flash puede crear un nuevo documento o abrir un documento existente. Puede utilizar el botón nuevo para abrir un documento del mismo tipo que el último documento creado. Para crear un documento nuevo haga lo siguiente: 1.- Selecciones el Menú Archivo – Nuevo 2.- En la Ficha General, Seleccionar Documento de Flash - Aceptar

Pág. # 2

En el cuadro de Dialogo Abrir. # 3 .0 Macromedia Flash 8. Para abrir un documento ya existente: 1.Centro Americano Integral de Idiomas y Computación C@INICOMPUT S. busque el archivo o introduzca la ruta del mismo.0 y sus Elementos Barra de Titulo Caja de Herramientas Línea de Tiempo Barra de Menú Barra de Herramientas Editar Escena Editar Simbolos Ventana de Propiedades Ventana de Acciones Para ver la barra de herramientas ingresar al Menú Ventana – Barra de Herramientas Principal. 3. luego se mostrará la Barra de Herramientas.A.Hacer clip en el Botón Abrir Pág. Manual de Macromedia Flash 8....Seleccionar el Menú Archivo – Abrir 2.

3. Para establecer el color de fondo del documento. # 4 . siga uno de estos procedimientos. Con el cuadro abierto.0 Para configurar las propiedades de un documento ya existente o nuevo en el cuadro de Dialogo Propiedades del documento haga lo siguiente: 1. En dimensiones. selecciones una opción del menú emergente situado en la esquina superior derecha. La mayoría de las afinaciones que se ven en los equipos. especialmente las que se producen desde un sitio Web. se mostrará el cuadro de Dialogo Propiedades del documento. La velocidad de fotograma predeterminada es de 12 fps. ingrese el número de fotograma de animación que debe mostrarse cada segundo. Pág. 4.Centro Americano Integral de Idiomas y Computación C@INICOMPUT S.A. 5. Para especificar la unidad de medida para las reglas que puede visualizar en la parte superior y lateral de la ventana de la aplicación. introduzca los valores en los cuadros de texto Anchura y Altura. seleccione Modificar Documento. haga clic en el triangulo del cuadro Color de fondo y seleccione un color de la paleta. En la sección Velocidad de fotograma. no necesitan una velocidad superior entre 8 y 12 fps (Fotogramas por segundos). Manual de Macromedia Flash 8. Para especificar el tamaño del escenario en píxeles. Este valor también determina las unidades utilizadas en el panel de Información. 2.

La herramienta de Transformación de Relleno permite cambiar el relleno en los objetos de mapa bits. La herramienta PoliStar permite crear polígonos de diferente tamaño solo de 5 puntas. se utiliza la herramienta Pincel. La herramienta rectángulo permite crear objetos cuadrados o rectángulos. La herramienta Selección permite escoger el objeto o seleccionar. mientras que la herramienta zoom permite aumentar el tamaño del objeto dentro del área del trabajo. La herramienta Lazo permite crear selección en determinada área del objeto. y a través de la herramienta transformación libre le cambiamos el tamaño del texto.A. permite crear trazados libres. La herramienta Transformación libre permite crear el tamaño del objeto sea mas grande o más pequeño. permite copia como muestra un color y pegarlo en otro lugar del objeto. La herramienta Borrador permite borrar áreas de un objeto. La herramienta Subselección. permite modificar los nodos del objeto seleccionado. La herramienta de Texto nos permite escribir formatos de textos. La herramienta colores permite modificar los colores tanto de línea como de relleno en un objeto. La herramienta óvalo nos permite crear objetos de formas circular. La herramienta Bote de Pintura y Cubo de pintura permite dar colores tanto de línea como de relleno a un objeto. # 5 .0 TRABAJANDO CON OBJETOS La Caja de Herramienta de Flash. Manual de Macromedia Flash 8. para realizar cualquier acción. La herramienta línea permite crear trazados en línea recta.Centro Americano Integral de Idiomas y Computación C@INICOMPUT S. La herramienta Lápiz. A través de la ventana mezclador de colores. La Herramienta mano permite mover el area del trabajo hacia donde se desea. La herramienta Cuentagotas. LINEA DE TIEMPO Y FOTOGRAMAS Pág. La herramienta pluma permite crear trazados de línea libre o curvas. Para crear trazos similares a los obtenidos al pintar en un lienzo.

elija insertar Línea de tiempo Fotograma clave. 2. Crear un Fotograma Clave 1. añadir guía de movimiento e insertar carpetas de capas. Pág. En la parte inferior encontramos botones de capas los cuales permiten crear una nueva capa.0 En la barra principal obtendremos un icono muy útil que es el de escalar que nos permite modificar los objetos Las capas poseen puntos de visualización de protección o bloqueo y un lápiz que indica sobre que capa estamos trabajando o editando actualmente.A. Manual de Macromedia Flash 8.Seleccione un fotograma en la línea de tiempo. de la barra de menú o Haga Clip con el botón derecho del ratón en un fotograma de la línea de tiempo y elija insertar fotograma clave.Luego se mostrará el fotograma clave insertado. Algunas de las teclas de Funciones nos permiten utilizar en forma rápida algunos de los tipos de inserción de Fotogramas F5 Insertar Fotograma F6 Insertar Fotograma clave F7 Insertar Fotograma Clave vacio ANIMACION INTERPOLADA Flash puede crear dos tipos de animación.Centro Americano Integral de Idiomas y Computación C@INICOMPUT S. # 6 . interpoladas: Interpolación de Movimientos e Interpolación de formas.

un grupo o un bloque de texto en un instante especifico. escoger la opción forma Pág. y después estas propiedades se pueden cambiar en otro momento. Puesto que los documentos de Flash guardan las formas en cada fotograma clave.Centro Americano Integral de Idiomas y Computación C@INICOMPUT S. En la Interpolación de formas.. se define propiedades tales como la posición.Clip derecho.. se dibuja una forma en un instante específico y después se modifica o se dibuja otra forma en otro instante.0 En la Interpolación de movimiento.Ubicarse en la posición a insertar el Fotograma 2.. En cada Interpolación sea de Forma o de movimiento se debe especificar la posición final de objeto Interpolación de Movimiento 1. el tamaño y la rotación de una instancia. Manual de Macromedia Flash 8. # 7 .Mostrar la Barra de propiedades en la parte inferior 3. y escoger Crear interpolación de movimiento Interpolación de Forma 1.. cree fotograma clave solo en los puntos de ilustraciones en los que se produzca alguna modificación.Ubicarse en la Posición final a Insertar el Fotograma 2.A. Flash interpola los valores de forma de los fotogramas intermedios para crear la animación. También se puede crear una interpolación de movimiento a lo largo de un trazado. Flash muestra los fotogramas interpolados en color verde claro para la Interpolación de formas y color azul claro para la Interpolación de movimiento.. con una flecha entre los fotogramas clave.En la propiedad animar.

Pág. Manual de Macromedia Flash 8. Insertar un fotograma clave suprimir la imagen anterior e importar la nueva imagen Desagrupar la imágenes desde la posición 1 de la línea de tiempo hasta la ultima posición a través de ctrl. luego nos ubicamos en la posición 20 de la línea de tiempo.A.Centro Americano Integral de Idiomas y Computación C@INICOMPUT S.0 Cambiar el nombre de la capa Para cambiar el nombre de la capa se da doble clic sobre la capa y se le ubica el nuevo nombre de la capa. # 8 . B para desagrupar los objetos Escoger la Ventana propiedades en la parte inferior y en cada punto de interpolación escoger interpolación de forma. Importar una Imagen Para importar una imagen al escenario escoger Archivo – Importar – Importar a Escenario y luego buscar la ruta donde se encuentra la Imagen Práctica # 1 Importar al escenario algunos objetos e Imágenes Crear interpolación de movimientos e interpolación de formas Cambiar el nombre a las capas Cada objeto se le crea una capa independiente a excepción de las imágenes con interpolación de formas En la Capa 2 Insertar una imagen en la posición 1 de la línea de tiempo.

2) Insertar una nueva capa para importar la imagen avión a partir de la posición 1.A. 6) Capa Paracaídas (j0278702).0 Ventana Propiedades Practica # 2 Crear el siguiente ejercicio 1) En la Capa 1 insertar un fondo con varios objetos y que llegue hasta la posición 40 de la línea de tiempo.Centro Americano Integral de Idiomas y Computación C@INICOMPUT S. 5) Capa Avión (TN00234). Manual de Macromedia Flash 8. # 9 . 3) Importar 3 Paracaidas 1 en cada capa. Pág. 4) Capa fondo Casa ( BL00122) Pared (BL00008) Casa negra (Bl00262) Fondo de tiempo de nieve (J0157177).

0 Práctica # 3 1..A...Importe en el escenario varias imágenes con casas para establecer el fondo 2.Centro Americano Integral de Idiomas y Computación C@INICOMPUT S.Cree 2 nuevas capas para el avion 1 y el avión 2 4. # 10 . Manual de Macromedia Flash 8.En capa 2 y 3 importar un edificio por cada capa 3.En las capas de Edificio 1 y Edificio 2 crearla con las interpolaciones de formas Pág..

incluidos formas. grupos y símbolos gráficos Imágenes de mapa bits.0 EFECTOS DE LINEA DE TIEMPO Flash incorpora efectos de línea de tiempo que permite crear animaciones complejas con un número mínimo de pasos. Manual de Macromedia Flash 8. # 11 .Cree y seleccione el objeto al que va a añadir el efecto de línea de tiempo haciendo clic sobre el objeto Pág. Los efectos de línea de tiempo pueden aplicarse a los siguientes objetos: Textos Gráficos. Símbolo de botón. Para añadir un efecto a un objeto haga lo siguiente: 1.Centro Americano Integral de Idiomas y Computación C@INICOMPUT S.A..

..Escoger aceptar .0 2. Para insertar un nuevo símbolo se realizan los siguientes pasos: 1) 2) 3) 4) 5) 6) Ir al menú insertar – Nuevo símbolo (Escribir el nombre del símbolo Tipo: Clic de película) Dibujar la Figura del símbolo Insertar el fotograma clave en la línea de tiempo escogida E insertar el número de imágenes de acuerdo a los diferentes posiciones En cada inserción de imágenes se inserta un nuevo fotograma clave y se suprime la imagen anterior Para mostrar el símbolo hacia la capa se crea la capa con el nombre diferente o el mismo nombre del símbolo Pág..Luego se mostrará una ventana donde verá una vista previa del efecto según los valores predeterminados 4. Considere la posibilidad de crear una animación en un símbolo cuando exista una acción repetitiva. # 12 . al mismo tiempo que se produce el mínimo el tamaño de archivo. TRABAJANDO CON SIMBOLOS Puede crear un símbolo a partir de los objetos seleccionados en el escenario o crear un símbolo vacio y crear o importar el contenido en modo de edición de símbolos En Flash.Centro Americano Integral de Idiomas y Computación C@INICOMPUT S. Mediante los símbolos con animación pueden crearse aplicaciones de Flash con mucho movimiento. Manual de Macromedia Flash 8. incluida la animación.Seleccione Insertar – Efectos de línea de tiempo. También se puede crear símbolos de fuentes. A continuación seleccione Efectos – Explotar 3.A. Los símbolos pueden tener toda la funcionalidad disponible en Flash.

Desplazar cada símbolo al escenario principal de la capa 1 Escoger la ventana Acciones de de clip de película y realizar la siguiente codificación.true) } en la siguiente línea escribir la siguiente codificación Pág.Centro Americano Integral de Idiomas y Computación C@INICOMPUT S. # 13 .A.0 7) Escoger el Menú ventana Biblioteca y luego escoger el símbolo y mover el símbolo hacia la capa creada y realizar los fotogramas claves con la creación de la interpolación de movimientos Practica # 4 Crear un rompecabezas tomando como ejemplo la base de un payaso mediante la inserción de símbolos Objetos Payaso terminado Para crear el rompecabezas hay que seguir los siguientes Pasos: 1) 2) 3) 4) 5) 6) 7) Insertar un símbolo por cada objeto tipo clip de películas. Funciones Globales – Control de Clip de películas – on doble clip en (press) al abrir la llave en la misma línea { Funciones Globales – Control de Clip de películas – StartDrag dentro de los paréntesis escribir (this. y escoger la opción Biblioteca. Ir Menú Ventana. Manual de Macromedia Flash 8. Enviar cada objeto al centro del escenario y agrupar el objeto Una vez creado todos los objetos.

# 14 .wmf C:\Archivos de Progrmas\Microsof Office\Clipart\Pub60Cor\J0 386120. Los siguientes formatos de archivos de sonidos se pueden importar a Flash. Nota: Este procedimiento se realiza por cada objeto restante del payaso Crear un símbolo tipo Botón: 1) Inserte un símbolo (Nombre: Imagen.  WAV  MP3 Para importar un sonido haga lo siguiente: Pág.wmf C:\Archivos de Progrmas\Microsof Office\Clipart\Pub60Cor\J0 174639.wmf INSERTAR SONIDOS Y VIDEOS Importar sonidos Para insertar archivos de sonidos en Flash. Tipo: botón) 2) Importar una imagen para el tipo Reposo 3) Pasar a la siguiente fase Sobre con la tecla de Función F7 e importar otra Imagen 4) De la misma manera importar la tercera Imagen a la fase Presionado con la tecla de Función F7 Reposo Sobre Presionado C:\Archivos de Progrmas\Microsof Office\Clipart\Pub60Cor\S O00191. Manual de Macromedia Flash 8.0 8) 9) 10) Funciones Globales – Control de Clip de películas – on doble clip en (release) al abrir la llave en la misma línea { Funciones Globales – Control de Clip de películas – StopDrag().A. puede importarlos a la Biblioteca del documento actual.Centro Americano Integral de Idiomas y Computación C@INICOMPUT S.

.Sonidos opción Cargar archivo MP3 de Flujo Pág.A.0 1. y presionar el botón abrir En el elemento de la Biblioteca se mostrará de la siguiente manera: Y la ventana propiedades: Como agregar un sonido a un botón 1.Crear una capa insertando un Botón 2.Escoger Añadir comportamiento 4...Centro Americano Integral de Idiomas y Computación C@INICOMPUT S.Seleccionar el Menú Ventana – Comportamiento 3.. Manual de Macromedia Flash 8.Importar a la Biblioteca 3..Seleccione Archivo – Importar 2. # 15 ...En el cuadro de dialogo Importar busque y seleccione el archivo.

. Manual de Macromedia Flash 8. MPEG U otro. escoger Al presionar INSERTAR VIDEOS Macromedia Flash proporciona diversos métodos para incluir videos en los documentos de Flash.Escoger la opción aceptar 7. Se puede importar Clip de Videos a Flash en archivos incorporados con formato MOV.0 5. # 16 .Aceptar 2) Al aceptar se mostrará un Asistente Pág.En la opción evento..Centro Americano Integral de Idiomas y Computación C@INICOMPUT S. ubicar la dirección del archivo de sonido Ejemplo: C:\Documents and Settings\Fmlia. AVI. Lucas Reyna\Mis documentos\MY MUSIC FOR EVER\27 .En el cuadro de diálogo aparece Introducir la dirección de la URL..A.05 . Para importar un clip de video incorporado hacer lo siguiente: 1) Seleccionar Archivo – Importar – Importar a escenario .2006 (D)\Disco 6.

Centro Americano Integral de Idiomas y Computación C@INICOMPUT S. 4) Al final se mostrará el video importado Pág. Manual de Macromedia Flash 8.0 3) Hacer clic en Finalizar para cerrar el asistente de importación de video y comenzar el procedimiento de Importación.A. # 17 .

Nota: No se puede utilizar escena en un documento basado en pantallas. Los fotogramas del documento se numeran de forma consecutiva en todas las escenas Para insertar una nueva realizar los siguientes pasos: 1) 2) Ir al menú Insertar – Escena y en la parte superior de la línea de tiempo se mostrará el número de la escena en que se está trabajando Si deseamos cambiar el nombre a la escena escoger el menú Ventana – Otros Paneles – Escenas 3) Dar doble clic sobre el nombre de la Escena 1 y cambiar el nombre de la misma Practica # 5 1) 2) 3) Crear una Escena Menú e insertar varios botones en las que por medio de los botones llamar a cada escena Para insertar los botones Ir al Menú Ventana – Escoger – Bibliotecas Comunes – Botones Tipo de botones para los normales Buttons buble 2 escoger los colores Pág. un mensaje de carga y los créditos.0 TRABAJANDO CON ESCENAS Para organizar un documento por temas.Centro Americano Integral de Idiomas y Computación C@INICOMPUT S. puede utilizar escenas diferentes para una introducción. puede utilizar escenas: Por ejemplo. # 18 . Al publicar un documento de Flash que contiene más de una escena. las escenas del documento se reproducen en el orden en el que aparecen en el panel Escena del documento de Flash.A. Manual de Macromedia Flash 8.

A.Centro Americano Integral de Idiomas y Computación C@INICOMPUT S.0 4) Tipo de botón para el botón salir Playback rounded – rounded green stop Dentro De cada escena debe existir botones de retorno hacia la escena menú Pág. Manual de Macromedia Flash 8. # 19 .

Centro Americano Integral de Idiomas y Computación C@INICOMPUT S.”true”). Manual de Macromedia Flash 8.0 Dentro de la ventana Acción de Botón de cada botón crear la siguiente función. 5) Funciones Globales – Control de Clip de Películas – on (press) al comenzar la llave { Funciones Globales – Control de Linea de tiempo – GotoAndStop (“COSTA”. Practicas Adicionales Proyecto Cupido Pág. # 20 .A.1) 6) 7) El código para el botón salir es el siguiente: Funciones Globales – Control de Clip de películas – on (release) al comenzar la llave { Funciones Globales – Navegador\Red – fscommand (“quit”. 8) En la capa 1 crear un código para detener el parpadeo 9) Funciones Globales – Control de línea de tiempo – Stop.

También se deben crear símbolos con rectángulos que son los que van a recibir las piezas del rompecabezas. # 21 .0 Practica Final Practica de Rompecabezas. podemos insertar la imagen dentro.A. Después de haber creado todos los fragmentos procedemos a diseñar la pantalla que va a tener nuestro rompecabezas. Una vez fragmentada la imagen tenemos que hacer lo siguiente: 1. Luego se guardan los fragmentos individualmente con formato (jpg). en flash. 3. Importamos el fragmento dentro del símbolo. para facilidad lo podemos hacer con el programa Corel Draw. Necesitamos editar la imagen para dividirla en varias partes.Centro Americano Integral de Idiomas y Computación C@INICOMPUT S. del objeto dibujado y después se debe desagrupar. Símbolos (Fotos) 12 en total Este va a ser el aspecto de nuestro diseño. Manual de Macromedia Flash 8.Símbolo) 2. utilizando la herramienta papel grafico. En Flash creamos un Símbolo (Insertar--. Y luego se repiten lo mismo hasta terminar con todos los fragmentos. Símbolos (Rectángulos) 12 en total Pág. para dibujar el objeto contenedor y con la opción de PowerClip.

cada uno de ellos necesitará otro símbolo (Rectángulos). Fragmentos a la izquierda.A.0 La parte del código. Como a la hora de mover los fragmentos. # 22 . que los va a recibir a ellos se les deberá ubicar un nombre instancia también.Centro Americano Integral de Idiomas y Computación C@INICOMPUT S. Los fragmentos deberán llevar nombres de instancia desde f1 hasta f12. 1. Pág. y rectángulos (símbolos) a la derecha. mientras que los rectángulos deberán llevar nombres de instancia desde c1 hasta c12. A cada fragmento se le debe ubicar un nombre de instancia para poder hacer referencia a él en la programación 2. en igual número. (Cada símbolo debe llevar un nombre de instancia. Manual de Macromedia Flash 8.

f5. f6_y=_root. A cada fragmento se le deberá crear una variable (programación) para almacenar la ubicación del símbolo (tanto en X como también en Y) en el documento._y._x._y.f6.f1.f9. f12_x=_root._y.startDrag ()._x._x._y.f8. 4. f3_y=_root. # 23 .c6)) {this.f3. f11_y=_root.f7.f1. f10_y=_root.f11.hitTest(_root._y. Manual de Macromedia Flash 8. f2_x=_root. Nombres de las variables (X._x._x.Centro Americano Integral de Idiomas y Computación C@INICOMPUT S.f12. f9_y=_root._x._y._x. f5_x=_root. llego la hora de escribir el código de movimiento a cada fragmento._x.f9.A.f5._y. Después de haber creado las variables a cada fragmento. f6_x=_root. Proceso del movimiento y validación.f3. En las acciones del escenario se creará todas las variables para cada fragmento de la foto para almacenar su ubicación con relación a la pantalla. f7_x=_root._y.Y) Nombre de instancia del fragmento._x.f10. f9_x=_root.f2. f7_y=_root. } on (release) { if (this. f4_x=_root. f10_x=_root.0 3._y. f5_y=_root._x.f8. on (press) { this. f2_y=_root.f11._y.f7._y. f3_x=_root.f10. Pág. f12_y=_root.f2. f1_y=_root.f6. f1_x=_root._x._x.c6._x.f12.f4. f8_y=_root._x=_root. f4_y=_root.f4. f11_x=_root. f8_x=_root._y.

f6_y. if (this. Manual de Macromedia Flash 8.f6_x._y=_root. this.Centro Americano Integral de Idiomas y Computación C@INICOMPUT S. this. {this. stopDrag().} else { stopDrag().c6.startDrag (). else { stopDrag()._y.c6)) Si esto es verdadero al fragmento se le asignará la posición del símbolo (rectángulo) que le corresponde. StopDrag () .c6._x=_root.f6_x.} En caso contrario es decir que el fragmento no colisiono con el símbolo que le corresponde se le asignara la ubicación inicial que se encuentra almacenada en la variable.c6._y. this.} Como usted sabra esta programación es para cada uno de los fragmentos y debe cambiarse el nombre dependiendo el fragmento y el rectángulo en que se este programando. on (press) { this. # 24 ._y=_root._y=_root._x=_root. } Luego dentro del evento on (release) se hará la validación al momento de soltar el clic se preguntará si ha hecho colisión en el símbolo (rectángulo) correcto._x=_root.f6_y.A._x. this._y=_root.0 this. this.hitTest(_root.} } En las primeras líneas de código lo que se logra es que el objeto se mueva al hacer clic sostenido sobre el y arrastrarlo en la pantalla. Pág.

You're Reading a Free Preview

Descarga
scribd
/*********** DO NOT ALTER ANYTHING BELOW THIS LINE ! ************/ var s_code=s.t();if(s_code)document.write(s_code)//-->