P. 1
Cap 06 Ejemplos Sencillos de HEC-RAS

Cap 06 Ejemplos Sencillos de HEC-RAS

|Views: 32|Likes:
Publicado porAndy Carrera

More info:

Published by: Andy Carrera on Apr 07, 2013
Copyright:Attribution Non-commercial

Availability:

Read on Scribd mobile: iPhone, iPad and Android.
download as PDF, TXT or read online from Scribd
See more
See less

11/14/2013

pdf

text

original

_____________________________________________Capitulo 6.

Ejemplos sencillos de HecRas

CAPITULO 6. EJEMPLOS SENCILLOS DE HEC-RAS
1 DESCRIPCIÓN: En esta sesión realizaremos algunos ejercicios básicos para familiarizarnos con el entorno HEC-RAS. Veremos el procedimiento a seguir para construir un proyecto HEC-RAS desde la introducción de la geometría hasta el estudio y comparación de diversos resultados. 2 CREACIÓN DEL PROYECTO El primer paso para iniciar el ejercicio consiste en lanzar la aplicación HEC-RAS, y crear un nuevo proyecto, para ello basta con escoger la opción de menú:
File New Project

Aparecerá la clásica ventana HEC de selección de carpeta y de nombre del proyecto donde escribiremos el nombre de proyecto “Ejemplo1.prj” y la descripción, “Primer ejemplo del curso”.

Resulta importante introducir una descripción adecuada para el proyecto ya que los nombres deben ser preferiblemente cortos para evitar problemas. Otro aspecto importante esta en las unidades, por defecto el modelo HEC-RAS trabaja con unidades del sistema británico, a través del menú:
Options Unit Sytem (US Customary/SI)

Podemos escoger el sistema internacional, dentro del mismo menú de opciones existen otros elementos de la configuración básica de HEC-RAS. Un proyecto HEC esta formado por una serie de ficheros que contienen datos de proyecto, datos de condiciones de contorno, geometría y datos de plan, que podemos traducir como datos de caso. En general por extensiones podríamos describir estos ficheros como:

1

_____________________________________________Capitulo 6.Ejemplos sencillos de HecRas

Tabla 1. Ficheros integrados en un proyecto. Proyecto Ejemplo1.prj Geometría Ejemplo1.g01 Condiciones de contorno permanente Ejemplo1.f01 Condiciones de contorno no permanente Ejemplo1.u01 Caso Ejemplo1.p01

A medida que vayamos avanzado en el proyecto se irán creando los diferentes ficheros que lo conforman, todos los enumerados en la tabla anterior correspondientes a datos de proyecto son ficheros de tipo ASCII modificables mediante cualquier editor de texto simple (Wordpad, Notepad, …). Asociados a los proyectos y a los diferentes casos que los integran aparecen unos ficheros de extensión “*.O01” y “*.r01” que se generan en el momento del cálculo de un caso (plan) concreto, estos ficheros los genera el programa “snet.exe” que es el módulo de cálculo en régimen permanente de HEC-RAS, este modulo esta escrito en FORTRAN a diferencia del entorno gráfico “ras.exe” que está escrito en Visual Basic. El primero de los ficheros “*.O01” es un fichero binario (no editable con Notepad) que contiene los resultados del calculo, el segundo fichero “*.r01” es un fichero de datos ASCII en el formato interpretado por el módulo de cálculo, también es legible pero es de más difícil comprensión que el resto de ficheros ASCII del proyecto. Los ficheros de resultados (*.O01 *.r01) están siempre asociados a un plan, es decir que para cada fichero de tipo caso, “Ejemplo1.p01” habrá asociados unos resultados (“Ejemplo1.O01”, “Ejemplo1.r01”), esto implica que si tenemos tres planes diferentes tendremos tres resultados diferentes. Ambos ficheros son resultado del cálculo de un caso, por lo que se pueden omitir al copiar un proyecto ya que para obtener nuevamente los resultados bastara con recalcular el caso del proyecto. Esto puede resultar interesante cuando debemos enviar un proyecto por mail ya que si el proyecto consta de muchos casos y geometrías complicadas pueden ser de un tamaño considerable, por lo que podemos prescindir de enviar los ficheros de resultados y recalcular el proyecto en el ordenador de destino. Para que un proyecto creado en una carpeta sea valido en otro ordenador o carpeta tenemos que copiar todos los ficheros anteriores (Ejemplo1.*) a la nueva ubicación y bastará con que estén en la misma carpeta para que funcionen correctamente, esto se debe a que las rutas (path) de los ficheros que integran un proyecto se almacenan de forma relativa, no absoluta. Para las diferentes geometrías, condiciones de contorno o casos incluidos en un proyecto, si realizamos alguna modificación respecto al anterior y deseamos guardarla de manera diferente, el programa seleccionará una numeración consecutiva a los existentes y guardara el fichero con el mismo nombre del proyecto y la numeración consecutiva. Es decir si poseemos la geometría “Ejemplo1.g01” y la modificamos y guardamos con un nuevo nombre el programa seleccionara el nombre “Ejemplo1.g02”. Por lo tanto el nombre del fichero no nos permitirá incluir información sobre la modificación realizada, esta información debe incluirse en el espacio reservado para la descripción. 3 CREACIÓN DE LA GEOMETRÍA Una vez creado el proyecto, el orden en la introducción de datos debería ser, primero la geometría del caso, segundo las condiciones de contorno, tercero los parámetros de cálculo del caso y finalmente los resultados. Por lo tanto el primer paso será crear la geometría. Para acceder al editor de geometría lo hacemos a través del la barra de herramientas principal del programa.

2

_____________________________________________Capitulo 6.Ejemplos sencillos de HecRas

Una vez dentro del editor vemos que aparecen múltiples herramientas además de unos menús cargados de diferentes opciones. La geometría está formada por dos elementos fundamentales, el río (stream) y las secciones (crossections). Para realizar cualquier cálculo es necesario partir de estas dos informaciones. En general en la actualidad se parte de herramientas de tipo GIS para el la realización de las geometrías cuando se trata de cauces naturales, sin embargo para cauces de diseño se puede trabajar directamente dentro de HECRAS. 3.1 Eje del río El primer elemento que crearemos será el eje del río, éste consiste en una polilínea que marca el cauce del río. Para dibujarla utilizaremos la herramienta correspondiente dentro del editor. En principio no resulta excesivamente importante este trazado por dos razones, en primer lugar la geometría de este cauce no interviene para nada en el cálculo. Únicamente interesa la esquematización del la zona de estudio, es decir el numero de tramos de estudio, que tipo de uniones existen entre ellas, etc…

En segundo lugar el editor no dispone de herramientas que permitan un dibujo preciso del eje del río, ni siquiera se pueden introducir distancias. Sin embargo existe una tabla en el menú: 3

Una vez introducido el eje del río nos aparece en la pantalla del editor de geometría el eje con unas etiquetas indicando el nombre. En principio para este ejercicio partiremos de un eje sencillo con un solo tramo de río. empezando por la tolerancia de cálculos que es de 10 cm. no de encauzamientos y todos los elementos en el presentes apuntan en esa dirección. 4 . escogemos la herramienta de dibujo del eje.Ejemplos sencillos de HecRas Edit Reach Schematic Lines … Donde si se permite editar a mano las coordenadas del eje del río. A lo largo de todo el curso debe tenerse muy presente que el programa HEC-RAS se creó para el cálculo de ríos. Es muy importante ser consciente de que las dimensiones de este eje no son significativas de cara al cálculo. Es decir que el eje aparezca curvado o no o más largo o menos no afecta en absoluto al cálculo. trazamos una serie de puntos teniendo en cuenta que el trazado se realiza de aguas arriba hacia aguas abajo y cuando hayamos finalizado el trazado terminamos con un doble clic haciendo que aparezca un formulario para introducir el nombre del río que estamos modelando (river) así como el nombre del tramo concreto (reach)._____________________________________________Capitulo 6. inaceptable para el cálculo de una obra de dimensiones reducidas.

esto significa cual es el punto kilométrico de la nueva sección dentro del río.1 Sección ya existente o ya diseñada Para introducirla seleccionamos la herramienta Edit and/or create crossections de la barra de herramientas. ya sea existente o de proyecto. el modelo admite valores negativos. ya que el procedimiento de extraer manualmente la topografía de las secciones e introducirlas en el programa resulta demasiado lento.2 Secciones del río. SMS). En el caso de que se trabaje con secciones naturales extraídas mediante una herramienta GIS el propio HEC-RAS dispone de una serie de filtros geométricos para simplificar la geometría de manera que los cálculos sean más rápidos. para ello usamos el menú: Options Add A new Crossection … En ese momento nos preguntará el river station.2.Ejemplos sencillos de HecRas 3. Par introducir una sección ya existente la única alternativa es hacerlo mediante la introducción directa sin embargo si se trata de una sección de prototipo podemos hacerlo mediante dos herramientas más ya existentes dentro del HEC-RAS. Una vez introducido el eje vamos a introducir las secciones. Por lo tanto partiremos de la hipótesis de que se trata de una sección artificial. El orden de los puntos kilométricos empieza con en 0 en el final del tramo creciendo hacia aguas arriba._____________________________________________Capitulo 6. Arcmap) o un programa específico (River CAD. 3. En el primer caso si se trata de un cauce natural debería trabajarse sobre un entorno GIS (Arcview. se nos abrirá el editor de secciones donde en primer lugar debemos crear una nueva sección. en esta parte resulta fundamental el hecho de si se modela un caso real o se modela un prototipo. 5 .

_____________________________________________Capitulo 6. channel. Como comentarios debe decirse que es posible asignar un coeficiente de Manning diferente para cada abscisa. El más importante de todos es el correspondiente al par Station/Elevation.s. Sabemos que la sección se divide en tres partes. por lo que ROB < Channel < LOB. Estos tres valores resultan fundamentales por varias razones. left overbank. el orden de las abscisas debe ser mirando la sección desde aguas arriba hacia aguas abajo de izquierda a derecha. el programa calculará la longitud total del río a partir de la suma de todas las distancia channel.n. por lo tanto existe una casilla para cada una de estas distancias.m). Por otra parte sobre las rugosidades debe tenerse en cuenta que esta se introduce a través de la conveyance: 6 . en este caso si estamos introduciendo la sección última la longitud hasta la siguiente debe ser 0. causando pérdidas de energía diferentes para cada uno de ellos.Ejemplos sencillos de HecRas Un introducido el punto kilométrico de la primera sección debemos llenar varios campos dentro de la sección. right overbank. por otra parte si estamos trabajando en un sistema no georeferenciado. Posteriormente introduciremos el valor de los coeficientes de perdidas para cada una de las partes de las secciones y la abscisa en la que empieza cada una de las partes de la sección. en el lado interior de la sección las distancias hasta la siguiente sección serían menores. Estos valores de deben introducir en cota absoluta (m. Por ejemplo en una curva del flujo hacia la derecha. que es el correspondiente a las longitudes hasta la sección siguiente. El segundo valor que se debe introducir es el de Downstream Reach Lengths. la primera es que si estamos en un tramo curvo la única modificación que se produce en el cálculo es debido a la diferente longitud de estas tres distancias. Cada una de estas partes puede tener una distancia diferente hasta la sección de aguas abajo. donde se deben introducir los valores de abscisa/cota de nuestra sección. para ello basta usar el menú: Options Horizontal Variation in n Values … Esto hará aparecer una tercera columna donde introduciremos el valor de la rugosidad para cada abscisa y será valido desde esa hasta siguiente. Para los puntos situados a la izquierda se admiten valores de Station negativos.

el aera._____________________________________________Capitulo 6. así si tenemos tramos de sección con diferente Manning y con pendiente geometrica menor de 5H:1V se combinan los tramos de diferente rugosidad según la fórmula: Donde cada rugosidad interviene según el perímetro que le corresponde. A. Por otra parte para pendientes mayores se calcula cada tramo de Manning por separado con su propia conveyance. cada uno con una conveyance propia que finalmente se suma para tener la equivalente de toda la llanura. los overbanks siempre se dividen por tramos de diferente rugosidad. n. K .Ejemplos sencillos de HecRas 2 Q = KS 1/ f K= AR 2 / 3 n Donde Q. pero cuando tiene más de uno se sigue un criterio que depende de la pendiente del perfil de la sección. la conveyance. De cara al cálculo. R son el caudal. En el channel se pretende utilizar una única conveyance equivalente. De cara a la evaluación de la rugosidad de una sección compuesta se sigue el siguiente criterio. en el caso de que éste posea un único Mannig no hay problema. todo ello conduce a una división de las propiedades del flujo según el esquema: Para este caso trabajaremos con una sección trapezoidal simple. Una vez introducidos todos los parámetros de la sección característica el resultado final es el siguiente: 7 . el coeficiente de Mannig y el radio hidráulico respectivamente.

Por lo tanto la pendiente final del tramo será de un 3 por mil.Ejemplos sencillos de HecRas Ahora creamos la sección aguas arriba. Por último deberemos ajustar las cotas de esta sección ya que esta a mayor altura que la inferior. los ángulos de los taludes y las profundidades totales de los diferentes tramos de la sección. ya que los tres tramos de esta sección (overbanks y channel) están a 1000 metros de la sección de aguas abajo. Desde este editor escogemos el menú: Options-->Copy Current Cross Section Introducimos el punto kilométrico de la sección de aguas arriba. para este caso el P. En este asistente se introducen los parámetros fijos de diseño y el programa nos calcula los variables.2. para acceder a ella haremos: Run-->Hydraulic Design Functions . 1000. Y aparecerá una pantalla en la que introduciremos un 3 haciendo que todas las cotas de la sección se incrementen en 3 unidades. Los parámetros que se pueden considerar fijos son la pendiente del tramo. el caudal que circula. overbank. es 1000. En este caso la herramienta que utilizaremos es el asistente de diseño hidráulico. para ello iremos al menú: Options-->Adjust Elevations . Esta herramienta consta de cinco componentes: a) Calculo de regimenes normales b) Diseño de secciones por capacidad c) Diseño de secciones naturales estables d) Calculo de erosión en pilas e) Capacidad de transporte de sedimentos En este caso para este cálculo utilizaremos el diseño de secciones por capacidad.... Esta herramienta es específica para cauces artificiales. 3._____________________________________________Capitulo 6. para ello vamos al editor de geometría desde la barra de herramientas y clicamos en la herramienta Edit and/or create cross sections. Los parámetros variables corresponden con los anchos de cada elemento. channel.Hydraulic Design Package for Channels 8 .K.. 1000. Ahora nos falta ajustar los valores de las distancias hasta la sección de aguas abajo que en este caso será 1000. la herramienta para cauces naturales (c) esta derivada del modelo: SAM .2 Diseño de sección por capacidad La siguiente manera de introducir la sección de diseño es a través del asistente para la creación de secciones.

Introducimos una longitud WL y WR de tanteo de 5 metros. Los elementos asociados al transporte de sedimentos no forman parte de este curso. Para nuestro caso introducimos una pendiente de 3 por mil._____________________________________________Capitulo 6. al darle al botón Apply Geometry obtenemos la sección resultado de nuestro dimensionamiento geométrico. Se fundamenta en teorías como la fuerza tractiva o teoría del régimen.5 metros. Dentro de esta herramienta escogemos la pestaña correspondiente a: Width Como hemos comentado anteriormente los datos necesarios son los que aparecen en las siguientes figuras. 9 ..Ejemplos sencillos de HecRas Desarrollado por Coastal and Hydraulics Laboratory (CHL). unos taludes 2:1 (H:V) y una altura de canal de 2 metros y de overbanks de 0. la altura de éste se debe imponer. pero podemos imponer un cierto calado para imponer un resguardo y dando el caudal y la pendiente al darle al botón Compute. Para acceder a la herramienta que nos interesa dentro de Hydraulic Design ejecutamos: Type-->Uniform Flow .. Esta herramienta funciona correctamente para el cálculo del ancho que debe tener el channel para transportar un cierto cauda. el programa calcula cual es el ancho necesario para obtener el régimen normal deseado.

punto kilométrico.K. para ello vamos al editor de geometría desde la barra de herramientas y clicamos en la herramienta Edit and/or create cross sections. altura. ancho inferior._____________________________________________Capitulo 6. para ello iremos al menú: Options-->Adjust Elevations .K. es 1000. para este caso el P. cota absoluta del punto inferior. 3. ya que los tres tramos de esta sección (overbanks y channel) están a 1000 metros de la sección de aguas abajo. Por lo tanto la pendiente final del tramo será de un 3 por mil.. de la sección de diseño.3 Asistente de diseño de secciones La siguiente manera de introducir las secciones de diseño consiste en ir al editor de geometría desde la barra de herramientas y una vez dentro de este ejecutar: Tools-->Design Crossections Se nos abrirá una tabla en la que tenemos que introducir características muy sencillas de las secciones que queremos crear.. Por último deberemos ajustar las cotas de esta sección ya que esta a mayor altura que la inferior. para nuestro caso lo parámetros serán los siguientes: 10 .2. en este caso 0. Desde este editor escogemos el menú: Options-->Copy Current Cross Section Introducimos el punto kilométrico de la sección de aguas arriba. distancia hasta la sección aguas abajo y rugosidad y a partir de estos parámetros nos construye las secciones. Y aparecerá una pantalla en la que introduciremos un 3 haciendo que todas las cotas de la sección se incrementen en 3 unidades. pendiente de los taludes. 1000. Ahora nos falta ajustar los valores de las distancias hasta la sección de aguas abajo que en este caso será 1000. 1000.Ejemplos sencillos de HecRas Cuando la sección resulta satisfactoria ejecutamos Copy XS to Geometric Data e introducimos el P. Ahora creamos la sección aguas arriba.

La imagen actual en el editor de geometría es la siguiente: 11 . Es importante saber que para estas secciones aparezcan debe existir el río y el tramo a que se hace referencia en el asistente. estas secciones se crean mediante un interpolador. pero como están muy separadas (1000 m) el error sería importante. aceptamos y ya aparece la nueva geometría con las dos secciones creadas. y con el botón Make Designed Cross Sections aparece un aviso de que se van a crear nuevas secciones. 3._____________________________________________Capitulo 6.Ejemplos sencillos de HecRas En esta tabla ya introducimos los datos correspondientes a las dos secciones que queremos crear en el modelo. estos son los elementos mínimos para un tramo. ya que a pesar de que se trata de un esquema numérico de orden 2 (Average Conveyance) es un delta de X demasiado grande. Ahora con las secciones definidas podríamos realizar un cálculo. Por lo tanto necesitamos crear nuevas secciones para el cálculo.3 Interpolación de secciones Con estos parámetros ya creamos una sección aguas abajo y otra aguas arriba.

. La segunda herramienta de interpolación es específica para la interpolación entre dos secciones y permite un control mayor sobre la interpolación. es decir podemos establecer correspondencias entre tramos de la sección aguas arriba con tramos en la sección aguas abajo. y entre estos tramos establecerá una correspondencia lineal y sobre esta interpolará.._____________________________________________Capitulo 6... el tramo y dentro de este tramo escoger una zona concreta. Se puede especificar el río.Ejemplos sencillos de HecRas La herramienta para la interpolación se encuentra en el editor de geometría en el menu: Tools-->XS Interpolation-->Within a Reach . El programa HEC-RAS siempre realiza interpolaciones lineales de geometría. esto permite utilizar densidades de interpolación diferentes en función de las necesidades de la zona. pero este editor nos permite delimitar los tramos a interpolar. 12 . Existe otra alternativa llamada Between 2 XS's . La primera de ellas nos permite crear secciones interpoladas a lo largo de un río.

por lo que no se realiza un balance global del flujo de energía que circula.g01". Apareceré una pantalla en la que nos listará las geometrías actualmente asociadas a nuestro proyecto. La siguiente condición de contorno necesaria es un calado. 4 CONSTRUCCIÓN DE CONDICIONES DE CONTORNO El siguiente paso lógico para la construcción del modelo consiste en introducir las condiciones de contorno. si seleccionamos una ya existente la sobrescribirá. siempre será necesario introducir el caudal en nuestro tramo.. si únicamente introducimos la descripción de la nueva geometría la guardará con un nombre numéricamente consecutivo con la última del proyecto. perdiéndose la antigua. Dentro de la 13 . ni en las uniones. Llegados a este punto se debe guardar la geometría. para ello especificaremos nosotros el nombre. sino se calcula un balance de la energía específica. es decir el programa no exige continuidad en el caudal dentro del tramo. el caudal circulante puede variarse en una sección cualquiera del tramo. es decir la interpolación realizada por programa siempre crea secciones a una distancia igual o menor a la especificada.. Por otra parte el programa calcula la línea de energía.Ejemplos sencillos de HecRas Es importante destacar que las distancias de interpolación especificadas siempre son una cota superior. lo que quiere decir que todo el caudal introducido pasa a a tener la misma energía que el que ya circulaba por el cauce. para el correcto uso de esta condición de contorno es necesario conocer algo de la teoría hidráulica._____________________________________________Capitulo 6. es cualquier caso únicamente podemos introducir la descripción ya que el programa se reserva la capacidad de decidir el nombre real del fichero de geometría. Estos nombres siempre están constituidos por el nombre del proyecto más una extensión que para las geometrías es "g" y un número consecutivo con la última geometría introducida. así que dentro del editor de geometría escogeremos el menú: File-->Save Geometry Data As . Esto conduce a situaciones en las que podemos duplicar el caudal en una determinada sección y en lugar de conservarse la energía total del flujo se conserva la energía específica. en nuestro caso como se trata de la primera del proyecto será ". ya que el gravado automático genera nombres que no aportan información sobre el fichero. Las condiciones de contorno necesarias pueden variar en función del problema.

Además de los tramos en los que varia el caudal también se debe el numero de caudales de calculo. Visto todo lo anterior ahora nos vamos al menú de condiciones de contorno. Para empezar asignaremos un caudal de 100 m3/s y pasaremos a imponer las condiciones de contorno sobre el calado. La pantalla principal que aparece ahora es la que nos permite imponer los caudales. es decir para una misma configuración podemos probar caudales diferentes. El quedarse siempre con la solución de mayor fuerza es sencillamente por que la fuerza específica define el peso que tiene la condición de contorno en esa sección concreta. ya que en estos saltos no se cumple la ecuación. por lo tanto necesitamos una nueva ecuación que si que se cumpla en estas situaciones._____________________________________________Capitulo 6. y siempre gana la condición de contorno que ha dado una mayor fuerza específica en la sección. por defecto el caudal se introduce aguas arriba del tramo y es posible introducir nuevos caudales en diferentes puntos del tramo. Una vez calculadas ambas soluciones para buscar la definitiva se evalúa la fuerza específica de cada una de las soluciones en cada nodo y nos quedamos la mayor. Esto se debe a la naturaleza de las ecuaciones de Saint-Venant que establecen el problema dinámico y en ellas se comprueba que únicamente tiene sentido un problema físico en el que la condición de calado en régimen rápido se imponga aguas arriba y el calado del régimen lento se imponga aguas abajo. La justificación de esta metodología viene dada por el hecho de que la ecuación de la energía no permite salto de régimen.Ejemplos sencillos de HecRas conservación de la energía (Bernoulli) en la resolución de problema conocido como Step Method aparecen en general dos soluciones. de manera automática el programa detecta cuantos tramos hay en la geometría y permite introducir un caudal para cada uno de ellos. Sin embargo para el caso permanente no debería ser así ya que basta conocer el calado en un punto (en general) para poder construir la solución. Si como hemos dicho la solución en rápido y la solución en lento son únicas debe bastar con introducir un solo calado de cada una de ellas y se construye la solución. por lo tanto en general se introducen dos condiciones de contorno una para la solución en rápido y otro para la solución en lento. una por encima del calado crítico y otra por debajo. y esta ecuación es la de la fuerza específica. Sin embargo en general solo se permite introducir el calado para la solución en lento aguas abajo y el calado para la solución en rápido aguas arriba. para ello ejecutamos Reach Boundary Conditions 14 . las definimos como régimen lento y régimen rápido. Para que la solución sea correcta no es posible que uno de los Steps se produzca un salto de régimen.

Imponer el calado normal supone que introducimos la pendiente y el programa calcula a que calado normal corresponde esta pendiente. Así los ingredientes fundamentales de una caso son una geometría y unas condiciones de contorno. y esto permite comparar situaciones y soluciones diferentes.Ejemplos sencillos de HecRas Vemos que existen diferentes alternativas para dar los calados en los extremos del tramo. Una vez introducidos los valores de cálculo ejecutamos desde la pantalla de Steady Flow Data File-->Save Flow Data As Y nos permiten guardar los datos introducidos con un descripción. 15 . 5 CASO (PLAN) Una vez establecidas las condiciones de contorno ya solo falta definir el caso (Plan). así podemos realizar un calculo con la geometría del estado actual y otro con la geometría de proyecto._____________________________________________Capitulo 6. Como puede versa la versatilidad en las condiciones de calculo es importante y debe aprovecharse. el caso resulta fundamental ya que como se ha mencionado anteriormente para cada uno de los casos definidos se guardan unos resultados. Escogemos la herramienta de Plan.). es importante realizar este paso ya que podemos introducir varios escenarios diferentes correspondientes a caudales diferentes y a condiciones de contorno diferentes como por ejemplo nuestro tramo vaya en avenida y la desembocadura no o a la inversa unas cotas de agua altas en la desembocadura y bajas aguas arriba. se puede hacer como una cota absoluta de agua (Known W. Todos estos métodos acaban conduciendo a la imposición de un calado.S. un calado normal o una curva de aforo. el calado crítico.

si se escoge el mixto la solución final será la de máxima fuerza especifica. es decir tenemos que definir qué solución queremos... Si únicamente queremos una de las soluciones (supercritical. la presentación 3D. las tablas de resultados. En este formulario además hay varios menús importantes correspondientes a parámetros de cálculo. De momento únicamente vamos a mencionar el menú: Options-->Critical Depth Output Option .Ejemplos sencillos de HecRas Y aparece una pantalla en la que escogemos la geometría de cálculo y las condiciones de contorno con las que queremos realizar el cálculo. Que nos permitirá presentar siempre en los resultados el calado crítico. subcritical) bastara con dar una de las condiciones de contorno. 16 ._____________________________________________Capitulo 6. entre los más destacables están los perfiles longitudinales. para ello basta apretar el botón Compute. Con todos estos elementos ya podemos realizar el primer cálculo. 6 RESULTADOS El programa HEC-RAS dispone de una gran variedad de opciones para la presentación de resultados. Debe haber una correspondencia entre ambas ya que las condiciones de contorno hacen referencia a ubicaciones de la geometría por lo que estas ubicaciones deben existir en la geometría de cálculo o tendremos un error. Otro elemento muy importante de esta pantalla es el tipo de régimen. las secciones. Al igual que en el caso anterior es necesario guardar el fichero con una descripción concreta: File-->Save Plan As Veremos que además del nombre del plan nos pedirá una descripción breve.

Haciendo: Options-->Variables . en ella se ve el perfil longitudinal del canal así como los valores de lámina de agua. es decir cotas absolutas.s.. por lo tanto ni la velocidad ni el Froude ni ningún otro elemento se puede consultar desde esta pantalla.Ejemplos sencillos de HecRas 6. Podemos ver una ventana en la que escogemos las variables que queremos representar. línea de energía. etc.m). 17 ._____________________________________________Capitulo 6.1 Resultados de perfil longitudinal Esta es la salida básica de resultados..n. todas las variables representables en este modo tienen como unidades (m.

6. es muy adecuado en el cálculo de puentes por que nos da los detalles de cada uno de los cálculos. colores y etiquetas son completamente configurables. Al igual que en el caso anterior las leyendas. como dibujo e incluso es formato DXF.Ejemplos sencillos de HecRas Como es común a otras salidas de datos de HEC-RAS es fácilmente editable. podemos escoger desde los colores de los gráficos las etiquetas y las leyendas. en total más de 160 variables diferentes. Una de las variables mas importantes es el calado. este aparece en el menú como Max Chl Depth.3 Resultados por sección Cuando existe alguna sección problemática esta es la opción que nos permite ver informaciones detalladas de la sección. pasando desde las velocidades hasta las tensiones de fondo.2 Resultados generales La única diferencia respecto a los perfiles anteriores es que ahora se puede crear el perfil de cualquiera de las variables de cálculo del programa. exportarlos los resultados como tabla. 18 . El único problema de esta ventana es que si se dibujan (plotean) variables de unidades y ordenes de magnitud muy diferentes resulta difícil ver claramente los resultados ya que no permite utilizar el eje secundario Y._____________________________________________Capitulo 6. 6.

4 Tabla de resultados Esta tabla reproduce los mismos resultados que hemos visto en los perfiles pero lo hace en forma de tabla de manera que resulta más sencilla la consulta de valores concretos.Ejemplos sencillos de HecRas 6. Se suele poner como anejo de resultados. 19 ._____________________________________________Capitulo 6. el único inconveniente es que no es posible traducir las cabeceras de las columnas por lo que quedarán necesariamente en Inglés.

En el 20 . 8 MAS EJEMPLOS Como continuación al capítulo veremos varios ejemplos para tratar de entender la mecánica de cálculo del programa HEC-RAS._____________________________________________Capitulo 6. Uno de los éxitos del programa HEC-RAS y motivos por los que parece fácil de utilizar es que independientemente de los errores que aparezcan durante el cálculo siempre obtenemos un resultado. Para este caso el HEC-RAS aplica el método de la energía específica.Ejemplos sencillos de HecRas 7 WARNINGS Este elemento normalmente se ignora pero resulta fundamental ya que únicamente aquí veremos todos los errores encontrados durante el cálculo. En el primero de ellos veremos el cálculo de regímenes mixtos. Estos son los que contienen una parte del flujo en régimen lento y otra parte en régimen rápido. Por todo ello es necesario revisar los warnings arrojados por el programa para garantizar que no existe ninguno de ellos crítico. Siempre es tolerable un número de avisos mientras ninguno de ellos sea crítico.

primero configuraremos algunos aspectos del programa. para ello nos vamos al editor de secciones y seleccionamos el menú: Options Add a new Cross Section . El siguiente paso consiste en introducir las secciones correspondientes al tramo. para ello vamos al editor de geometría y definiremos un nuevo eje con nombre de río “Río” y nombre de tramo “Tramo1”. y como los aborda el programa HEC-RAS. En el tercer ejemplo veremos como altera las curvas de remanso la presencia de pérdidas por contracción expansión. 9 PROLEGÓMENOS. 10 EJEMPLO 1. como descripción del proyecto daremos “Calculo de régimen mixto”. COEFICIENTES Y UNIDADES Como prolegómeno a la creación de los ejemplos._____________________________________________Capitulo 6. Para el trazado del eje nos bastara una línea recta. para ello basta con abrirlo y dentro de la ventana principal del programa vamos al menú: Options Unit System (US Customary/SI) … Y dentro de la ventana que aparece seleccionamos sistema internacional. 0. El siguiente paso es la definición de la geometría.. En primer lugar y como siempre definiremos un nuevo proyecto dentro de alguna carpeta conocida que llamaremos “Ejemplo1.prj”. El cuarto ejemplo será un análisis de sensibilidad respecto a las distancias de interpolación.Ejemplos sencillos de HecRas segundo ejemplo veremos la influencia del posicionamiento de los banks de la sección. RÉGIMEN MIXTO: Como se ha comentado en la introducción aquí veremos el cálculo de regímenes mixtos. 21 .. además de definirlo como sistema por defecto: Por otra parte en el menú: Options Default Parameters Expansion and Contractions Coef… Definimos como parámetros por defecto para la expansión y contracción los valores 0.

para ello desde el menú: Options-->Adjust Elevations . Subimos 8 metros las cotas. La geometría consiste en una sección de tipo trapezoidal de coordenadas y parámetros: El siguiente paso consiste en copiar la sección a la posición 2000...Ejemplos sencillos de HecRas Como punto kilométrico de la primera sección introducimos el “0”. por lo que si la distancia a la sección siguiente es de 2000 metros la pendiente del tramo es del 4 por mil.. para ello ejecutamos el menú: Options-->Copy Current Cross Section . 2000 y 2000. Con esta sección concluida estamos en disposición de interpolar las restantes secciones del sistema. Para ello cerramos el editor de secciones y volvemos al editor principal de geometría. De la misma manera debemos rectificar las cotas de la sección para introducir la pendiente.._____________________________________________Capitulo 6. ahora desde el menú: 22 . las nuevas distancias son 2000. ahora ya podemos introducir los valores correspondientes a esta sección. Y escribimos la nueva posición “2000” ahora debemos cambiar las distancias hasta la próxima sección aguas abajo.

. como la pendiente. En esta pantalla si presionamos la tecla “control” podemos trazar una línea recta y al soltar la tecla aparece una pantalla con información de la línea trazada. De todas ellas seleccionamos Profile Plot y vemos que aparece una nueva ventana con el perfil longitudinal de nuestro tramo.. Llamamos al interpolador de secciones. Interpolamos una sección cada 20 metros. para ello desde el editor principal de geometría clicamos sobre el eje del tramo y aparece un menú contextual con las siguientes opciones._____________________________________________Capitulo 6. para la geometría sencilla de este problema basta con este interpolador simple. El siguiente paso consiste en la 23 . Podemos ver el perfil del tramo que hemos diseñado. ahora podemos guardar la geometría con el nombre de “Interp 20”.Ejemplos sencillos de HecRas Tools-->XS Interpolation-->Within a Reach .

podemos ver que estamos en un régimen lento. sub”. vemos que el resultado es idéntico al obtenido al seleccionar 24 . Ejemplo 1. en este caso en régimen lento. mixed”. Q 100. con estos elementos seleccionamos como tipo de régimen del cálculo “Mixed”. para ello volvemos al editor de plan y ahora en lugar de régimen mixed seleccionamos supercritical. como nombre corto “I20Q100SUB” y al igual que en el caso anterior lo calculamos.Ejemplos sencillos de HecRas creación de las condiciones de contorno. En ella vemos los resultados del último cálculo realizado. Las condiciones que debemos imponer en este caso son régimen crítico arriba y abajo y un caudal de 100 metros cúbicos por segundo. como nombre corto “I20Q100SUP”. Una vez creadas las condiciones de contorno el siguiente paso es crear el caso o plan. dentro de este podemos ver que por defecto se ha seleccionado como fichero de geometría el que hemos creado “Interp 20” y como fichero de condiciones de contorno “Caudal 100 m3/s”. mixed 14/06/2006 Legend WS PF 1 Rio Tramo1 10 Crit PF 1 Ground 8 Elevation (m) 6 4 2 0 0 500 1000 1500 2000 2500 Main Channel Distance (m) Ahora vamos a analizar la influencia del régimen. Guardamos el plan como “Interp 20. Régimen mixto 12 Plan: Interp 20._____________________________________________Capitulo 6. desde la pantalla principal seleccionamos la herramienta Profile Plot esta herramienta nos muestra un perfil del terreno y la lámina de agua. ahora podemos presionar el botón “Compute” de la pantalla. Ahora tenemos calculado el mismo caso en régimen lento y régimen rápido. super”. Para ver los resultados. Cuando acabe el cálculo volvemos a la pantalla plan y ahora seleccionamos subcritical como tipo de régimen y guardamos como “Inter. Q 100. Para ello desde la ventana principal abrimos el editor de plan. Para ello desde la ventana principal de HEC-RAS abrimos la ventana de salida de resultados en perfil Profile Plot. el nombre corto “I20Q100MIX”. Ahora recalculamos con el botón “Compute”. Q 100. podemos comparar ambos resultados. Ahora guardamos el caso con el nombre de “Interp 20. Guardamos el fichero con la descripción “Caudal 100 m3/s”. 20. para ello vamos a la ventana principal de HEC-RAS y dentro de ella escogemos la herramienta de editar condiciones de contorno. Q 100.

Después de activar el resultado de régimen rápido y de régimen lento obtenemos la siguiente imagen: 25 . Para ello sobre la pantalla del perfil presionando el botón derecho del ratón aparece un menú contextual del que podemos seleccionar la opción Plans … Entonces nos aparce una lista con todos los plans incluidos en el proyecto.Ejemplos sencillos de HecRas mixed. ya que en este caso se trataba de un canal con régimen normal en lento._____________________________________________Capitulo 6. podemos superponer a la solución lenta la obtenida con régimen rápido. podemos visualizar simultáneamente varios de ellos para comparar los resultados.

Esta ventana nos da los valores de todas las variables calculadas por el programa en nuestro tramo de caudal.I20Q100SUP 8 WS PF 1 .I20Q100SUB Crit PF 1 . para decidir cual es la válida podemos ver las fuerzas específicas asociadas a cada una de ellas.Ejemplos sencillos de HecRas Ejemplo 1. régimen rápido y de ambas soluciones.I20Q100SUB Crit PF 1 . para poder visualizarla. en cada sección nos quedamos la de mayor fuerza específica. son más de 100. la que nos interesa es la fuerza específica._____________________________________________Capitulo 6.I20Q100SUP Ground Elevation (m) 6 4 2 400 600 800 1000 1200 1400 1600 Main Channel Distance (m) Por lo tanto de cara al cálculo en mixed el procedimiento implica el cálculo en régimen lento. En la imagen anterior vemos las dos soluciones. Régimen mixto Plan: 1) I20Q100SUP 14/06/2006 2) I20Q100SUB 14/06/2006 Rio Tramo1 Legend 10 WS PF 1 . situándonos sobre la pantalla presionamos el botón derecho del ratón y en el menú que aparece seleccionamos la opción Plot Variables … 26 . para ello desde la ventana principal del HEC-RAS nos vamos a la herramienta View General Profile Plot.

Ahora al aceptar volveremos a la pantalla y ahora veremos los valores de la fuerza específica obtenida en HEC-RAS. para ello en el panel de la derecha basta con que hagamos doble clic sobre los elementos que aparecen. 27 . por otra parte en la lista de la izquierda seleccionamos Specific Force. ahora para poder comparar los valores en régimen lento y rápido basta con visualizar ambos planes simultáneamente. y del listado seleccionamos el que corresponde al régimen rápido y el que corresponde al régimen lento.Ejemplos sencillos de HecRas Lo primero que tenemos que hacer es deseleccionar las variables que vienen por defecto. para ello al igual en la pantalla de perfiles._____________________________________________Capitulo 6. al presionar el botón de la derecha del ratón. que son las velocidades. en el menú contextual seleccionamos plans.

con un nombre para el río y para el tramo.I20Q100SUP 73. por lo que el caudal circula ocupando las llanuras de inundación.65 73.Ejemplos sencillos de HecRas Ejemplo 1. INFLUENCIA DE LA POSICION DE LOS BANKS: En este ejemplo estudiaremos como influye la posición de los banks en el resultado HECRAS. como los que existen en nuestro ámbito habitual de trabajo.prj”. overbanks).55 73.60 73. sobretodo en cauces de caudales medios bajos.80 Legend Specif Force PF 1 . Para grandes caudales de avenida en general los niveles de inundación son grandes.70 Specif Force (m3) 73.I20Q100SUB 73. En este caso la ubicación exacta de los banks que delimitan las zonas de cálculo se hace innecesaria. Empezaremos como siempre definiendo un nuevo proyecto que llamaremos “Ejemplo2. Los detalles sobre el cálculo de rugosidades y pérdidas de energía se pueden encontrar en el manual “Reference Hydraulic”. el resultado de la lámina de agua debe ser muy similar a la curva de remanso descrita teóricamente. altura 4 metros y ancho de la base inferior de 8 metros. la “0” y la “2000” con un 0. Régimen mixto Plan: 1) I20Q100SUP 14/06/2006 2) I20Q100SUB 14/06/2006 Tramo1 73.75 Specif Force PF 1 . en esta geometría definiremos un eje. Este diferencia de resultados se debe al diferente tratamiento que se aplica sobre las perdidas de energía en función de la zona en la que se calcula (channel. por lo tanto es la que se queda el modelo como resultado válido mixed. por ejemplo canales de sección trapezoidal. 11 EJEMPLO 2._____________________________________________Capitulo 6. Veremos como un posicionamiento incorrecto de los banks originará un alejamiento del calado normal que debería estar presente en la solución. en definitiva una 28 .50 0 500 1000 1500 2000 2500 Main Channel Distance (m) Como aparece en la imagen la solución en régimen lento (I20Q100SUB) posee mayor fuerza específica. asi como dos secciones. dentro de este proyecto definiremos una nueva geometría que llamaremos “Interp 20”. por otra parte para encauzamientos de geometría más reducida y acotada si que esta determinación exacta puede tener influencia ya que en estas estructuras.4% de pendiente y sección trapezoidal de taludes 1:4 (H:V).

Ejemplos sencillos de HecRas geometría idéntica a la del problema anterior. 9. para ello desde la pantalla de edición de geometría hacemos: Tools XS Interpoaltion Within a Reach … De la ventana que aparece. para ello primero abrimos la herramienta de interpolación a lo largo del tramo. Ahora guardamos esta geometría: File Save Geometric Data … Para crear la geometría de comparación primero desinterpolamos._____________________________________________Capitulo 6. 10. a las coordenadas 1. primero seleccionamos “Delete Interpolated XS’s” Después de eso cerramos la ventana y nos vamos al editor de secciones y en las dos secciones originales que hemos introducido modificamos la posición de los banks (puntos rojos) de las coordenadas 0. Estas secciones al igual que en el ejemplo anterior las interpolamos cada 20 metros. Ahora la nueva imagen de la sección debe ser: 29 . Los banks están situados en las abscisas 0 y 10 de nuestras secciones.

Régimen mixto . Q 100. Los nombres cortos serán.02 9 Plan: Interp 20. ahora basta con generar unas condiciones de contorno para ambas. Para visualizar más de un plan al mismo tiempo basta con seleccionar la opción correspondiente del menú contextual que aparece al presionar el botón derecho del ratón sobre la pantalla de resultados (como hemos visto anteriormente) . Disponemos de las dos geometrías para comparar. podemos compara los resultados de ambos plans. El siguiente caso será interpolar secciones cada 20 metros. Para la modificación de la leyenda basta con escoger del mismo menú la opción Lines and Symbols … y dentro de este modificar las visualizaciones de los diferentes elementos._____________________________________________Capitulo 6. que se tratara de un caudal de 100 m3/s. overbanks abajo . ambos planes los llamaremos “Interp 20. El siguiente caso consistirá en crear un plan para cada una de las geometrías calculándolas con las condiciones de contorno descritas anteriormente. Q 100. las condiciones de contorno las podemos guardar con el nombre “Q 100 m3/s”.Ejemplos sencillos de HecRas Ejemplo 1. 30 . Q 100” y “Interp 20. una vez calculados ambos planes dentro del visor de resultados Profile Plot. Overbanks abajo”.02 15/06/2006 . la nueva geometría la guardamos como “Interp 20. Overbanks abajo”. calado critico abajo y arriba.02 Legend Crit PF 1 WS PF 1 8 Ground Bank Sta Elevation (m) 7 6 5 4 0 2 4 Station (m) 6 8 10 Donde se aprecia la nueva posición de los banks en la parte baja de la sección (puntos rojos). “I20Q100MIX” y “I20Q100OA”. así como su leyenda. como en el caso anterior.

Ejemplos sencillos de HecRas Una vez modificadas adecuadamente las leyendas como nos interese podemos obtener un resultado visual del tipo: Vemos en la imagen como la diferencia en los calados obtenidos para las dos posiciones de los banks llega a algo más de 30 centímetros. por lo tanto el cambio de posición a afectado notablemente al 31 ._____________________________________________Capitulo 6. resultando que uno de ellos está en régimen rápido y el otro en lento.

En las zonas de overbanks o llanuras de inundación hemos encontrado un radio hidráulico pequeño. channel y overbanks. por lo tanto las pérdidas de energía se han calculado de manera independiente en cada una de las zonas.4%. sin embargo el caudal es pequeño. por lo tanto es más correcta la primera. 12 EJEMPLO 3. con sección trapezoidal.Ejemplos sencillos de HecRas resultado. 32 . INFLUENCIA DE LOS COEFICIENTES EXPANSIÓNCONTRACCIÓN: Este ejemplo será muy similar al anterior pero en lugar de comparar dos geometrías con los banks en diferentes posiciones compararemos una geometría con pérdidas por contracción expansión y otra sin ellos. en el centro de la sección el radio hidráulico ha sido mayor._____________________________________________Capitulo 6. Esencialmente reproduciremos las geometrías utilizadas anteriormente. esto hace que en régimen normal los calados sean menores. definiendo las tres zonas de flujo. por lo que las pérdidas han sido menores y el caudal que circula por ellas mayor. pendiente del 0. lo que origina muchas perdidas de energía en esta zona.014. longitud de tramo de 2000 metros. Esto se debe fundamentalmente a que el hecho de haber posicionado los banks en la parte inferior de la sección ha definido las tres zonas de cálculo de la sección. además la interpolación se realizará cada 10 metros en lugar de 20. las diferencias serán que ahora el coeficiente de Manning será de 0. pero no debemos olvidar que la primera geometría (con los banks arriba) estaba más acorde con las hipótesis sobre las que se desarrollo la ecuación de Manning. En conjunto las perdidas globales de energía son menores (a igual calado) con los overbanks situados en la parte baja de sección. esto nos garantizará que el régimen será rápido.

ahora basta con seleccionar cada una de las columnas e introducir el valor que deseemos. es decir calados críticos en los extremos y caudal de 100 m3/s. El siguiente paso consiste en definir las condiciones de contorno. al primero le damos el nombre “Interp 10. Podemos apreciar en el resultado de perfiles. Q 100”. Ahora por lo tanto bastará con crear dos planes para poder calcular cada una de las geometrías con las condiciones de contorno definidas. nombre corto “I10Q100” y al segundo el nombre “Interp 10 Exp-Cont. Este ejemplo resulta ilustrativo de los errores que pueden aparecer cuando se usan estos coeficientes de perdidas en las geometrías inapropiadas. Q 100” y nombre corto “I10Q100C-E”.1/0.Ejemplos sencillos de HecRas Cuando hayamos creado esta geometría la guardamos con el nombre “Interp 10” y ahora modificamos los coeficientes de expansión-contracción. 0. en este caso usaremos los que recomienda HEC-RAS por defecto. Una vez introducidos los nuevos valores para los coeficientes de expansión y contracción guardamos esta geometría como “Interp 10 Exp-Cont”._____________________________________________Capitulo 6. utilizaremos las mismas de los casos anteriores.3. 33 . Exp-Cont” y las condiciones de contorno. Por lo tanto la conclusión es que cuando las geometrías no presentes grandes cambios a lo largo de su desarrollo se hace innecesario utilizar estas pérdidas ya que la propia curva de remanso ya incluye las pérdidas correspondientes al flujo y no deben introducirse otras. y otro con la geometría “Interp 10. como los correspondientes a la geometría con coeficientes de expansión-contracción están distorsionados y son incapaces de reproducir la curva de remanso correspondiente al flujo en la sección prismática. Una vez calculados ambos plans presentamos los resultados de ambos de la manera descrita anteriormente. Para ello creamos un plan con la geometría “Interp 10” y las condiciones de contorno. Para ello dentro del editor de geometría vamos al menú: Tables Contraction and Expansion Coefficients … Se nos abre una ventana en la que aparecen las secciones y los coeficientes utilizados en cada una de ellas. estos nombres siempre deben ser descriptivos porque son los que aparecen en las leyendas de los resultados cuando comparamos.

ANÁLISIS DE SENSIBILIDAD En este ejemplo vamos a ver como tres interpolaciones diferentes dan un resultado similar. esto se debe a que en estas zonas los errores numéricos dependen en gran medida de la distancia de interpolación. Lo que nos queda es deshacer la interpolación de 10 metros e interpolar a 20 metros. guardar la geometría como “Interp 20”. deshacer de nuevo la interpolación y reinterpolar a 40 metros.I10Q100C-E WS PF 1 . los valores de los calados y las velocidades resultan muy parecidos. Abrimos esta geometría desde el editor de geometrías con el menú: File Open Geometry Data Y seleccionamos “Interp 10”. Podemos ver un detalle de la zona de aguas abajo próxima al calado crítico: 34 . Ahora creamos los plans correspondiente utilizando estas geometrías y calculamos los resultados correspondientes a usar las diferentes interpolaciones con las condiciones de contorno anteriores “Q 100 m3/s”. Contracción-Expansión Plan: 1) I10Q100 14/06/2006 2) I10Q100C-E 14/06/2006 Rio Tramo1 12 Legend Crit PF 1 .I10Q100 10 Crit PF 1 .I10Q100 8 Elevation (m) Ground 6 4 2 0 0 500 1000 Main Channel Distance (m) 1500 2000 13 EJEMPLO 4.4%. para ello partiremos de geometría anteriormente utilizada y guardada como “Interp 10”. Al comparar los resultados se aprecia como excepto en las zonas próximas al calado crítico._____________________________________________Capitulo 6. esta última geometría la llamamos “Interp 40”. ahora tenemos cargada la geometría correspondiente a la sección trapezoidal con interpolación cada 10 metros y pendiente de 0.I10Q100C-E WS PF 1 .Ejemplos sencillos de HecRas Ejemplo 1.

I20Q100 WS PF 1 ._____________________________________________Capitulo 6.I10Q100 3 Ground Elevation (m) 2 1 0 0 50 100 150 Main Channel Distance (m) 35 .Ejemplos sencillos de HecRas Ejemplo 1. Análisis de sensibilidad Plan: 1) I20Q100 15/06/2006 2) I40Q100 15/06/2006 3) I10Q100 15/06/2006 Rio Tramo1 Legend 4 WS PF 1 .I40Q100 WS PF 1 .

You're Reading a Free Preview

Descarga
scribd
/*********** DO NOT ALTER ANYTHING BELOW THIS LINE ! ************/ var s_code=s.t();if(s_code)document.write(s_code)//-->