Está en la página 1de 44

Sistemas Operativos UNIDAD 20

Ejercicios

1. Escribir un programa que lea el valor correspondiente a una distancia en millas marinas y las escriba expresadas en metros. Sabiendo que 1 milla marina equivale a 1.852 metros. Ordinograma
INICIO

Pseudocdigo PROGRAMA: Convertidor de millas MDULO: Principal INICIO DATOS VARIABLES N millas = A N real Millas = B N real Resultado = S N real ALGORITMO Leer datos A S=A*B Escribir S END

LEER MILLAS

METROS = m * 1.852

Qbasic 10 CLS 20 PRINT introduzca las millas 30 INPUT A 40 LET B = 1.852 50 LET S = A * B 60 PRINT Los kilmetros son ; S 70 END

ESCRIBIR METROS

FIN

-1-

Sistemas Operativos

Ejercicios

2. Disear el algoritmo ( pseudocodigo y ordinograma ) correspondiente a un programa que escribe el porcentaje descontado en una compra, introduciendo por teclado el precio del articulo y el precio pagado. Ordinograma
INICIO precioar preciopa porc

Pseudocodigo

leer precioar leer preciopa

porc=(preciopa/precioar)*100

escribir porc

PROGRAMA: Porcentaje equivalente MDULO: Principal INICIO DATOS VARIABLES precioar N real preciopa N real porc N real ALGORITMO Leer precioar,precipa porc=(preciopa/precioar)*100 Escribir porc END

FIN

-2-

Sistemas Operativos

Ejercicios

3. Diseo del algoritmo correspondiente a un programa que calcula la potencia de un numero dada la base y el exponente. ORDINOGRAMAS.

Pseudocdigo.

INICIO

A=0

Programa : Potencia Modulo: principal Inicio Datos Variables a nmero real e nmero real b nmero real Algoritmo Inicializar a=0 Leer b,e Si e=1 Escribir B Finsi Si e=0 Escribir 1 Repetir a.=b a=a*b e=e-1 Mientras e=0 Escribir a Fin

LE E R

B ,E

E=1

E=0

A= B

A =A *B

E =E - 1

E=0

F IN

-3-

Sistemas Operativos

Ejercicios

4. Diseo del algoritmo correspondiente a un programa que suma todos aquellos numeros leidos mientras no sean negativos. Ordinograma
IN IC IO

Pseudocodigo

n um ,su m a

sum a = 0 sum a = sum a + nu m lee r n um si no

n um > 0

E sc ribir su m a

PROGRAMA: suma positiva MDULO: Principal INICIO DATOS VARIABLES Num,suma ALGORITMO Leer num Si num>0 Suma=suma+num Si no escribir suma Fin si END

F IN

5. Algoritmo que lee cinco valores numericos y calcula su producto. Ordinograma


INICIO

Pseudocodigo

num,c,producto,V v=5 producto=1 c=1,v,1

leer num producto=producto*num

PROGRAMA: producto de 5 numeros MDULO: Principal INICIO DATOS VARIABLES Num, c V=0 Producto=1 Algoritmo Para c de 1 a v con inc =1 Leer num Producto=producto*num Fin para Escribir producto FIN

escribir producto

FIN

-4-

Sistemas Operativos

Ejercicios

6. Disear el algoritmo ( ordinograma y pseudocodigo ) correspondiente a un programa que calcule el area lateral y el volumen de un cilindro recto, introduciendo por teclado los valores del radio y de la altura. Ordinograma
INICIO Al,V,,r,h =3,1415 leer r leer h V=*r^2*h Al=2**r*h escribir V escribir Al FIN

Pseudocodigo

PROGRAMA: volumen y area lateral del cilindro MDULO: Principal INICIO DATOS VARIABLES R,h =3,1415 ALGORITMO Leer r Leer h V= r^2*h Al=2* *r*h Escribir,V,Al END

7. Escribir un programa ( expresando su algoritmo en notacion pseudocodificada y ordinograma ) que lea equivalente en grados centigrados. Ordinograma
IN IC IO

Pseudocodigo

fa r,C

lee r fa r

C = (fa r-3 2 )*(5 /9)

e s cribir C F IN

PROGRAMA: De Fahrenheit a grados centgrados MODULO: Principal INICIO DATOS VARIABLES Far,C ALGORITMO Leer far C=(far-32)*(5/9) Escribir C FIN

-5-

Sistemas Operativos

Ejercicios

8. Diseo del algoritmo correspondiente a un programa que lee 100 numeros, los procesa y, despues de leer el ultimo, determina si alguno de ellos era multiplo de 3. Ordinograma
INICIO

Pseudocodigo

num ,c,resto,V,x c=100 V=1,c,1 leer num x=num /3 resto=m odx si

resto=0 no

PROGRAMA: Multiplos MODULO: Principal INICIO DATOS VARIABLES Num,c,resto,V C=100 ALGORITMO Para V de 1 a c con inc=1 X=num/3 es m ultiplo Resto=modx Si resto=0 no es m ultiplo Escribir es mltiplo Si no Escribir no es mltiplo Fin si Fin para FIN

FIN

9. Disear el algoritmo de un programa que lea N numeros enteros ( tanto positivos como negativos ) y muestre el maor y el menor de los numeros leidos. Pseudocodigo

PROGRAMA: Muestra mayor y menor de los nmeros introducidos MODULO: Principal INICIO DATOS VARIABLES May, men, n, c Sw=0 ALGORITMO Leer n Sw=0 Si sw=0 May=n,men=n,sw=1 Si no Si n>may -6May=n Si no

Si n<men Men=n Fin si C=c+1 Si c>=100 el mayor es;may el menor es;men si no leen num fin si FIN

Sistemas Operativos

Ejercicios

10. Disear el algoritmo de un programa que escriba la tabla de multiplicar de un numero introducido por teclado. Ordinograma
IN IC I O C ,ta b la ,n u m

Pseudocodigo

C = 0

le e rn u m

ta b la = n u m * c c = c + 1 s i n o e s c rib ir ta b la F IN

PROGRAMA: Tabla de multiplicar MODULO: Principal INICIO DATOS VARIABLES Tabla, num C=0 ALGORITMO Leer num Tabla=num*c C=C+1 Si c <=10 Tabla=num*C Si no Escribir tabla FIN

c < = 1 0

-7-

Sistemas Operativos

Ejercicios

EL RESTO DE ORDINOGRAMAS Y PSEUDOCODIGOS HECHOS EN CLASE ALGORITMO QUE DETERMIA EL MAYOR DE 3 NMEROS METIDOS POR TECLADO.
IN IC IO

LE E R A ,B,C

Pseudocdigo PROGRAMA: Mayor_3_numeros MODULO: Principal INICIO DATOS VARIABLES A N entero B N entero C N entero ALGORITMO Leer A, B,C Si A < B<C Mostrar A < B<C Sino Si A = B Mostrar A = B=C Sino Mostrar A > B>C Fin si Fin si END

A >B

A >C

B >C

A MAYOR

C M A YOR

B M AY OR

FIN

-8-

Sistemas Operativos

Ejercicios

Programa que una vez introducidos los tres lados de un tringulo el programa nos diga si es equiltero, issceles o escaleno.

IN IC IO

Pseudocdigo

LEER A,B,C

A=B

B=C

A=C

EQUILTER O

ISSCE LES

ESC AL EN O

FIN

PROGRAMA: Tipo_tringulo MDULO: Principal INICIO DATOS VARIABLES A N entero B N entero C N entero ALGORITMO Leer A, B, C Si A = B Si A = C Mostrar equiltero Sino Mostrar issceles Fin si Sino Si A = C Mostrar Issceles Sino Si B = C Mostrar issceles Sino Mostrar escaleno Fin si Fin si FIN

-9-

Sistemas Operativos

Ejercicios

Introducidos 5 nmeros cualesquiera por teclado calcular la media aritmtica

Ordinograma

Pseudocdigo PROGRAMA: Media_aritmtica MDULO: Principal INICIO DATOS VARIABLES A N entero X N entero Y N entero Z N entero ALGORITMO Inicializar x = y = 0 Mientras Y 5 Leer A X=X+A Y = Y ++ Mientras Y = 5 S = (X / 5) Mostrar S Fin mientras FIN

I N IC IO

A , B , C, D, E

(A + B + C + D + E ) / 5

F IN

CONVERSOR DE EUROS A PTAS

-10-

Sistemas Operativos Ordinograma


IN IC IO ptas,euros,m

Ejercicios Pseudocodigo

m =166,386

leer euros

ptas=euros*m

PROGRAMA: conversor de euros a ptas. MDULO: Principal INICIO DATOS VARIABLES Ptas,euros M=166,386 Algoritmo Leer euros Ptas=euros*m Escribir ptas FIN

escribir ptas

FIN

Calcular el mayor de 3 numeros introducidos Ordinograma

-11-

Sistemas Operativos
INICIO

Ejercicios

X,Y,Z

leer X,Y,Z

si

Y<X>Z

no

X es el mayor

si

X<Y>Z

no

Y es el mayor

si

X<Z>Y

no

Z es el mayor

son iguales

FIN

Pseudocodigo PROGRAMA: Mayor de tres numeros MDULO: Principal INICIO DATOS VARIABLES Z,X,Y ALGORITMO Leer Z,X,Y Si Y<X>Z X es el mayor Si no Si X<Y>Z Y es el mayor Si no Si X<Z>Y Z es el mayor

Si no Si X<Z>Y Z es el mayor Si no Los tres son iguales Fin si Fin si Fin si FIN

Introducir 2 numeros, si al multiplicarlos el resultado es positivo, introducir otro numero positivo y sumarlo al producto. Si es negativo restar 10 al producto.Si el resultado de la resta es menor de 100, introducir un numero negativo y restarlo al actual producto.

-12-

Sistemas Operativos

Ejercicios

Ordinograma
INICIO

a,b,c,multi

leer a, b

multi=a*b

si leer c

multi>=0

no multi=multi-10 si no

multi=multi+c leer c si

multi<100

c>0

no

escribir multi FIN

Pseudocodigo PROGRAMA: Restar o dejarlo MDULO: Principal INICIO DATOS VARIABLES A,b,c,multi ALGORITMO Leer a,b Multi=a*b Si multi>=0

Leer c
Multi=multi+c Si no Multi=multi-10 Si multi<100 Leer c Si c>0 Leer c Si no Multi=multi-c Si no Multi Fin si Fin si Fin si FIN

1 .- Elaborar un algoritmo el cual calcule e imprima el sueldo de un empleado, teniendo como datos de entrada: nombre, horas trabajadas y cuota por hora. ALGORITMO: 1.- inicio

-13-

Sistemas Operativos

Ejercicios

2.- pedir horas,pedir nombre, pedir horas trabajadas y cuota por hora (N,H,C) 3.- multiplicar el numero de horas trabajadas por la cuota por hora (S=H*C) 4.- mostrar resultados (S) 5.- fin 2) Escribe un algoritmo para obtener el rea de un tringulo, tomando en cuenta que el rea: (base * altura)/2. ALGORITMO: 1.- inicio 2.- pedir la base y la altura (B,H) 3.- multiplicar la base y la altura y dividirlas entre 2 (A=B*H/2) 4.- mostrar resultados (A) 5.- fin 3) Hacer un algoritmo para calcular el promedio de calificaciones de un estudiante. Los datos disponibles son: nombre y las 4 calificaciones de los exmenes. El algoritmo deber imprimir el mensaje de Aprobado si el promedio fue >=7, de lo contrario el mensaje deber ser Reprobado. ALGORITMO: 1.- inicio 2.- pedir nombre (N) 3.-Pedir calificaciones( c1,c2,c3,c4) 4.- sacar promedio prom=(c1+c2+c3+c4)/4 5.- si el promedio es >=7 entonces mostrar como resultados aprobado si el promedio es menor a 7 mostrar como resultado reprobado. 6.- fin 4) Hacer un algoritmo que calcule e imprima el costo de un terreno rectangular, teniendo como datos la anchura y longitud en metros, y el costo del metro cuadrado. ALGORITMO: 0.- inicio 1.-Pedir el costo (C) 2.- pedir el precio del metro cuadrado (Pm2) 3.- pedir el ancho y largo del terreno en metros cuadrados (A,L) 4.- multiplicar el numero de metros cuadrados del terreno por el precio por metro para sacar su costo total (C=Pm2*(A*L)) 5.- mostrar resultados (C).

-14-

Sistemas Operativos 6.- fin

Ejercicios

5) Hacer un algoritmo que convierta un nmero dado de segundos en minutos y que imprima el resultado. ALGORITMO: 1.- inicio 2.- pedir el numero de segundos (ns) 3.- multiplicar el numero de segundos por 60 (M = ns*60) 4.- mostrar resultados 5.- fin 6) Una temperatura en grados centgrados se puede convertit a su equivalencia en Fahrenheit con la formula F=9/5 C + 32. Hacer un algoritmo que lea una temperatura en grados centgrados y obtenga e imprima la temperatura Fahrenheit equivalente. ALGORITMO: 1.- inicio 2.- pedir la temperatura en grados centgrados (C) 3.- multiplicar la temperatura dada por 9/5+32 (F=9/5C+32) 4.- mostrar resultados 5.- fin 7) Hacer un algoritmo que lea un nmero de pies y calcule e imprima su equivalente en yardas, pulgadas, centmetros y metros, de acuerdo con las siguiente equivalencias: 1 pie = 12 pulgadas, 1 yarda = 3 pies, 1 pulgada = 2.54 cm, 1 metro = 100 cm. ALGORITMO: 1.- inicio 2.- pedir el nmero de pies (fT) 3.- dividir los pies entre 12 para sacar la equivalencia en pulgadas (Pulgadas=Ft/12) y guardar el resultado en equivalencias. 4.- multiplicar los pies por 3 para sacar la equivalencia en yardas (Yardas=fT*3) y guardar resultado en equivalencias. 5.-Dividir las pulgadas entre 2.54 para obtener los centmetros (centmetros=fT /2.54) guardar resultado en equivalencias. 6.-Dividir los centmetros entre 100 para sacar la equivalencia en metros (metros=centmetros/100) 7.- mostrar resultados (equivalencias). 8.- fin. 8) Elabore un algoritmo para calcular e imprimir el precio de un terreno el cual tiene los siguientes datos: largo, ancho y precio por metro cuadrado. Si el terreno tiene ms

-15-

Sistemas Operativos

Ejercicios

de 500 metros cuadrados el descuento es del 17% y si tiene mas de 1000 el descuento ser del 25%. ALGORITMO: 1.- inicio 2.- pedir los metros cuadrados de ancho(ma) 3.-Pedir los metros cuadrados de largo(ml) 4.-Multiplicar el largo por el ancho para sacar el total de metros (mt=l *a) 3.- si los metros cuadrados son 500 tendr el 17% de descuento, y si son mas >= 1000 tendr un descuento del 25% del precio total. 4.- mostrar resultados 5.- fin

4. Realizar el anlisis, diagrama de flujo y prueba de escritorio, para los siguientes planteamientos 1.- Determinar en una lista los pasos para ir al cine con el novio o la novia. Anlisis:

-16-

Sistemas Operativos

Ejercicios

Problema: invitar a la novia a cine. Especificaciones de entrada: llamar a la novia, hacer invitacin. Especificaciones de salida: fijar lugar, fijar hora, encuentro en el lugar fijado, compra de boletas, ingreso a la sala de cine.

2.- Realizar un algoritmo donde se indique los pasos para realizar un plato tpico de la regin. Anlisis: Problema: elaboracin de plato tpico mamona Especificaciones de entrada: comprar la novilla. Especificaciones de salida: sacrificio de la novilla, condimentos, yuca, papa, sal, trozos de lea.

-17-

Sistemas Operativos

Ejercicios

-18-

Sistemas Operativos

Ejercicios

3.- Realizar un diagrama que permita esquematizar (dibujo) los pasos para baar un elefante. Problema: como baar un elefante Especificaciones de entrada: un elefante, un lazo, 100 litros de agua, 100 cc de jabn liquido, un cepillo, un balde Especificaciones de salida: mojar el elefante, aplicar jabn, cepillar, enjuagar.

-19-

Sistemas Operativos

Ejercicios

4.- Determinar cual es el cuadrado, de un determinado nmero, primero haga la lista de pasos a utilizar, luego el algoritmo en pseudocdigo y finalmente el diagrama de flujo. Pasos: Inicio Ingrese un nmero: a Lea numero: a Cuadrado = a^2; Escriba el resultado Fin

5.- Elaborar un diagrama de flujo que permita determinar si un nmero es Positivo o Negativo.

-20-

Sistemas Operativos

Ejercicios

6.- Elabore en pseudocdigo y en diagrama de flujo un algoritmo que halle el rea de un triangulo.

7.- Ejercicio de conversin, desarrollar un algoritmo en pseudocdigo y luego un diagrama, que permita ingresar una cantidad en metros y la convierta a Centmetros, Kilmetros, Pies, pulgadas (utilice las sentencias de seleccin). -21-

Sistemas Operativos

Ejercicios

PSEUDOCODIGO 1. algoritmo de conversin de metros a: centmetros, kilometros, pies, pulgadas; 2. var 3. m,km,cm,pies,pulgadas:real 4. inicio 5. escriba(por favor ingrese un numero); 6. lea(m); 7. cm = m*100; 8. escriba(el valor es:,cm); 9. km = m*0.001; 10. escriba(el valor es:,km); 11. pies = m*3.281; 12. escriba(el vlor es:,pies); 13. pulgadas = m*39.37; 14. escriba(el valor es:,pulgadas); 15. imprimir(c,km,pies,pulgadas) 16. fin

8.- Leer una determinada temperatura en grados centgrados y convertirla a Fahrenheit

-22-

Sistemas Operativos PSEUDOCODIGO 1. leer una temperatura en grado centigrados y convertirla en grados fahreheit. 2. var 3. c = (grados centigrados); real 4. inicio 5. ingrese(el valor en grados); 6. lea(c); 7. Fahrenheit = c(9/5)+32; 8. escriba(grados Fahrenheit es:,f); 9. fin

Ejercicios

9.- Elabore un algoritmo en pseudocdigo y un diagrama de flujo que teniendo como datos de entrada el radio y la altura de un cilindro calcule el rea total y el volumen del cilindro.

-23-

Sistemas Operativos

Ejercicios

10.- Elaborar un diagrama de flujo, que permita ingresar 3 valores y los imprima en forma descendente.

-24-

Sistemas Operativos

Ejercicios

-25-

Sistemas Operativos

Ejercicios

5. Analice el siguiente algoritmo en pseudocdigo y discuta con sus compaeros de grupo, porque en este ejercicio se emplearon 3 condicionales?, Existen otras formas de resolverlo? 1. Algoritmo mayor_v1 2. var 3. a,b:entero 4. inicio 5. Escriba(Por Favor entre un nmero); 6. Lea(a); 7. Escriba(por favor entre el segundo nmero); 8. Lea (b); 9. Si (a=b) 10. escriba (los Nmeros son Iguales); 11. fin_si 12. Si (a>b) 13. escriba (El mayor es :, a); 14. fin_si 15. Si (a) 16. escriba(el mayor es :,b); 17. fin_si 18. fin RTA Se emplean 3 condicionales; por que necesitamos saber cual es el mayor y menor de los 2 nmeros enteros, pero que pasa, si al introducir los nmeros son iguales, posiblemente imprimira error; entonces empleamos las tres condiciones, para que el algoritmo no se ambiguo. Forma 2 1. Algoritmo mayor_v1 2. var 3. a,b:entero 4. inicio 5. Escriba(Por Favor entre un nmero); 6. Lea(a); 7. Escriba(por favor entre el segundo nmero); 8. Lea (b); 9. Si (a=b) 10. escriba (los Nmeros son Iguales); 11. sino_si(a>b) 12. escriba (El mayor es :, a); 13. sino_si(a) 14. escriba(el mayor es :,b); 15. fin_si 16. fin 6. Defina estructura de seleccin simple, doble y en cascada y d un ejemplo en pseudocdigo. Seleccin simple La estructura de seleccin simple permite ejecutar una accin o un grupo de acciones slo si se cumple una determinada condicin. As, si la condicin es verdadera se ejecuta la accin acciona; en caso contrario, no se hace nada Por ejemplo, si se desea cambiar el signo de un nmero nicamente en caso que sea negativo, podemos escribir: SI( numero

-26-

Sistemas Operativos

Ejercicios

<0) numero = -1 * numero Si el nmero no es negativo, simplemente esta estructura se pasara por alto y se continuara en la siguiente instruccin despus del SI. Estructura de Seleccin Doble SI - SINO La estructura de seleccin doble permite seleccionar una ruta de dos rutas posibles en base a la verdad o falsedad de una condicin. As, en la Figura 3.2, si la condicin es verdadera, se ejecuta la accin A; en caso contrario, se ejecuta la accin B.

Por ejemplo, la siguiente estructura de seleccin doble determina si una persona es mayor o menor de edad: SI( edad >= 18 ) estado = "Mayor de edad" SINO estado = "Menor de edad" Esto imprime "Mayor de edad" si la persona tiene 18 aos ms e imprime "Menor de edad" si la persona tiene menos de 18 aos. En cualquiera de los casos, despus de efectuar la impresin, se ejecutar la primera instruccin que sigue a la estructura SI...SINO. Estructura de Seleccin Doble en Cascada SI-SINO-SI La estructura de seleccin doble en cascada esta formada por varias estructuras de seleccin doble SI-SINO puestas una a continuacin de otra de forma que a un SI-SINO le sigue otro SI-SINO. En la estructura de seleccin doble en cascada, las condiciones se evalan en orden descendente, pasando de una condicin a otra si la condicin anterior resulta falsa. En el momento que se encuentra una condicin verdadera, se efecta la accin correspondiente a dicha condicin y se corta el resto de la estructura. Si todas las condiciones resultan falsas, se efecta la accin correspondiente al ltimo SINO, que se considera como la accin por defecto.

-27-

Sistemas Operativos

Ejercicios

Diagrama de flujo y el pseudocdigo de la estructura de seleccin doble en cascada.

-28-

Sistemas Operativos

Ejercicios

Ejemplos de seleccin simple: Ejemplo 1: Por ejemplo, si se desea cambiar el signo de un nmero nicamente en caso que sea negativo, podemos escribir: 1. cambio de signo a un numero si es negativo 2. var 3. numero:entero,real 4. inicio 5. introduzca(el numero); 6. lea(n); 7. si(n<0) 8. numero=-1*n; 9. fin Ejemplo 2: Realizar un pseudocdigo, para saber si pase un determinado curso. Pseudocodigo 1. Algoritmo para conocer el estado acadmico 2. var 3. nota: entero, real; 4. inicio 5. ingrese(por favor la nota); 6. lea(nota); 7. si(nota>=3.0) 8. entones(paso el semestre); 9. fin Ejemplos de seleccin doble: EJEMPLO 1 Hallar el salario de los empleados de ventas de la empresa comercial andina: teniendo los siguientes datos, sueldo bsico 500.000, segn las ventas de cadaempleado se le da una comisin, asi: menor de 2.000.000 5%, mayor 10%. PSEUDOCODIGO 1. algoritmo para calcular el salario de un empleado 2. var 3. s,ventas,sueldo basico,0.05,0.1:entero,real 4. inicio 5. introduzca(valorventas); 6. lea(valor) 7. si(ventas<2000000) 8. s=(ventas*0.05)+sueldobasico; 9. sino(ventas*0.1)+sueldobasico; 10. imprima (salarios de empleados) 11. fin Ejemplos de seleccin doble en cascada: SI-SINO-SI. Disee un algoritmo que califique el puntaje obtenido en el lanzamiento de tres dados en base a la cantidad seis obtenidos, de acuerdo a lo siguiente: tres seis, excelente; dos seis, muy bien; un seis, regular; ningn seis, psimo. PSEUDOCODIGO calificacion del puntaje segn el lanzaminento VAR ENTERO:dado1, dado2, dado3 CADENA: calificacion inicio LEER(dado1,dado2,dado3) SI(dado1+dado2+dado3==18) calificacion="Excelente"

-29-

Sistemas Operativos SINO SI(dado1+dado2==12||dado1+dado3==12||dado2+dado3==12) calificacion="Muybin" SINO SI(dado1==6||dado2==6||dado3==6); calificacion="Regular" SINO calificacion="Psimo" IMPRIMIR(calificacion) FIN

Ejercicios

1.- Mostrar su nombre, sexo edad y estado civil, que son ingresados por teclado ALGORITMO datopersonal INICIO CARACTER nombre[30], sexo, Ec Entero edad 1.-LEER nombre, sexo, edad, Ec // Ec = estado civil 2.-MOSTRAR nombre, sexo, edad , Ec FIN 2.- Ingresar por teclado el nombre y la edad de cualquier persona e imprima tanto el nombre como la edad ALGORITMO edad INICIO CARACTER nombre[30]. Entero edad 1.-LEER nombre, edad 2.-MOSTRAR nombre, edad FIN 3.- Ingresar por teclado el nombre y la edad de cualquier persona e imprima, solo si la persona es mayor de edad, el nombre de la persona. ALGORITMO adulto INICIO CARACTER nombre Entero edad 1.- LEER nombre, edad 2.- SI (edad >= 18) ENTONCES a)MOSTRAR nombre FINSI FIN 4.- .- Ingresar por teclado el nombre y la edad de cualquier persona e imprima solo si la persona es mayor de edad, el nombre de la persona, de lo contrario, imprima un mensaje que diga : no puede votar. ALGORITMO votar INICIO Cadena nombre Entero edad 1.-LEER nombre , edad 2.-SI ( edad >= 18) ENTONCES a)MOSTRAR nombre SINO a)MOSTRAR no puede votar FINSI FIN

-30-

Sistemas Operativos

Ejercicios

5.- Ingresar por teclado el nombre, la edad y el sexo de cualquier persona e imprima, solo si la persona es de sexo masculino y mayor de edad, el nombre de la persona. NOTA: suponga que en el campo denominado sexo el numero 1 es masculino o el numero 2 es femenino ALGORITMO sex INICIO Cadena nombre Entero sexo , edad 1.-LEER nombre, sexo, edad 2.-SI (sexo = 1) y (edad>= 18) ENTONCES a)MOSTRAR nombre. FINSI FIN 6.- Ingresar por teclado el nombre, la edad, el sexo (1 o 2) y el estado civil de cualquier persona e imprima solo si la persona es un hombre soltero mayor de edad, el nombre de la persona. NOTA: en el campo de estado civil se graba el numero 1 en vez de soltero, el numero 2 en vez de casado o el numero 3 en vez de otro. ALGORITMO hombsolt INICIO Cadena nombre Entero edad , sexo, ec // ec =estado civil. 1.-LEER nombre, edad, sexo, ec. 2.-SI (sexo = 1) y (ec = 1) y (edad >= 18) ENTONCES a)MOSTRAR nombre FINSI FIN 7.-Lea de un registro el nombre, la edad, el sexo y el estado civil de cualquier persona e imprima, solo si la persona es hombre o mujer menor de edad o es hombre casado de cualquier edad, el nombre de la persona y un mensaje que diga usted no se manda. En los dems casos imprima el nombre de la persona solamente. ALGORITMO mensaje INICIO CARCTER nombre[30] , s, ec // s = sexo, e = edad Entero, e // ec = estado civil 1.-LEER nombre, e, s, ec 2.-SI (s = M) o ((s = F) y (e < 18)) o ((s = M) y ( ec = C)) ENTONCES a)MOSTRAR nombre, usted no se manda SINO a)MOSTRAR nombre. FINSI FIN 8.-Ingrese un numero e imprima el numero y el valor absoluto del mismo. ALGORITMO valorabsoluto INICIO Real , x, VA 1.-LEER x

// {x es el numero}

-31-

Sistemas Operativos 2.-VA abs (x) 3.- MOSTRAR VA

Ejercicios

// VA es el valor absoluto FIN 9.-Ingrese un nmero y calcule e imprima su raz cuadrada. Si el numero es negativo imprima el nmero y un mensaje que diga tiene raz imaginaria ALGORITMO RC INICIO Real ,num, RC 1.-LEER num 2.- SI (num >= 0) ENTONCES a. RC sqrt (num) b. MOSTRAR RC SINO a. MOSTRAR num tiene raz imaginaria FINSI FIN 10.-Ingrese dos nmeros desde el teclado ALGORITMO pos INICIO Real A, B 1.-LEER A, B 2.-SI (A>0) ENTONCES MOSTRAR A FINSI 3.-SI (B>0) ENTONCES MOSTRAR B FINSI FIN 11.-Ingrese dos nmeros desde el teclado positivos ALGORITMO numpos INICIO Real , A, B 1.-LEER A, B 2.-SI (A>0) y (B>0) ENTONCES a)MOSTRAR A, B FINSI FIN 12.-Ingrese dos nmeros desde el teclado uno de ellos es positivo ALGORITMO num INICIO Real A ,B 1.-LEER A, B 2.-SI (A>0) o (B>0) ENTONCES a) MOSTRAR A, B FINSI FIN 13.-Ingrese dos nmeros desde el teclado diferente signo y distintos de cero ALGORITMO signosop INICIO Real A, B e imprima solo los positivos

e imprima ambos nmeros slo si son

e imprima ambos nmeros si por lo menos

e imprima ambos nmeros solo si son de

-32-

Sistemas Operativos 1.-LEER A, B 2.-SI ( AB ) y ( B0 ) ENTONCES a) SI (A<0 ) y (B>0) o (A>0) y (B<0) ENTONCES 1) MOSTRAR A, B FINSI FINSI FIN

Ejercicios

14.-Ingrese dos nmeros desde el teclado. Calcule la suma e imprima los nmeros ledos y la suma. ALGORITMOsum INICIO Real, A, B, S // S, es la suma 1.- LEER A, B 2.- SA + B 3.- MOSTRAR A, B, S FIN 15.- Lea dos nmeros de un mismo registro. Calcule la suma de los nmeros. Imprima los nmeros ledos y slo si suma es negativa. Imprmala tambin ALGORITMOsuma INICIO Real A, B, S // S es la suma 1.- LEER A, B 2.- S A + B 3.- SI ( S < 0 ) ENTONCES a) MOSTRAR A, B, S SINO a) MOSTRAR A, B FINSI FIN 16.- Lea dos nmeros de un mismo registro y calcule el cociente de dividir el primero por el segundo. Imprima el cociente. Si el segundo nmero es cero no ejecute el clculo e imprima un mensaje que diga : la divisin no es posible. ALGORITMO cociente INICIO Real A, B , COC // COC es el cociente 1.-LEER A, B 2.- SI ( B = 0) ENTONCES a. MOSTRAR la divisin no es posible SINO a. COC A / B b. MOSTRAR COC es el cociente FINSI FIN 17.- Leer de un mismo registro el nombre de un empleado, su salario bsico por hora y el nmero de horas trabajadas en el mes. Calcular su salario mensual e imprimir tanto el nombre como su salario mensual ALGORITMO salario INICIO Cadena nombre Real SxH, SM // SxH es salario por hora, SM, salario mensual

-33-

Sistemas Operativos Entero HT 1.- LEER nombre SxH, HT 2.- SM SxH * HT 3.- MOSTRAR nombre, SM FIN

Ejercicios // HT es el nmero de horas trabajadas

18.- Leer un nmero y calcular el 5% del nmero ledo. Obtener tanto el nmero como el porcentaje calculado ALGORITMO porciento INICIO Real Num , PC // PC es el porcentaje 1.- LEER , Num 2.- PC (5/100) * Num 3.- MOSTRAR PC, Num FIN 19.- Leer de un registro el nombre de un empleado, su salario bsico por hora, el nmero de horas trabajadas en el perodo y el porcentaje de retencin en la fuente. Calcular el salario bruto, el valor de la retencin y su salario neto. ALGORITMO retencion INICIO Real SxH, P, R, SB, SN, HT // SxH salario por hora, P porcentaje de retencin, R Retencin, SB Salario bruto, SN salario neto, HT, horas trabajadas. Cadena , nombre 1.- LEER nombre Sxh, HT, P 2.- SB SxH * HT 3.- R(P*SB)/100 4.- SN SB-R 5.- MOSTRAR SB, R, SN, nombre FIN 20.-Para un salario bruto hasta de $1.500, no hay retencin. Para un salario bruto de $1500 a $ 3.000 el porcentaje de retencin es de 5%. Para un salario bruto mayor de $3000 el porcentaje de retencin es 8%. Obtener el nombre del empleado, el salario bruto, el valor de la retencin y el salario neto. Se debe leer el nombre y el salario. ALGORITMO salarioneto INICIO Cadena, nombre Real, SB, SN, Ret // SB salario bruto, SN salario neto, Ret retencin 1.- LEER nombre , SB 2.- SI (SB <= 1500) ENTONCES a) Ret 0 SINO 1) SI ( SB > 3000) ENTONCES a) Ret (8/100) * SB SINO a) Ret (5/100)*SB FINSI FINSI 3.- SN SB - Ret 4.-MOSTRAR nombre, SB, Ret, SN FIN 21.- Leer de un registro el nombre de un empleado , el salario bsico por hora y el

-34-

Sistemas Operativos

Ejercicios

nmero de horas trabajadas durante una semana. Calcular el salario neto, teniendo en cuenta que si el nmero de horas trabajadas durante la semana es mayor de 48, esas horas dems se consideran horas extras y tienen un 35 % de recargo. Imprima el nombre del empleado y el salario neto. ALGORITMO sueldoneto INICIO Real, Sb, Ht, SN, Sextr, Extr // Sb salario por hora, Ht horas trabajadas, Extr hora extra // SN salario neto, Sextr, salario por hora extra CARACTER Nombre[30] constante Tr = 0.35 // Tr tasa de recargo 1.- LEER nombre, Sb, Ht, 2.-SI ( Ht>48) ENTONCES a)ExtrHt-48 b)SextrSb+Sb*Tr c)SN (48*Sb) + (Extr*Sextr) SINO a)SN Sb*Ht FINSI 3.- MOSTRAR nombre, SN FIN 22.-Obtenga los 100 primeros nmeros naturales. ALGORITMO ciennum INICIO Entero, i 1.- PARA i1 HASTA i100 HACER a) MOSTRAR i FINPARA 23.- Obtener los nmeros pares comprendidos entre 1 y 1000 ALGORITMO numpar INICIO Entero i 1.- PARA i2 HASTA i 1000 INC = 2 HACER a) MOSTRAR i FINPARA FIN 24.- Leer de un registro un nmero entero positivo y obtener los mltiplos de 3 comprendidos entre 1 y el nmero ledo. ALGORITMO mult3 INICIO Entero i, N 1.- LEER N 2.- PARA i 1 HASTA i N HACER a) SI ( i MOD 3 = 0 ) ENTONCES 1. MOSTRAR i FINSI FINPARA FIN

-35-

Sistemas Operativos

Ejercicios

25.- Lea los veinte primeros registros de un archivo, cada uno de los cuales contienen un nombre. Imprimir los nombres. ALGORITMO nombre INICIO Entero, i CARACTER nombre[30] 1.- PARA i 1 HASTA i 20 HACER a) LEER nombre b) MOSTRAR nombre FINPARA FIN 26.- Leer varios registros cada uno de ellos, conteniendo un nombre. El nmero de estos registros se encuentra grabado en un registro que precede a los anteriores. Imprimir cada uno de los hombres ledos. ALGORITMO nombres INICIO CARACTER nombre Entero i, N 1.- LEER NReg 2.- PARA i1 HASTA iNReg HACER a) LEER nombre b) MOSTRAR nombre FINPARA FIN 27.- Leer un conjunto de registros cada uno de ellos conteniendo el cdigo y el nombre de cada uno de los estudiantes de la universidad. El ltimo registro del conjunto (registro centinela) contiene el cdigo 9999999 y es utilizado slo para chequear el final de los registros. Imprima cada uno de los cdigos ledos. Lgicamente la informacin del registro centinela no se imprime porque no pertenece a ningn estudiante. ALGORITMO estudiante INICIO Entero cod // cod es el cdigo. CARACTER nombre[30] 1.- LEER cod, nombre 2.- MIENTRAS (cod 9999999) HACER a) MOSTRAR cod , nombre b) LEER cod, nombre FINMIENTRAS FIN 28.-Imprimir cuatro columnas. En la primera columna, los enteros del 1 al 50 . En las otras columnas, la segunda, la tercera y la cuarta potencia de los enteros de la primera columna ALGORITMOpotencia INICIO Entero , i , pot2, pot3, pot4 1.- PARA i 1 HASTA i 50 HACER a)pot2 sqr ( i ) b)pot3 pot2 * i c)pot4 pot2 * pot2 d) MOSTRAR i , pot2, pot3, pot4

-36-

Sistemas Operativos FINPARA FIN 29.- Calcule la suma de los100 primeros nmeros naturales ALGORITMO suma INICIO Entero suma, i 1.- suma 0 2.- PARA i1 HASTA i 100 HACER a) sumasuma + i FINPARA 3.-MOSTRAR suma FIN 30.- Obtener la suma de los nmeros pares comprendidos entre 1 y 100 ALGORITMO sum INICIO Entero i , suma 1.- suma 0 2.-PARA i 2 HASTA i100 INC = 2 HACER a) suma suma + i FINPARA 3.-MOSTRAR suma FIN

Ejercicios

31.- Encuentre la calificacin promedio para un gran nmero, aunque desconocido, de calificaciones de exmenes. Estas vienen grabadas en registros. La calificacin ms alta posible es 10.0 ALGORITMO calificacin INICIO Real calificacin, Promedio, Totcal // Totcal suma de las calificaciones, Entero, n // n es el nmero de calificaciones 1.- Totcal 0 2.- n 0 3.- LEER calificacin 4.- MIENTRAS (calificacion >=0 y calificacin <= 10 ) HACER a) Totcal Totcal + calificacin b) nn + 1 c) LEER calificacin FINMIENTRAS 5.-Promedio Totcal / n 6.-MOSTRAR Promedio FIN 32.-Leer una serie de nmeros. Encontrar el valor absoluto (magnitud) de cada nmero. Imprimir tanto los nmeros como sus valores absolutos. Use centinela 999 ALGORITMO valorabsoluto INICIO Real num, VA, // VA valor absoluto, num nmero 1.-LEER num 2.-MIENTRAS ( num 999) HACER a) VA abs ( num)

{999 es el valor centinela}

-37-

Sistemas Operativos b) MOSTRAR VA es el valor absoluto de num c) LEER num FINMIENTRAS FIN

Ejercicios

33.- Leer una serie de nmeros. Obtener el cuadrado y el cubo de cada nmero e imprimir tanto los nmeros como sus cuadrados y sus cubos. ALGORITMO potencia INICIO Real num, cuadrado, cubo 1.- LEER num 2.- MIENTRAS ( num -999) HACER {-999 valor centinela} a) cuadradosqr ( num ) b) cubocuadrado*num c) MOSTRAR cuadrado, cubo,num d) LEER num FINMIENTRAS FIN 34.- Leer una serie de pares de nmeros y obtener de cada par el nmero mayor. Imprima un mensaje especial si los nmeros son de igual valor. Los numeros son precedidos por la cantidad de registros ALGORITMO mayornum INICIO Real A, B 1.- LEER nreg 2.- PARA i 1HASTA i nreg HACER a) LEER A, B b) SI (A = B) ENTONCES 1) MOSTRAR A, B, son iguales SINO 1) SI ( A>B) ENTONCES a. MOSTRAR A es el mayor SINO a. MOSTRAR B es el mayor FINSI FINSI FINPARA FIN 35.- Leer una serie de grupos de tres nmeros y obtener el nmero mayor y el nmero menor de cada terna. Escriba un mensaje si por lo menos dos de cada tres nmeros son iguales. ALGORITMO ternasmayormenor INICIO Real A, B, C Entero, cant 1.-MOSTRAR "ingrese la cantidad de ternas" 2.-LEER cant 3.-PARA i1 HASTA icant HACER a) LEER A, B, C b)SI (A=B) o (B=C) o (A=C) ENTONCES 1) MOSTRAR "por lo menos 2 de los 3 nmeros son ="

-38-

Sistemas Operativos SINO 1) MENA 2) SI (B<MEN) ENTONCES a) MEN B FINSI 3) SI (C<MEN) ENTONCES a) MEN C FINSI 4) MOSTRAR MEN "es el menor" 5) MAY A 6) SI (B > MAY) ENTONCES a)MAY B FINSI 7) SI (C > MAY) ENTONCES a)MAY C FINSI 8) MOSTRAR MAY "es el mayor" FINSI FINPARA FIN

Ejercicios

36.-Identifique y obtenga el nmero medio de un conjunto de tres nmeros nicos. EL nmero medio es aquel que no es el menor ni el mayor. ALGORITMO numeromedio INICIO Real A, B, C. 1.-MOSTRAR "ingrese tres nmeros distintos" 2.-LEER A, B, C 3.-SI ( A>B) ENTONCES a) SI (A>C) ENTONCES 1)SI (B>C) ENTONCES a)MEDB SINO a) MED C FINSI SINO 1)MEDA FINSI SINO a) SI (B>C)ENTONCES 1)SI (A>C)ENTONCES a)MEDA SINO a)MED C FINSI SINO 1)MEDB FINSI FINSI 4.-MOSTRAR MED "es el nmero medio" FIN 37.- El Dane est interesado en saber el nmero de personas mayores de 18 aos, tanto hombres como mujeres en la ciudad de Medelln . Calcule e imprima el resultado de esta investigacin. Se deben leer registros que contiene cada uno el sexo y el nmero de aos.

-39-

Sistemas Operativos ALGORITMO dane INICIO Entero edad, h, m, sexo 1.-h0 2.-m0 3.-LEER edad , sexo 4.-MIENTRAS (edad 999) a) SI (edad >= 18) y (sexo = 1) ENTONCES 1)hh + 1 SINO 1) SI (edad > = 18) y (sexo = 2) ENTONCES a)mm + 1 FINSI FINSI b) LEER edad, sexo FINMIENTRAS 5.- MOSTRAR h, m FIN

Ejercicios

38.-Una tienda de libros y gneros diversos al menudeo ofrecen un descuento de cortesa del 10% para profesores. Muestre como la computadora puede calcular e imprimir el 10% de 1.00, 1.10, 1.20, etc hasta $25.00. ALGORITMO menudeo INICIO Real , desc //desc es el descuento Entero, i 1.- i 1.00 2.- MIENTRAS (i < = 25.00) HACER a) desc 0.10 * i b) MOSTRAR desc c) i i + 0.10 FINMIENTRAS FIN 39.-Un vendedor desea calcular su comisin total sobre la venta de varios artculos. Al vendedor le corresponde el 5% de su comisin sobre artculos cuyo precio es menor de $100 y el 7.5 % de comisin sobre aquellos artculos cuyo precio es de $100 o ms. Suponga que el vendedor hizo N ventas ALGORITMO comisin INICIO Constantes TC1 = 0,05 TC2 = 0.075 Entero N , i. Real comision ,tcom, venta 1.-men 0 2.-may 0 3.-MOSTRAR " ingrese el nmero de ventas que hizo " 4.- LEER N 5.- i 1 6.-MIENTRAS (i <= N ) HACER a) LEER precio, nart b) SI (precio< 100) ENTONCES 1)venta(nart*precio) 2)comision venta * tc1

-40-

Sistemas Operativos SINO

Ejercicios

1)venta(nart*precio) 2) comision venta * tc2

FINSI c) tcom tcom + comision d) i i + 1 FINMIENTRAS 7.- MOSTRAR tcom FIN 40.-Coldeportes de Antioquia est interesado en promover el bsquetbol y para ello desea conocer personas que tengan las siguientes caractersticas, edad mxima: 18 aos, estatura mnima: 1.80 metros, peso mximo: 80 kilos. Lea identificacin. Edad , estatura y peso. Use centinela identificacion 99999 ALGORITMO basquet INICIO Entero identificacin, edad Real, estatura, peso 1.- LEER identificacin, edad, estatura, peso 2.- MIENTRAS (identificacin 99999) HACER a) SI (edad <= 18) y (estatura >=1.80 ) y (peso<=80) ENTONCES 1) MOSTRAR identificacin, edad, estatura , peso FINSI b) LEER, identificacin, edad, estatura, peso FINMIENTRAS FIN 41.-Lea de un mismo registro A, B, C (coeficientes de la ecuacin cuadrtica. Calcule e imprima x1 y x2 (races de la ecuacin ) Recuerde que x1 y x2 se pueden calcular slo s a) B2 - 4. AC >= O b) A 0. ALGORITMO ecuacin INICIO Real, x1, x2 , A, B, C 1.-LEER A, B, C 2.-SI ( A 0 ) ENTONCES a) Disc sqr (B) 4*A*C b) SI (Disc >= 0) ENTONCES 1) X1 ( - B + sqrt(Disc) ) / (2*A) 2)X2( - B - sqrt(Disc) ) / (2*A) 3) MOSTRAR x1, x2 SINO MOSTRAR Tiene raices imaginarias FINSI FINSI FIN 42.-Se tienen registro con los datos de los estudiantes de una universidad, as: cdigo del estudiante, nombre del estudiante. Valor crdito del estudiante, nmero de crditos tomados, valor del recargo en la matrcula. Se requiere leer los registros e imprimir un listado con la siguiente informacin por estudiante: cdigo, nombre del estudiante, valor crdito, nmero de crditos, valor del recargo, valor total pagado por estudiante. Tambin se debe calcular e imprimir al final del listado el total pagado por todos los estudiantes y el promedio por estudiante. Use codigo de centinela = 9999

-41-

Sistemas Operativos

Ejercicios

ALGORITMO pago INICIO Entero, cdigo, n, ct // n, nmero de estudiantes, ct crditos tomados Real, vc, rec, totpag, p // vc valor crdito, ,rec valor de recargo, totpag total pagado CARCTER nombre[30] 1.- n0 2.- totpag0 3.- LEER cdigo, nombre, vc, ct, rec 4.- MIENTRAS ( cod 9999) HACER a) PE( vc* ct) + rec b) nn + 1 c) totpag totpag + PE d) MOSTRAR cod, nombre, vc, ct, rec, PE e) LEER cod, nombre, vc, ct, rec FINMIENTRAS 5.-Ptotpag / n 6.-MOSTRAR p,es el promedio FIN 43.-Se tiene un conjunto de registros de los empleados de una compaa, cada registro contiene los siguientes datos: nmero del empleado, nombre del empleado, salario bsico por hora, horas trabajadas en el mes, deducciones, Se requiere leer los registros e imprimir un listado con la siguiente informacin por empleado : nmero del empleado , nombre del empleado, salario bsico por hora, horas trabajadas, deducciones, salario mensual. Tambin se debe calcular e imprimir al final del listado, el total de salarios pagados a todos los empleados y el promedio salarial por empleado. ALGORITMO compaa INICIO Entero, num, i // num, nmero del empleado, nov, nombre, sh salario por hora, // ht, horas trabajadas,d, deducciones i, nmero de empleados, tot, // Total pagado, SM, salario mensual, P, promedio salarial//, Real, sh, ht, d, tot sm , p CARCTER nomb [30] 1.- i 0 2.- tot0 3.- LEER num, nomb, sh, ht, d 4.- MIENTRAS ( num 9999) HACER a) ii + 1 b) sm (sh * ht) d c) tot tot + sm d) MOSTRAR num, nomb, sh, ht, d, sm e) LEER num, nomb, sh, ht, d FINMIENTRAS 5.- MOSTRAR tot 6.- itot/ i 7.- MOSTRAR P es el promedio salarial por empleado FIN

44.-Calcular e imprimir los salarios que se adeudan a trabajadores, basados en tasa a

-42-

Sistemas Operativos

Ejercicios

1.5 veces la tasa regular, cuando Las horas trabajadas excedan de 40 por semana ALGORITMO salarios INICIO Real, ht, d, ext ,td // ht, horas trabajadas, d deuda, sh salario bsico por hora, extr, // horas extras, TD total de la deuda 1.-LEER ht, sh 2.- MIENTRAS ( ht 0 ) HACER a) SI ( ht > 40) ENTONCES 1) Extr ht 40 2) D 1.5 * extr * sh 3) MOSTRAR D 4) TD TD + D FINSI b) LEER ht. Sh FINMIENTRAS 3. MOSTRAR TD FIN 45.- Dado que un peso de maana tiene menor valor que un peso de hoy (fenmeno econmico que llamamos inflacin) las empresas cuando calculan los futuros ingresos transformados a pesos de hoy superan el monto de la inversin hecha. La frmula general para el clculo del valor actual es : VA = C / (1 + i) N donde: C es la cantidad del ingreso i es la tasa de inflacin N son los aos en consideracin Una empresa tiene informacin sobre la tasa de inflacin, la inversin y los ingresos calculados para diez aos seguidos. Con sta desea saber si al cabo de dicho tiempo ha recuperado la inversin, hablando en pesos del da en que se hace la misma ALGORITMO inflacin INICIO Entero, N Real, VA,. C, inv, i, den 1.-LEER i , inv , C, N 2.- denexp( N * ln (1+i)) 3.- VA C / den 4.- SI ( VA > inv ) ENTONCES a) MOSTRAR recupera inversin SINO a) MOSTRAR no recupera la inversin FINSI 5.- MOSTRAR VA FIN Un empleado trabaja 48 horas en la semana a razn de $5.000 hora. El porcentaje de retencin en la fuente es del 12.5% del salario bruto. Se desea saber cul es el salario bruto, valor de la retencin en la fuente y el salario neto del trabajador.

INICIO HORASTRAB = 48 VALHORA = 5000 PORTEFTE = 12.5

-43-

Sistemas Operativos

Ejercicios

SalBruto, ReteFuente, SalNeto: Real SalBruto = HORASTRAB * VALHORA * 4 ReteFuente = SalBruto * 12.5 / 100 SalNeto = SalBruto -ReteFuente ESCRIBIR: Salario Bruto = , SalBruto, Valor de Retencin en la fuente= , Retefuente, Salario Neto = ,SalNeto FIN

-44-