Está en la página 1de 6

Actualizar PHP en paquete Xampp

La ultima version de Xampp viene con PHP 5.3.1 y la ultima version es la 5.3.2. Para que quiero actualizar PHP? Para los programas que escribo no hay problema en usar una version u otra, pero sin embargo el programa MediaWiki no es compatible con esta version y si la detecta se niega a ejecutar.

[1]

Asi que para ejecutar MediaWiki hay que actualizar PHP, primero descargas la

version thread safe desde la pagina oficial http://windows.php.net/download/ [2]

[3]

Descargas la version Zip. Ahora debes detener el servicio de apache, ejecutando en un cmd como administrador net stop apache2.2

[4]

Ahora anda a C:\Xampp y la carpeta php renombrala a php_old u otro nombre, luego crea una carpeta llamada php. Esto es para respaldar la instalacion actual y ademas debes copiar un archivo desde esta carpeta a la carpeta nueva, al terminar el proceso puedes eliminarla si quieres.

[5]

En la nueva carpeta php copia los archivos de la ultima version de php que descargaste

[6]

Luego de la carpeta php_old copia el archivo php.ini a la carpeta php, luego abrelo. Busca esta seccion y la linea seleccionada

[7]

Cambialo por esto, lo que esta seleccionado

[8]

1. http://www.alexisabarca.com/wp-content/uploads/2010/03/image11.png 2. http://windows.php.net/download/ 3. http://www.alexisabarca.com/wp-content/uploads/2010/03/image12.png 4. http://www.alexisabarca.com/wp-content/uploads/2010/03/image13.png 5. http://www.alexisabarca.com/wp-content/uploads/2010/03/image14.png 6. http://www.alexisabarca.com/wp-content/uploads/2010/03/image15.png 7. http://www.alexisabarca.com/wp-content/uploads/2010/03/image16.png 8. http://www.alexisabarca.com/wp-content/uploads/2010/03/image17.png