Está en la página 1de 28

Unid ad 12.

Los infor mes (I)

Búsqueda
ISO-8859-1 GALT:#008000;G es

pub-1875034419

1

ISO-8859-1

Los informes sirven para presentar los datos de una tabla o consulta generalmente para imprimirlos. La diferencia básica con los formularios es que los datos que aparecen en el informe sólo se pueden visualizar o imprimir (no se pueden modificar) y en los informes se puede agrupar más facilmente la información y sacar totales por grupos. En esta unidad veremos cómo crear un informe utilizando el asistente y cómo cambiar su diseño una vez creado.

Introducción.
Para crear un informe podemos utilizar a sección Informess que encontrarás en la pestaña Crear:

Diseño de informe abre un informe en blanco en la vista diseño y tenemos que ir incorporando los distintos objetos que queremos aparezcan en él. Este método no se suele utilizar ya que en la mayoría de los casos es más cómodo y rápido crear un autoinforme o utilizar el asistente y después sobre el informe creado modificar el diseño para ajustar el informe a nuestras necesidades. En esta unidad veremos más adelante cómo modificar el diseño de un informe. Asistente para informes utiliza un asistente que nos va guiando paso por paso en la creación del informe. Informe consiste en crear automáticamente un nuevo informe que contiene todos los datos de la tabla o consulta seleccionada en el Panel de Exploración. Informe en blanco abre un informe en blanco en vista Presentación. Explicaremos a continuación la forma de crear un informe utilizando el asistente.

El asistente para informes.
Para arrancar el asistente para informes haz clic en el botón Asistente para informes que puedes ver en la imagen anterior.

Aparece la primera ventana del asistente:

En esta ventana nos pide introducir los campos a incluir en el informe. Primero seleccionamos la tabla o consulta de donde cogerá los datos del cuadro Tablas/Consultas este será el origen del informe. Si queremos sacar datos de varias tablas lo mejor será crear una consulta para obtener esos datos y luego elegir como origen del informe esa consulta. A continuación seleccionamos los campos haciendo clic sobre el campo para seleccionarlo y clic sobre el botón o simplemente doble clic sobre el campo. y el campo se quita de la lista

Si nos hemos equivocado de campo pulsamos el botón de campos seleccionados.

Podemos seleccionar todos los campos a la vez haciendo clic sobre el botón deseleccionar todos los campos a la vez haciendo clic sobre el botón .

o

A continuación pulsamos el boton Siguiente> y aparece la ventana que puedes ver en la siguiente página...

Unid ad 12.

Búsqueda
ISO-8859-1 GALT:#008000;G es

pub-1875034419

1

ISO-8859-1

hacer clic sobre el campo por el cual queremos agrupar y hacer clic sobre el botón sobre el campo). (o directamente hacer doble clic En la parte de la derecha aparece un dibujo que nos indica la estructura que tendrá nuestro informe. en la zona central aparecen los campos que se visualizarán para cada registro. hacer clic sobre la cabecera correspondiente al grupo para seleccionarlo y pulsar el botón . Podemos agrupar los registros que aparecen en el informe por varios conceptos y para cada concepto añadir una cabecera y pie de grupo. Si queremos cambiar el orden de los grupos definidos utilizamos los botones . en el pie de grupo normalmente se visualizarán totales de ese grupo. en nuestro ejemplo. Para añadir un nivel de agrupamiento. la . encima aparece un grupo por población. en la lista de la izquierda.Los infor mes (II) El asistente para informes (cont). En esta pantalla elegimos los niveles de agrupamiento dentro del informe. y encima un grupo por código postal. Para quitar un nivel de agrupamiento.

Unid ad 12. Una vez tenemos los niveles de agrupamiento definidos hacemos clic en el botón Siguiente> y pasamos a la siguiente ventana que verás en la siguiente página. desplegando el cuadro podemos indicar que utilice para agrupar el valor completo contenido en el campo o que utilice la primera letra. las dos primeras. Haciendo clic en ese botón aparecerá el siguiente cuadro de diálogo: En este cuadro aparecen los distintos grupos que tenemos definidos.. Con el botón podemos refinar el agrupamiento. y por cada grupo tenemos el campo que define el grupo en Campos de grupo: y el cuadro Intervalos de agrupamiento:. la flecha hacia abajo baja el grupo un nivel..flecha hacia arriba sube el grupo seleccionado un nivel. Los infor mes (III) Búsqueda ISO-8859-1 GALT:#008000. etc.. Después de pulsar el botón Aceptar volvemos a la ventana anterior..G es pub-1875034419 1 ISO-8859-1 El asistente para informes (cont). .

para elegir una ordenación descendente hacer clic sobre el botón Ascendente y pasará a ser Descendente. Para seguir con el asistente hacemos clic sobre el botón Siguiente> y aparece la siguiente ventana: . Podemos elegir un tipo de ordenación diferente en los distintos campos de ordenación. Seleccionamos el campo por el que queremos ordenar los registros que saldrán en el informe. y elegimos si queremos una ordenación ascendente o descendente.En esta pantalla podemos elegir ordenar los registros por hasta cuatro campos de ordenación.

Unid ad 12. .En esta pantalla elegimos la distribución de los datos dentro del informe. Seleccionando una distribución aparece en el dibujo de la izquierda el aspecto que tendrá el informe con esa distribución. A continuación pulsamos el botón Siguiente> y aparece la ventana que podremos ver en la siguiente página. Con la opción Ajustar el ancho del campo de forma que quepan todos los campos en una página. Los infor mes (IV) Búsqueda ISO-8859-1 GALT:#008000. En el cuadro Orientación podemos elegir entre impresión Vertical u Horizontal (apaisado). se supone que el asistente generará los campos tal como lo dice la opción.G es pub-1875034419 1 ISO-8859-1 El asistente para informes (cont)...

podemos elegir entre los estilos que tiene definidos Access.En esta pantalla elegimos el estilo que queremos dar al informe. Una vez seleccionado el estilo que nos interesa pulsamos el botón Siguiente y aparece la última pantalla del asistente para informes: . Seleccionando un estilo aparece en el dibujo de la izquierda el aspecto que tendrá el informe con ese estilo.

Para practicar esas operaciones puedes realizar el Ejercicio paso a paso crear un informe con el asistente. Si quieres seguir con la unidad. si seleccionamos esta opción aparecerá la ventana Diseño de informe donde podremos modificar el aspecto del informe. pasa a la página siguiente. Ejercicio paso a paso.. Crear informes con el asistente Objetivo. Antes de pulsar el botón Finalizar podemos elegir entre: Vista previa del informe en este caso veremos el resultado del informe preparado para la impresión o bien Modificar el diseño del informe.. Saber crear informes con el asistente. este título también será el nombre asignado al informe. .En esta ventana el asistente nos pregunta el título del informe.

. 3 Haz clic sobre el botón para añadir todos los campos al informe. 19 Haz clic sobre el botón Siguiente. 15 Elige el campo Apellidos alumnado. Volvemos a la ventana del asistente. 4 Haz clic sobre el botón Siguiente para ir al siguiente paso del asistente.Abrir la base de datos Clases. 7 Haz clic en el campo fecha nacimiento para seleccionar el campo.accdb que se encuentra en la carpeta Mis ejercicios. 20 Elige la opción que más te guste como estilo del informe. 10 Despliega el cuadro Intervalos de agrupamiento del campo fecha nacimiento. 21 Haz clic sobre el botón Siguiente. 16 Haz clic sobre el botón Siguiente. 5 Haz clic sobre el campo Curso del informe para seleccionarlo. 17 Deja activada la opción En pasos como distribución del informe. 13 Haz clic sobre el botón Siguiente. 11 Elige la opción Año. 2 En la primera pantalla del asistente elige en el cuadro Tabla/consulta la tabla Alumnado. 8 Haz clic sobre el botón para agrupar por fecha de nacimiento. vamos a cambiar esa opción y vamos a definir una agrupación por año de nacimiento: 9 Haz clic sobre el botón . Ahora vamos a hacer que los alumnos del mismo año aparezcan ordenados por apellidos: 14 Despliega el cuadro 1 correspondiente al primer campo de ordenación. 12 Haz clic sobre el botón Aceptar. Vamos a crear primero un informe para la visualización de los datos de la tabla Alumnado. 18 Marca la opción para poner el informe en Vertical y que quepan los controles. para ello utilizaremos el asistente para informes: 1 Haz clic en el botón Asistente para informes en la pestaña Crear. Como hemos elegido un campo de tipo Fecha/Hora el asistente agrupa por mes. 6 Haz clic sobre el botón para quitar el campo.

24 Cierra el informe guardando los cambios. en ella le indicamos a Access cómo debe presentar los datos del origen del informe. Los infor mes (V) Búsqueda ISO-8859-1 GALT:#008000. para ello nos servimos de los controles que veremos más adelante de la misma forma que definimos un formulario. Para entrar en la vista diseño debemos posicionarnos en la ventana Base de datos con el informe seleccionado y a continuación hacemos clic en el botón Nos aparece la ventana diseño: . Unid ad 12.22 Escribe como título listado de alumnos. 23 Haz clic sobre el botón Finalizar.G es pub-1875034419 1 ISO-8859-1 La vista diseño de informe La vista diseño es la que nos permite definir el informe. .

La sección Encabezado de página.El área de diseño consta normalmente de cinco secciones: La sección Encabezado del informe. La sección Detalle. Aunque se visualicen varios registros en una página. en ella ponemos lo que queremos aparezca al final del informe. en ella ponemos lo que queremos aparezca al final de cada página. en ella ponemos lo que queremos que aparezca al principio de cada página. Podemos eliminar los encabezados y pies con las opciones encabezado o pie de página y encabezado o pie de página del informe que encontrarás en la pestaña Organizar: . La sección Pie de informe. o varios registros o uno sólo por página según el tipo de informe. en ella aparecerán los registros del origen del informe. La sección Pie de página. debemos indicar en la sección Detalle el diseño correspondiente a un sólo registro. en ella ponemos lo que queremos que aparezca al principio del informe.

en la imagen anterior puedes ver estas opciones.Si quitamos las secciones perderemos todos los controles definidos en ellas. Para ver u ocultar las reglas o la cuadrícula tenemos en la sección Mostrar u ocultar las opciones Regla y Cuadrícula respectivamente. también disponemos de una cuadrícula que nos ayuda a colocar los controles dentro del área de diseño. sólo tenemos que volver a seleccionar la opción. Unid ad 12. Alrededor del área de diseño tenemos las reglas que nos permiten medir las distancias y los controles.G es pub-1875034419 1 ISO-8859-1 La pestaña Diseño de informe . Para abrirlas. Los infor mes (VI) Búsqueda ISO-8859-1 GALT:#008000.

Con el botón hacemos aparecer y desaparecer el cuadro Propiedades del control seleccionado. se accede a esa página de código haciendo clic sobre el botón . El primer botón nos permite pasar de una vista a otra. la Vista Presentación que muestra un hibrido entre la vista Informes y Diseño y finalemente la Vista Informes que muestra el informe en pantalla. Las propiedades del informe son parecidas a las de un formulario. . El botón permite modificar los niveles de agrupamiento como veremos más adelante. Recuerda que siempre podemos acceder a la ayuda de Access haciendo clic en el botón . si lo desplegamos podemos elegir entre Vista Diseño la que estamos describiendo ahora.Si has entrado en diseño de informe podrás ver la pestaña de Diseño que muestra las siguientes opciones: Esta barra la recuerdas seguro. es muy parecida a la que estudiamos en los formularios. La Vista Preliminar nos permite ver cómo quedará la impresión antes de mandar el informe a impresora. A continuación describiremos los distintos botones que pertenecen a esta barra. Haciendo clic en el botón Agregar campos existentes harás aparecer y desaparecer el cuadro lista de campos en el que aparecen todos los campos del origen de datos para que sea más cómodo añadirlos en el área de diseño como veremos más adelante. Todo informe tiene asociada una página de código en la que podemos programar ciertas acciones utilizando el lenguaje VBA (Visual Basic para Aplicaciones).

Unid ad 12. se suele utilizar para presentar un campo de tipo Sí/No. Se suele utilizar más en formularios.Si quieres seguir con la unidad. Los infor mes (VII) Búsqueda ISO-8859-1 GALT:#008000. si el campo contiene el valor Sí. el botón aparecerá presionado. Botón de alternar . . El cuadro incluye los siguientes tipos de controles: Etiqueta sirve para visualizar un texto fijo. En la pestaña Diseño encontrarás los mismo controles que vimos en el tema anterior: Cuando queremos crear varios controles del mismo tipo podemos bloquear el control haciendo doble clic sobre él (aparecerá rodeado de una línea más oscura). para más detalle repasar la unidad de formularios. Grupo de opciones Se utiliza para presentar un conjunto limitado de alternativas. pasa a la página siguiente. se pueden utilizar los mismos controles que en los formularios aunque algunos son más apropiados para formularios como por ejemplo los botones de comando. texto que escribiremos directamente dentro del control o en su propiedad Título. a partir de ese momento se podrán crear todos los controles que queramos de este tipo sin necesidad de hacer clic sobre el botón correspondiente cada vez. Para insertar un hipervínculo tenemos el botón . Para quitar el bloqueo hacemos clic sobre el botón .G es pub-1875034419 1 ISO-8859-1 La sección Controles y campos Para definir qué información debe aparecer en el informe y con qué formato.

cómo ajustar el tamaño o la alineación de varios controles. el botón tendrá este aspecto . sino. sino. Control imagen cambiar de registro. Si el . Una combinación informe/subinforme se llama a menudo informe jerárquico. se suele utilizar para presentar un campo de tipo Sí/No. cómo moverlo de sitio. repasa la . cambiar su tamaño. para más detalle para insertar imágenes en el informe. para insertar una imagen u otro objeto que cambia de Salto de página . este otro . Rectángulo Por último podemos añadir más controles. Funciona de forma idéntica a los subformularios que vimos en el tema anterior. y el informe dentro del informe se denomina subinforme. También podemos agregar un subinforme . Botón de comando y Control pestaña repasar la unidad de formularios. un gráfico. más complejos con el botón Puesto que el manejo de los controles en informes es idéntico al de los controles de un formulario. . este otro .Botón de opción . informe principal/detalle o informe principal/secundario. campo contiene el valor Sí. esta imagen no variará al Marco de objeto independiente para insertar controles como un documento Word. Si el campo contiene el valor Sí. En la propiedad Origen del control tenemos el nombre del campo de la tabla al que está asociado (cuando es un dependiente) o una fórmula de cálculo cuando queremos que nos presente el resultado de ese cálculo. El informe primario se denomina informe principal. por ejemplo para presentar los resultados de un cálculo. Serán controles que no variarán al cambiar de registro. Grupo de opciones . la casilla tendrá este aspecto Cuadro de texto se utiliza mayoritariamente para presentar un dato almacenado en un campo del origen del informe. etc. Casilla de verificación . Cuadro combinado . Este tipo de cuadro de texto se llama un cuadro de texto dependiente porque depende de los datos de un campo. Los cuadros de texto también pueden ser independientes. Cuadro de lista . . Se suelen utilizar más en formularios.. copiarlo. en este último caso hay que preceder la fórmula por el signo de igualdad =. Marco de objeto dependiente un registro a otro. se suele utilizar para presentar un campo de tipo Sí/No. si tienes alguna duda sobre cómo añadir un control. para añadir un rectángulo al informe. el salto de página produce un cambio de página aunque no se haya llegado al final de la página.. Línea para añadir una línea en el informe. Un subinforme es un informe que se inserta en otro.

Imprimir directamente Hacer clic sobre el nombre del informe que queremos imprimir en el Panel de Exploración para seleccionarlo. Abrir el cuadro de diálogo Imprimir Hacer clic sobre el nombre del informe que queremos imprimir para seleccionarlo. es conveniente comprobar las opciones definidas en ese momento. para ello tenemos que abrir el cuadro de diálogo Imprimir. Y seleccionando la opción Imprimir del Botón de Office. Despliega el Botón de Office y colcoca el ratón sobre la flecha que aparece junto al comando Imprimir. lo podemos hacer de varias formas y desde distintos puntos dentro de Access. Se abrirá el cuadro de diálogo Imprimir en el que podrás cambiar algunos parámetros de impresión como te explicaremos a continuación: . Antes de mandar la primera impresión del documento.unidad anterior Unid ad 12.G es pub-1875034419 1 ISO-8859-1 Imprimir un informe Para imprimir un informe. en el desplegable que se abrirá selecciona Impresión Rápida. Los infor mes (VIII) Búsqueda ISO-8859-1 GALT:#008000.

podemos especificar el número de copias a imprimir. mientras que si activamos Intercalar imprime todas las copias de cada página juntas.Si tenemos varias impresoras conectadas al ordenador. Con el botón Propiedades accedemos a la ventana de propiedades de la impresora. Si queremos imprimir unas páginas.. En el recuadro Copias. podemos configurar la página.. etc.. en alta calidad o en borrador. suele ocurrir cuando están instaladas en red... podemos especificar si queremos imprimir Todo el informe o bien sólo algunas páginas. Con el botón Configurar. impresión a varias columnas. Si tenemos registros seleccionados cuando abrimos el cuadro de diálogo. el tipo de papel que utilizamos. La opción Imprimir en archivo permite enviar el resultado de la impresión a un archivo del disco en vez de mandarlo a la impresora. . podremos activar la opción Registros seleccionados para imprimir únicamente esos registros. Por último pulsamos el botón Aceptar y se inicia la impresión. imprime una copia entera y después otra copia. desplegando el cuadro combinado Nombre: podemos elegir la impresora a la que queremos enviar la impresión. en el recuadro desde especificar la página inicial del intervalo a imprimir y en el recuadro hasta especificar la página final.. cambiar los márgenes. En el recuadro Intervalo de impresión. esta ventana cambiará según el modelo de nuestra impresora pero nos permite definir el tipo de impresión por ejemplo en negro o en color. etc. Si cerramos la ventana sin aceptar no se imprime nada. Si la opción Intercalar no está activada.

colocar el ratón en la flecha al lado del comando Imprimir y seleccionar Vista previa en el menú desplegable. También puedes hacer clic derecho sobre el Informe en el Panel de Exploración y seleccionar la opción en el menú contextual. Unid ad 12. Los infor mes (IX) Búsqueda ISO-8859-1 GALT:#008000. O si aparece. desplegar el Botón de Office . Para abrir la vista previa tienes dos opciones: Con el objeto Informe seleccionado. elegir directamente Vista previa en el cuadro de Vistas.G es pub-1875034419 1 ISO-8859-1 La ventana Vista previa .Abrir el informe en vista previa Para comprobar que la impresión va a salir bien es conveniente abrir una vista previa del informe en pantalla para luego si nos parece bien mandar la impresión definitiva.

a la página siguiente o a la última página. Para pasar por las distintas páginas tenemos en la parte inferior izquierda una barra de desplazamiento por los registros con los botones que ya conocemos para ir a la primera página. En la parte superior tenemos una nueva y única pestaña (la pestaña Vista preliminar) con iconos que nos ayudarán a ejecutar algunas acciones: El botón pantalla. a la página anterior.En esta ventana vemos el informe tal como saldrá en la impresora. reduce el tamaño del informe para poder ver dos páginas en una sola . a una página concreta.

y en el menú contextual. envía el informe a un documento Word. 3 Despliega el Botón de Office y elegimos la opción Imprimir. Abrir la base de datos Clases. desplegando el cuadro también enviarlo a una hoja de cálculo Excel por ejemplo. podemos elegir Utiliza la opción PDF o XPS para guardar una copia del informe en formato PDF o XPS.accdb que se encuentra en la carpeta Mis ejercicios. Ahora vamos a cambiar opciones de impresión. 3 Selecciona la opción 4 Prueba los botones . . Ejercicio paso a paso. 2 Haz clic derecho sobre el informe Listado de alumno. 2 Haz clic derecho sobre el informe Listado de alumno. Cerrar Vista Previa cierra la vista preliminar sin enviar el informe a impresora.permite visualizar hasta seis páginas en la misma pantalla. Para practicar estas operaciones puedes realizar el Ejercicio paso a paso impresión de informes. Saber imprimir informes y manejar las opciones de la ventana vista preliminar. Vamos a visualizar el resultado del informe que creamos en el ejercicio anterior. se abrirá el cuadro de diálogo Imprimir. que tienes en la pestaña Vista preliminar. 5 Haz clic sobre el botón Aceptar... 1 Posiciónate en el Panel de Exploración. 1 Posiciónate en el Panel de Exploración. 4 Cambia el número de copias. Imprimir informes Objetivo. 5 Haz clic sobre el botón Cerrar.

Para practicar estas operaciones puedes realizar el Ejercicio paso a paso crear informes con grupos. Del mismo modo. en un informe se pueden definir niveles de agrupamiento lo que permite agrupar los registros del informe y sacar por cada grupo una cabecera especial o una línea de totales. Informes con grupos . haciendo clic en Agregar un orden establaceremos un orden dentro de ese grupo. Utiliza las flechas desplegables para seleccionar diferentes modos de ordenación dentro de un grupo. Con las flechas puedes mover las agrupaciones arriba y abajo. Los infor mes (X) Búsqueda ISO-8859-1 GALT:#008000.G es pub-1875034419 1 ISO-8859-1 Agrupar y ordenar Cuando ya hemos visto con el asistente. también podemos definir una determinada ordenación para los registros que aparecerán en el informe. Se abrirá la sección Agrupación. orden y total que te mostramos a continuación: Puedes añadir un grupo de ordenación haciendo clic en Agregar un grupo. Puedes hacer clic en el vínculo Más para ver más opciones de ordenación y agrupación. Para definir la ordenación de los registros. crear un nuevo nivel de agrupamiento o modificar los niveles que ya tenemos definidos en un informe que ya tenemos definido.Unid ad 12. Ejercicio paso a paso. lo abrimos en Vista Diseño y hacemos clic sobre el botón de la pestaña Diseño.

Vamos a partir del informe creado en el primer ejercicio de esta unidad para después cambiarlo desde la ventana Diseño de informes. y elige la opción Guardar como. 7 Mira como aparece un grupo con el campo Fecha nacimiento. Ahora vamos a añadir una línea de totales por población. 1 Haz clic derecho en el informe listado de alumnos en el Panel de Exploración. vamos a agrupar los alumnos por población. Practicar el diseño de informes con niveles de agrupación. 8 Despliega la lista del nombre y cambia Fecha nacimiento por el campo Poblacion. 15 Haz clic en el vínculo Más y selecciona la opción con una sección de pie en el deplegable correspondiente. 14 Haz clic sobre el botón de la pestaña Diseño. 9 Borra el contenido de la caja de texto del encabezado y escribe Poblacion. 6 Haz clic sobre el botón de la pestaña de Diseño. 12 Cierra la vista preliminar haciendo clic en el botón Cerrar. Ahora vamos a cambiar la agrupación. Fijate que el Encabezado Fecha nacimiento ha cambiado a Encabezado Población. 11 Haz clic sobre la opción Vista preliminar en el Botón de Office → Imprimir para ver el resultado. 5 Haz clic en el botón Aceptar.. 17 Abre el cuadro Propiedades del control que has creado con el icono . Observa como se ha abierto una nueva sección Pie de poblacion.. en el menú contextual para entrar en la ventana 3 Despliega el Botón de Office . 2 Selecciona la opción Diseño de informe.Objetivo. 10 Cierra el cuadro.accdb que se encuentra en la carpeta Mis ejercicios. 4 Escribe Alumnos por poblacion. Abrir la base de datos Clases.. 16 En esta sección crea un control cuadro de texto.

Ejercicio 1: Concesionario 1 Abrir la base de datos Concesionario de la carpeta Mis ejercicios. 23 Cierra el informe guardando los cambios. e imprimirlo.. 3 Crear un informe para imprimir los registros de la tabla Coches vendidos agrupados por Marca y ordenados por Modelo sacando de cada marca la cantidad de coches vendidos. e imprimirlo. Los informes Ejercicio 1: Concesionario Apartado 2: . 19 En la propiedad Suma continua deja el valor No. 18 En la pestaña Datos en la propiedad Origen del control escribe = Cuenta([Codigo alumnado]). ábrelo para realizar los ejercicios planteados a continuación. Ejercicios Unidad 12. Aquí te lo explicamos. No queremos que siga sumando cuando cambia de grupo. 20 Selecciona el control así definido y crea otro copiándolo. Los informes Si no tienes abierto Access 2007. 22 Hacer clic sobre la opción Vista preliminar en el Botón de Office → Imprimir para ver el resultado. (Lo seleccionas. Si no tienes muy claro las operaciones a realizar en este ejercicio. Ayuda Ejercicios Unidad 12. Ctrl + C. Ctrl + V y mueve el nuevo a la derecha del primero) para que no se solapen) 21 En la propiedad Suma continua del nuevo control elige el valor Sobre todo. 2 Crear un informe para obtener una lista de los Clientes ordenados por Apellidos de tal forma que se pueda archivar los clientes de cada población en un archivador distinto. 4 Crear un informe para imprimir los registros de la tabla Revisiones. Este control me va decir cuántos alumnos llevo listados hasta ahora.

marcamos la casilla Modificar el diseño del informe. 14 Escribir como título Clientes por poblacion. 13 Hacer clic sobre el botón Siguiente. 12 Elegir el estilo del formulario que más te guste. 18 Selecciona con una sección de pie para mostrar un pie de grupo. 8 Desplegar el primer cuadro combinado y elegir Apellidos para que los registros aparezcan ordenados por apellidos. 2 Elegir la tabla Clientes como origen del informe. 19 Selecciona también la opción Mantener todo el grupo junto en una página para que hasta que no termine la sección (el pie de grupo) no salte de página. 15 Hacer clic sobre el botón Finalizar. 5 Hacer clic sobre el campo Poblacion para seleccionarlo. 1 Haz clic en el botón Asistente para informes de la pestaña Crear. vamos a añadir el salto de página. 10 Dejar activada la opción En pasos como distribución del informe. además se deberán imprimir los clientes de poblaciones distintas en hojas distintas. 16 Hacer clic sobre el botón de la pestaña Diseño. 4 Hacer clic sobre el botón Siguiente para ir al siguiente paso del asistente. 11 Haz clic sobre el botón Siguiente. 3Hacer clic sobre el botón para añadir todos los campos al informe. 6 Hacer clic sobre el botón para añadir esa agrupación. Queremos que salte después de terminar un grupo. 17 Haz clic en el vínculo Más para acceder a todas las opciones de la agrupación. Como tenemos que rectificar el diseño porque queremos que salte de página al finalizar cada población. luego esto lo indicaremos en el pie de grupo. Una vez en la ventana Diseño de informe. 7 Hacer clic sobre el botón Siguiente para ir al siguiente paso del asistente.Para que pueda archivar los clientes de cada población en archivadores distintos tengo que obtener un listado agrupado por población (dentro de la población ordenar los clientes por apellidos). . 9 Haz clic sobre el botón Siguiente.

20 Inserta en el pie creado un control Salto de línea 21 Hacer clic sobre la opción Vista preliminar en el Botón de Office → Imprimir para ver el resultado. 3 Hacer clic sobre el botón para añadir todos los campos al informe. 18 Hacer clic sobre el botón Siguiente. 22 Hacer clic sobre el botón Cerrar para salir de la vista preliminar 23 Cerrar el informe guardando los cambios. 14 Haz clic sobre el botón Siguiente. 13 Haz clic sobre el botón Aceptar para volver al asistente. 15 Dejar activada la opción En pasos como distribución del informe. 12 En la columna Suma marcar la casilla correspondiente al campo Precio para que se calcule la suma de los importes de una misma marca. 10 Desplegar el primer cuadro combinado y elegir Modelo para que los registros aparezcan ordenados por modelo dentro de la misma marca. 9 Hacer clic sobre el botón Siguiente para ir al siguiente paso del asistente. 2 Elegir la tabla Coches vendidos como origen del informe. 7 Hacer clic sobre el campo marca para seleccionarlo. Como queremos añadir una línea de totales. Apartado 3: 1 Haz clic en el botón Asistente para informes de la pestaña Crear.. 17 Elegir el estilo del formulario que más te guste. 4 Hacer clic sobre el botón Siguiente para ir al siguiente paso del asistente.. 6 Hacer clic sobre el botón para quitar esa agrupación. Observa que cambia de página cuando termina una población. 11 Hacer clic sobre el botón Opciones de resumen para añadir los totales. 16 Haz clic sobre el botón Siguiente. 5 Si aparece adrupado por Codigo de Cliente. 8 Hacer clic sobre el botón para añadir esa agrupación. . haz clic sbre él para seleccionarlo.

Para mejorar el diseño puedes añadir una etiqueta delante del nuevo campo con el contenido Nº de coches vendidos. Como tenemos que rectificar el diseño porque queremos añadir la cantidad de coches vendidos por marca.. 28 Hacer clic sobre la opción Vista preliminar en el Botón de Office → Imprimir para ver el resultado. 27 En la pestaña Formato. cambia =suma([precio]) por =cuenta([matricula]) para que este control cuente las matrículas (es lo mismo contar matrículas que coches). cambia el de Moneda por Número general. 22 Pulsar Ctrl + C para copiarlo. Mantenerlo seleccionado. Si en los importes aparecen almohadillas en vez del precio. quedará seleccionado.. 21 Hacer clic sobre el control correspondiente a la suma de importes. haz más grandes las cajas de texto que los contienen. Aquí lo que puedes hacer es practicar desplazando los controles y alineándolos. 25 Abrir el cuadro Propiedades con el botón (si no lo tienes abierto). 26 En la propiedad Origen del control. vamos a añadir el control. Observa que ahora tienes los dos totales. 29 Hacer clic sobre el botón Cerrar para salir de la vista preliminar 30 Cerrar el informe guardando los cambios. en la propiedad Formato. Apartado 4: Para realizar este ejercicio tienes que seguir los mismos pasos que en los apartados anteriores pero sin definir agrupaciones ni ordenaciones.19 Escribir como título Coches por marca.. 20 Hacer clic sobre el botón Finalizar. En el pie de grupo correspondiente aparece el total que incluimos con el asistente (el que calcula la suma de los importes). Deben aparecer las propiedades del nuevo control. marcamos la casilla Modificar el diseño del informe. sino haz clic sobre el control para seleccionarlo. Una vez en la ventana Diseño de informe.. Ejercicio 2: Clínica . Vamos a aprovechar este control para crear el nuevo. Aparece un nuevo control. 24 Arrástrarlo hasta donde quieres que se quede en el informe. 23 Pulsar Ctrl + V para pegarlo.

5 Hacer clic sobre el campo Apellidos de Pacientes para seleccionarlo. 9 Hacer clic sobre el campo Apellidos de Medicos para seleccionarlo.1 Abrir la base de datos Clinica de la carpeta Mis ejercicios. Si no tienes muy claro las operaciones a realizar en este ejercicio. Los informes Ejercicio 2: Clínica Apartado 2: 1 Antes de empezar a crear el informe crearemos la consulta Ingresos con paciente y medico para tener cada ingreso con los datos del paciente correspondiente y con los datos del médico correspondiente para luego utilizarla como origen del informe. Aquí te lo explicamos Ayuda Ejercicios Unidad 12. 14 Hacer clic sobre el botón Siguiente. 10 Hacer clic sobre el botón para añadirlo a la lista de campos del informe. 3 Hacer clic sobre el campo Fecha ingreso para seleccionarlo. 2 Elegir la consulta Ingresos con paciente y medico como origen del informe. 4 Hacer clic sobre el botón para añadirlo a la lista de campos del informe. 1 Haz clic en el botón Asistente para informes de la pestaña Crear. 8 Hacer clic sobre el botón para añadirlo a la lista de campos del informe. 13 Hacer clic sobre el botón Siguiente para ir al siguiente paso del asistente. 6 Hacer clic sobre el botón para añadirlo a la lista de campos del informe. 2 Crear un informe para imprimir Apellidos y nombre del paciente así como su fecha de ingreso y los apellidos del médico asignado. 11 Hacer clic sobre el botón Siguiente. 12 Hacer clic sobre el botón Siguiente para ir al siguiente paso del asistente. 7 Hacer clic sobre el campo Nombre de Pacientes para seleccionarlo. Después podemos empezar la creación del informe. . Si tienes algún problema deberías repasar el tema 7.

. marcar la casilla Modificar el diseño del informe. 18 Hacer clic sobre el botón Siguiente. 17 Elegir el estilo del formulario que más te guste. 21 Hacer clic sobre la opción Vista preliminar en el Botón de Office → Imprimir para ver el resultado. 20 Hacer clic sobre el botón Finalizar.15 Elige la opción En columnas como distribución del informe. 22 Hacer clic sobre el botón Cerrar para salir de la vista preliminar 23 Cerrar el informe guardando los cambios. 19 Escribir como título Ingresos con paciente y medico. 16 Haz clic sobre el botón Siguiente. puedes practicar cambiando los encabezados de las columnas y el formato de los controles. Una vez en la ventana Diseño de informe. Como tienes que rectificar el diseño para practicar.